summaryrefslogtreecommitdiffstats
path: root/meta/packages/gnome/libart-lgpl_2.3.16.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/gnome/libart-lgpl_2.3.16.bb')
-rw-r--r--meta/packages/gnome/libart-lgpl_2.3.16.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/packages/gnome/libart-lgpl_2.3.16.bb b/meta/packages/gnome/libart-lgpl_2.3.16.bb
new file mode 100644
index 0000000000..8028c8ef3f
--- /dev/null
+++ b/meta/packages/gnome/libart-lgpl_2.3.16.bb
@@ -0,0 +1,30 @@
1DESCRIPTION = "Library of functions for 2D graphics"
2SECTION = "x11/gnome"
3LICENSE = "LGPL"
4PR = "r2"
5ART_CONFIG = "${HOST_ARCH}/art_config.h"
6
7# can't use gnome.oeclass due to _ in filename
8SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/libart_lgpl/2.3/libart_lgpl-${PV}.tar.bz2 \
9 file://${ART_CONFIG} \
10 file://Makefile.am.patch;patch=1"
11
12inherit autotools pkgconfig
13
14DEPENDS = ""
15
16FILES_${PN} = "${libdir}/*.so.*"
17FILES_${PN}-dev += "${bindir}/libart2-config"
18
19S = "${WORKDIR}/libart_lgpl-${PV}"
20
21do_configure_prepend() {
22 cp ${WORKDIR}/${ART_CONFIG} ${S}/art_config.h
23}
24
25EXTRA_OECONF = "--disable-gtk-doc"
26
27do_stage() {
28 autotools_stage_includes
29 oe_libinstall -a -so libart_lgpl_2 ${STAGING_LIBDIR}
30}