summaryrefslogtreecommitdiffstats
path: root/meta/packages/glibc/glibc_csl-2005q3-2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/glibc/glibc_csl-2005q3-2.bb')
-rw-r--r--meta/packages/glibc/glibc_csl-2005q3-2.bb89
1 files changed, 0 insertions, 89 deletions
diff --git a/meta/packages/glibc/glibc_csl-2005q3-2.bb b/meta/packages/glibc/glibc_csl-2005q3-2.bb
deleted file mode 100644
index b1ea27dec5..0000000000
--- a/meta/packages/glibc/glibc_csl-2005q3-2.bb
+++ /dev/null
@@ -1,89 +0,0 @@
1require glibc.inc
2
3# DEFAULT_PREFERENCE = "-1"
4PV = "2.3.6+csl-arm-2005q3-2"
5PR = "r11"
6
7# the -isystem in bitbake.conf screws up glibc do_stage
8BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}"
9TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${includedir}"
10
11GLIBC_ADDONS ?= "nptl,libidn"
12
13GLIBC_BROKEN_LOCALES = "sid_ET tr_TR mn_MN gez_ET bn_BD gez_ER te_IN"
14
15#
16# For now, we will skip building of a gcc package if it is a uclibc one
17# and our build is not a uclibc one, and we skip a glibc one if our build
18# is a uclibc build.
19#
20# See the note in gcc/gcc_3.4.0.oe
21#
22
23python __anonymous () {
24 import bb, re
25 uc_os = (re.match('.*uclibc$', bb.data.getVar('TARGET_OS', d, 1)) != None)
26 if uc_os:
27 raise bb.parse.SkipPackage("incompatible with target %s" %
28 bb.data.getVar('TARGET_OS', d, 1))
29}
30
31SRC_URI = "http://www.codesourcery.com/public/gnu_toolchain/arm-none-linux-gnueabi/arm-2005q3-2-arm-none-linux-gnueabi.src.tar.bz2 \
32 file://nptl-crosscompile-2.3.6.patch;patch=1 \
33 file://etc/ld.so.conf \
34 file://generate-supported.mk \
35 "
36
37do_unpack2() {
38 cd ${WORKDIR}
39 tar -xvjf ./arm-2005q3-2-arm-none-linux-gnueabi/glibc-2005q3-2.tar.bz2
40 rm -rf ./arm-2005q3-2-arm-none-linux-gnueabi
41}
42
43addtask unpack2 after do_unpack before do_patch
44
45S = "${WORKDIR}/glibc-2.3.5pre"
46B = "${WORKDIR}/build-${TARGET_SYS}"
47
48EXTRA_OECONF = "--without-cvs --disable-profile --disable-debug --without-gd \
49 --enable-clocale=gnu \
50 --enable-add-ons \
51 --with-headers=${STAGING_INCDIR} \
52 --without-selinux \
53 ${GLIBC_EXTRA_OECONF}"
54
55EXTRA_OECONF += "${@get_glibc_fpu_setting(bb, d)}"
56
57do_configure () {
58# override this function to avoid the autoconf/automake/aclocal/autoheader
59# calls for now
60# don't pass CPPFLAGS into configure, since it upsets the kernel-headers
61# version check and doesn't really help with anything
62 if [ -z "`which rpcgen`" ]; then
63 echo "rpcgen not found. Install glibc-devel."
64 exit 1
65 fi
66 (cd ${S} && gnu-configize) || die "failure in running gnu-configize"
67 CPPFLAGS="" oe_runconf
68}
69
70rpcsvc = "bootparam_prot.x nlm_prot.x rstat.x \
71 yppasswd.x klm_prot.x rex.x sm_inter.x mount.x \
72 rusers.x spray.x nfs_prot.x rquota.x key_prot.x"
73
74do_compile () {
75 # -Wl,-rpath-link <staging>/lib in LDFLAGS can cause breakage if another glibc is in staging
76 unset LDFLAGS
77 base_do_compile
78 (
79 cd ${S}/sunrpc/rpcsvc
80 for r in ${rpcsvc}; do
81 h=`echo $r|sed -e's,\.x$,.h,'`
82 rpcgen -h $r -o $h || oewarn "unable to generate header for $r"
83 done
84 )
85}
86
87require glibc-stage.inc
88
89require glibc-package.inc