summaryrefslogtreecommitdiffstats
path: root/meta/packages/glibc/glibc_2.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/glibc/glibc_2.9.bb')
-rw-r--r--meta/packages/glibc/glibc_2.9.bb16
1 files changed, 8 insertions, 8 deletions
diff --git a/meta/packages/glibc/glibc_2.9.bb b/meta/packages/glibc/glibc_2.9.bb
index d56e42fdf8..24b07163e1 100644
--- a/meta/packages/glibc/glibc_2.9.bb
+++ b/meta/packages/glibc/glibc_2.9.bb
@@ -5,7 +5,7 @@ ARM_INSTRUCTION_SET = "arm"
5PACKAGES_DYNAMIC = "libc6*" 5PACKAGES_DYNAMIC = "libc6*"
6RPROVIDES_${PN}-dev = "libc6-dev virtual-libc-dev" 6RPROVIDES_${PN}-dev = "libc6-dev virtual-libc-dev"
7 7
8PR = "r0" 8PR = "r1"
9 9
10# the -isystem in bitbake.conf screws up glibc do_stage 10# the -isystem in bitbake.conf screws up glibc do_stage
11BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}" 11BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}"
@@ -42,8 +42,9 @@ RDEPENDS_${PN}-dev = "linux-libc-headers-dev"
42# file://arm-ioperm.patch;patch=1;pnum=0 \ 42# file://arm-ioperm.patch;patch=1;pnum=0 \
43# file://ldd.patch;patch=1;pnum=0 \ 43# file://ldd.patch;patch=1;pnum=0 \
44SRC_URI = "ftp://ftp.gnu.org/pub/gnu/glibc/glibc-${PV}.tar.bz2 \ 44SRC_URI = "ftp://ftp.gnu.org/pub/gnu/glibc/glibc-${PV}.tar.bz2 \
45 ftp://ftp.gnu.org/pub/gnu/glibc/glibc-ports-2.7.tar.bz2 \ 45 ftp://ftp.gnu.org/pub/gnu/glibc/glibc-ports-${PV}.tar.bz2 \
46 ftp://ftp.gnu.org/pub/gnu/glibc/glibc-libidn-${PV}.tar.bz2 \ 46 ftp://ftp.gnu.org/pub/gnu/glibc/glibc-libidn-${PV}.tar.bz2 \
47 file://nscd-init.patch;patch=1;pnum=0 \
47 file://arm-memcpy.patch;patch=1 \ 48 file://arm-memcpy.patch;patch=1 \
48 file://arm-longlong.patch;patch=1 \ 49 file://arm-longlong.patch;patch=1 \
49 file://fhs-linux-paths.patch;patch=1 \ 50 file://fhs-linux-paths.patch;patch=1 \
@@ -53,9 +54,6 @@ SRC_URI = "ftp://ftp.gnu.org/pub/gnu/glibc/glibc-${PV}.tar.bz2 \
53 file://glibc-check_pf.patch;patch=1;pnum=0 \ 54 file://glibc-check_pf.patch;patch=1;pnum=0 \
54 file://ldd-unbash.patch;patch=1 \ 55 file://ldd-unbash.patch;patch=1 \
55 file://glibc-arm-IO-acquire-lock-fix.diff;patch=1 \ 56 file://glibc-arm-IO-acquire-lock-fix.diff;patch=1 \
56 file://local-args6.diff;patch=1 \
57 file://arm-check-pf.patch;patch=1 \
58 file://arm-lowlevellock-include-tls.patch;patch=1 \
59 file://generic-bits_select.h \ 57 file://generic-bits_select.h \
60 file://generic-bits_types.h \ 58 file://generic-bits_types.h \
61 file://generic-bits_typesizes.h \ 59 file://generic-bits_typesizes.h \
@@ -64,10 +62,10 @@ SRC_URI = "ftp://ftp.gnu.org/pub/gnu/glibc/glibc-${PV}.tar.bz2 \
64 file://generate-supported.mk \ 62 file://generate-supported.mk \
65 file://march-i686.patch;patch=1;pnum=0 \ 63 file://march-i686.patch;patch=1;pnum=0 \
66 file://tls_i486.patch;patch=1 \ 64 file://tls_i486.patch;patch=1 \
67 file://glibc-arm-no-asm-page.patch;patch=1 \ 65 file://rulesfix.patch;patch=1 \
66 file://glibc-2.9-use-_begin.patch;patch=1 \
68 " 67 "
69 68
70
71# Build fails on sh3 and sh4 without additional patches 69# Build fails on sh3 and sh4 without additional patches
72SRC_URI_append_sh3 = " file://no-z-defs.patch;patch=1" 70SRC_URI_append_sh3 = " file://no-z-defs.patch;patch=1"
73SRC_URI_append_sh4 = " file://no-z-defs.patch;patch=1" 71SRC_URI_append_sh4 = " file://no-z-defs.patch;patch=1"
@@ -90,7 +88,7 @@ EXTRA_OECONF += "${@get_glibc_fpu_setting(bb, d)}"
90 88
91do_munge() { 89do_munge() {
92 # Integrate ports and libidn into tree 90 # Integrate ports and libidn into tree
93 mv ${WORKDIR}/glibc-ports-2.7 ${S}/ports 91 mv ${WORKDIR}/glibc-ports-${PV} ${S}/ports
94 mv ${WORKDIR}/glibc-libidn-${PV} ${S}/libidn 92 mv ${WORKDIR}/glibc-libidn-${PV} ${S}/libidn
95 93
96 # Ports isn't really working... Fix it 94 # Ports isn't really working... Fix it
@@ -124,6 +122,8 @@ addtask munge before do_patch after do_unpack
124 122
125 123
126do_configure () { 124do_configure () {
125# /var/db was not included to FHS
126 sed -i s:/var/db/nscd:/var/run/nscd: ${S}/nscd/nscd.h
127# override this function to avoid the autoconf/automake/aclocal/autoheader 127# override this function to avoid the autoconf/automake/aclocal/autoheader
128# calls for now 128# calls for now
129# don't pass CPPFLAGS into configure, since it upsets the kernel-headers 129# don't pass CPPFLAGS into configure, since it upsets the kernel-headers