diff options
Diffstat (limited to 'meta/packages/glibc/glibc_2.5.bb')
-rw-r--r-- | meta/packages/glibc/glibc_2.5.bb | 148 |
1 files changed, 0 insertions, 148 deletions
diff --git a/meta/packages/glibc/glibc_2.5.bb b/meta/packages/glibc/glibc_2.5.bb deleted file mode 100644 index a63b678949..0000000000 --- a/meta/packages/glibc/glibc_2.5.bb +++ /dev/null | |||
@@ -1,148 +0,0 @@ | |||
1 | require glibc.inc | ||
2 | |||
3 | PR = "r8" | ||
4 | |||
5 | # the -isystem in bitbake.conf screws up glibc do_stage | ||
6 | BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}" | ||
7 | TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${includedir}" | ||
8 | |||
9 | FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/glibc-2.4" | ||
10 | |||
11 | GLIBC_ADDONS ?= "ports,nptl,libidn" | ||
12 | |||
13 | GLIBC_BROKEN_LOCALES = "sid_ET tr_TR mn_MN gez_ET gez_ER bn_BD te_IN" | ||
14 | |||
15 | # | ||
16 | # For now, we will skip building of a gcc package if it is a uclibc one | ||
17 | # and our build is not a uclibc one, and we skip a glibc one if our build | ||
18 | # is a uclibc build. | ||
19 | # | ||
20 | # See the note in gcc/gcc_3.4.0.oe | ||
21 | # | ||
22 | |||
23 | python __anonymous () { | ||
24 | import bb, re | ||
25 | uc_os = (re.match('.*uclibc$', bb.data.getVar('TARGET_OS', d, 1)) != None) | ||
26 | if uc_os: | ||
27 | raise bb.parse.SkipPackage("incompatible with target %s" % | ||
28 | bb.data.getVar('TARGET_OS', d, 1)) | ||
29 | } | ||
30 | |||
31 | # file://noinfo.patch;patch=1 | ||
32 | # file://ldconfig.patch;patch=1;pnum=0 | ||
33 | # file://arm-machine-gmon.patch;patch=1;pnum=0 \ | ||
34 | # \ | ||
35 | # file://arm-ioperm.patch;patch=1;pnum=0 \ | ||
36 | # file://ldd.patch;patch=1;pnum=0 \ | ||
37 | SRC_URI = "ftp://ftp.gnu.org/pub/gnu/glibc/glibc-${PV}.tar.bz2 \ | ||
38 | ftp://ftp.gnu.org/pub/gnu/glibc/glibc-ports-${PV}.tar.bz2 \ | ||
39 | ftp://ftp.gnu.org/pub/gnu/glibc/glibc-libidn-${PV}.tar.bz2 \ | ||
40 | file://arm-memcpy.patch;patch=1 \ | ||
41 | file://arm-longlong.patch;patch=1 \ | ||
42 | file://fhs-linux-paths.patch;patch=1 \ | ||
43 | file://dl-cache-libcmp.patch;patch=1 \ | ||
44 | file://nptl-crosscompile.patch;patch=1 \ | ||
45 | file://glibc-check_pf.patch;patch=1;pnum=0 \ | ||
46 | # file://glibc-2.4-compile.patch;patch=1 \ | ||
47 | # file://glibc-2.4-openat-3.patch;patch=1 \ | ||
48 | # file://fixup-aeabi-syscalls.patch;patch=1 \ | ||
49 | file://zecke-sane-readelf.patch;patch=1 \ | ||
50 | file://eabi_kernel_version_hack.patch;patch=1 \ | ||
51 | file://glibc-2.6.1-use-short-for-fnstsw.patch;patch=1 \ | ||
52 | file://generic-bits_select.h \ | ||
53 | file://generic-bits_types.h \ | ||
54 | file://generic-bits_typesizes.h \ | ||
55 | file://generic-bits_time.h \ | ||
56 | file://etc/ld.so.conf \ | ||
57 | file://generate-supported.mk \ | ||
58 | file://glibc-arm-no-procinfo_h.patch;patch=1 \ | ||
59 | file://glibc-include-fixed.patch;patch=1;pnum=0" | ||
60 | |||
61 | |||
62 | # Build fails on sh3 and sh4 without additional patches | ||
63 | SRC_URI_append_sh3 = " file://no-z-defs.patch;patch=1" | ||
64 | SRC_URI_append_sh4 = " file://no-z-defs.patch;patch=1" | ||
65 | |||
66 | SRC_URI_append_powerpc = " file://powerpc-sqrt-hack.diff;patch=1" | ||
67 | |||
68 | S = "${WORKDIR}/glibc-${PV}" | ||
69 | B = "${WORKDIR}/build-${TARGET_SYS}" | ||
70 | |||
71 | EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \ | ||
72 | --without-cvs --disable-profile --disable-debug --without-gd \ | ||
73 | --enable-clocale=gnu \ | ||
74 | --enable-add-ons=${GLIBC_ADDONS} \ | ||
75 | --with-headers=${STAGING_INCDIR} \ | ||
76 | --without-selinux \ | ||
77 | ${GLIBC_EXTRA_OECONF}" | ||
78 | |||
79 | EXTRA_OECONF += "${@get_glibc_fpu_setting(bb, d)}" | ||
80 | |||
81 | do_munge() { | ||
82 | # Integrate ports and libidn into tree | ||
83 | mv ${WORKDIR}/glibc-ports-${PV} ${S}/ports | ||
84 | mv ${WORKDIR}/glibc-libidn-${PV} ${S}/libidn | ||
85 | |||
86 | # Ports isn't really working... Fix it | ||
87 | # Some of this is rather dirty, but it seems to be the only | ||
88 | # quick way to get this cruft to compile | ||
89 | rm -rf ${S}/ports/sysdeps/unix/sysv/linux/arm/linuxthreads | ||
90 | ln -s nptl ${S}/ports/sysdeps/unix/sysv/linux/arm/linuxthreads | ||
91 | cp ${S}/nptl/sysdeps/pthread/bits/sigthread.h ${S}/ports/sysdeps/unix/sysv/linux/arm/bits/ | ||
92 | cp ${S}/sysdeps/unix/sysv/linux/i386/bits/wchar.h ${S}/ports/sysdeps/unix/sysv/linux/arm/bits/ | ||
93 | cp ${S}/sysdeps/wordsize-32/bits/wordsize.h ${S}/ports/sysdeps/unix/sysv/linux/arm/bits/ | ||
94 | cp ${WORKDIR}/generic-bits_select.h ${S}/ports/sysdeps/unix/sysv/linux/arm/bits/select.h | ||
95 | cp ${WORKDIR}/generic-bits_types.h ${S}/ports/sysdeps/unix/sysv/linux/arm/bits/types.h | ||
96 | cp ${WORKDIR}/generic-bits_typesizes.h ${S}/ports/sysdeps/unix/sysv/linux/arm/bits/typesizes.h | ||
97 | cp ${WORKDIR}/generic-bits_time.h ${S}/ports/sysdeps/unix/sysv/linux/arm/bits/time.h | ||
98 | # Copy in generic stuff for not yet implemented headers | ||
99 | for i in ${S}/bits/*.h; do | ||
100 | F=`basename $i` | ||
101 | [ "$F" = "local_lim.h" ] && continue | ||
102 | [ "$F" = "errno.h" ] && continue | ||
103 | test -e ${S}/ports/sysdeps/unix/sysv/linux/arm/bits/$F || test -e ${S}/ports/sysdeps/arm/bits/$F || test -e ${S}/sysdeps/unix/sysv/linux/bits/$F || test -e ${S}/sysdeps/ieee754/bits/$F || cp $i ${S}/ports/sysdeps/unix/sysv/linux/arm/bits/ | ||
104 | done | ||
105 | # This is harmful; we need to get the one from nptl/sysdeps/pthreads | ||
106 | rm -f ${S}/ports/sysdeps/unix/sysv/linux/arm/bits/libc-lock.h | ||
107 | # Obsoleted by sysdeps/arm/{fpu,eabi}/bits/fenv.h | ||
108 | rm -f ${S}/ports/sysdeps/unix/sysv/linux/arm/bits/fenv.h | ||
109 | # Obsoleted by sysdeps/gnu/bits/utmp.h | ||
110 | rm -f ${S}/ports/sysdeps/unix/sysv/linux/arm/bits/utmp.h | ||
111 | } | ||
112 | |||
113 | addtask munge before do_patch after do_unpack | ||
114 | |||
115 | |||
116 | do_configure () { | ||
117 | # override this function to avoid the autoconf/automake/aclocal/autoheader | ||
118 | # calls for now | ||
119 | # don't pass CPPFLAGS into configure, since it upsets the kernel-headers | ||
120 | # version check and doesn't really help with anything | ||
121 | if [ -z "`which rpcgen`" ]; then | ||
122 | echo "rpcgen not found. Install glibc-devel." | ||
123 | exit 1 | ||
124 | fi | ||
125 | (cd ${S} && gnu-configize) || die "failure in running gnu-configize" | ||
126 | CPPFLAGS="" oe_runconf | ||
127 | } | ||
128 | |||
129 | rpcsvc = "bootparam_prot.x nlm_prot.x rstat.x \ | ||
130 | yppasswd.x klm_prot.x rex.x sm_inter.x mount.x \ | ||
131 | rusers.x spray.x nfs_prot.x rquota.x key_prot.x" | ||
132 | |||
133 | do_compile () { | ||
134 | # -Wl,-rpath-link <staging>/lib in LDFLAGS can cause breakage if another glibc is in staging | ||
135 | unset LDFLAGS | ||
136 | base_do_compile | ||
137 | ( | ||
138 | cd ${S}/sunrpc/rpcsvc | ||
139 | for r in ${rpcsvc}; do | ||
140 | h=`echo $r|sed -e's,\.x$,.h,'` | ||
141 | rpcgen -h $r -o $h || oewarn "unable to generate header for $r" | ||
142 | done | ||
143 | ) | ||
144 | } | ||
145 | |||
146 | require glibc-stage.inc | ||
147 | |||
148 | require glibc-package.inc | ||