summaryrefslogtreecommitdiffstats
path: root/meta/packages/glibc/glibc_2.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/glibc/glibc_2.4.bb')
-rw-r--r--meta/packages/glibc/glibc_2.4.bb24
1 files changed, 13 insertions, 11 deletions
diff --git a/meta/packages/glibc/glibc_2.4.bb b/meta/packages/glibc/glibc_2.4.bb
index faaf27ced3..bccdcc7da7 100644
--- a/meta/packages/glibc/glibc_2.4.bb
+++ b/meta/packages/glibc/glibc_2.4.bb
@@ -3,8 +3,13 @@ HOMEPAGE = "http://www.gnu.org/software/libc/libc.html"
3LICENSE = "LGPL" 3LICENSE = "LGPL"
4SECTION = "libs" 4SECTION = "libs"
5PRIORITY = "required" 5PRIORITY = "required"
6DEFAULT_PREFERENCE = "-1" 6# DEFAULT_PREFERENCE = "-1"
7PR = "r4" 7PR = "r10"
8
9# the -isystem in bitbake.conf screws up glibc do_stage
10BUILD_CPPFLAGS = "-I${STAGING_DIR}/${BUILD_SYS}/include"
11TARGET_CPPFLAGS = "-I${STAGING_DIR}/${TARGET_SYS}/include"
12
8 13
9FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/glibc-2.4" 14FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/glibc-2.4"
10 15
@@ -53,6 +58,7 @@ SRC_URI = "ftp://ftp.gnu.org/pub/gnu/glibc/glibc-2.4.tar.bz2 \
53 file://nptl-crosscompile.patch;patch=1 \ 58 file://nptl-crosscompile.patch;patch=1 \
54 file://glibc-2.4-compile.patch;patch=1 \ 59 file://glibc-2.4-compile.patch;patch=1 \
55 file://fixup-aeabi-syscalls.patch;patch=1 \ 60 file://fixup-aeabi-syscalls.patch;patch=1 \
61 file://zecke-sane-readelf.patch;patch=1 \
56 file://generic-bits_select.h \ 62 file://generic-bits_select.h \
57 file://generic-bits_types.h \ 63 file://generic-bits_types.h \
58 file://generic-bits_typesizes.h \ 64 file://generic-bits_typesizes.h \
@@ -60,6 +66,10 @@ SRC_URI = "ftp://ftp.gnu.org/pub/gnu/glibc/glibc-2.4.tar.bz2 \
60 file://etc/ld.so.conf \ 66 file://etc/ld.so.conf \
61 file://generate-supported.mk" 67 file://generate-supported.mk"
62 68
69# Build fails on sh3 and sh4 without additional patches
70SRC_URI_append_sh3 = " file://no-z-defs.patch;patch=1"
71SRC_URI_append_sh4 = " file://no-z-defs.patch;patch=1"
72
63S = "${WORKDIR}/glibc-2.4" 73S = "${WORKDIR}/glibc-2.4"
64B = "${WORKDIR}/build-${TARGET_SYS}" 74B = "${WORKDIR}/build-${TARGET_SYS}"
65 75
@@ -109,14 +119,6 @@ do_munge() {
109 rm -f ${S}/ports/sysdeps/unix/sysv/linux/arm/bits/fenv.h 119 rm -f ${S}/ports/sysdeps/unix/sysv/linux/arm/bits/fenv.h
110 # Obsoleted by sysdeps/gnu/bits/utmp.h 120 # Obsoleted by sysdeps/gnu/bits/utmp.h
111 rm -f ${S}/ports/sysdeps/unix/sysv/linux/arm/bits/utmp.h 121 rm -f ${S}/ports/sysdeps/unix/sysv/linux/arm/bits/utmp.h
112
113 # http://www.handhelds.org/hypermail/oe/51/5135.html
114 # Some files were moved around between directories on
115 # 2005-12-21, which means that any attempt to check out
116 # from CVS using a datestamp older than that will be doomed.
117 #
118 # This is a workaround for that problem.
119 rm -rf ${S}/bits
120} 122}
121 123
122addtask munge before do_patch after do_unpack 124addtask munge before do_patch after do_unpack
@@ -198,4 +200,4 @@ do_stage() {
198 echo 'GROUP ( libc.so.6 libc_nonshared.a )' > ${CROSS_DIR}/${TARGET_SYS}/lib/libc.so 200 echo 'GROUP ( libc.so.6 libc_nonshared.a )' > ${CROSS_DIR}/${TARGET_SYS}/lib/libc.so
199} 201}
200 202
201include glibc-package.bbclass 203require glibc-package.bbclass