summaryrefslogtreecommitdiffstats
path: root/meta/packages/glibc/glibc-initial_2.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/glibc/glibc-initial_2.5.bb')
-rw-r--r--meta/packages/glibc/glibc-initial_2.5.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta/packages/glibc/glibc-initial_2.5.bb b/meta/packages/glibc/glibc-initial_2.5.bb
new file mode 100644
index 0000000000..f13419a413
--- /dev/null
+++ b/meta/packages/glibc/glibc-initial_2.5.bb
@@ -0,0 +1,45 @@
1require glibc_${PV}.bb
2
3DEPENDS = "linux-libc-headers"
4PROVIDES = "virtual/${TARGET_PREFIX}libc-initial"
5FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/glibc-2.4', '${FILE_DIRNAME}/glibc', '${FILE_DIRNAME}/files', '${FILE_DIRNAME}' ], d)}"
6
7PACKAGES = ""
8
9do_configure () {
10 sed -ie 's,{ (exit 1); exit 1; }; },{ (exit 0); }; },g' ${S}/configure
11 chmod +x ${S}/configure
12 CC="${BUILD_CC}" CPP="${BUILD_CPP}" LD="${BUILD_LD}" ${S}/configure --host=${TARGET_SYS} --build=${BUILD_SYS} \
13 --without-cvs --disable-sanity-checks \
14 --with-headers=${CROSS_DIR}/${TARGET_SYS}/include \
15 --enable-hacker-mode
16 if grep -q GLIBC_2.3 ${S}/ChangeLog; then
17 # glibc-2.3.x passes cross options to $(CC) when generating errlist-compat.c, which fails without a real cross-compiler.
18 # Fortunately, we don't need errlist-compat.c, since we just need .h files,
19 # so work around this by creating a fake errlist-compat.c and satisfying its dependencies.
20 # Another workaround might be to tell configure to not use any cross options to $(CC).
21 # The real fix would be to get install-headers to not generate errlist-compat.c.
22 make sysdeps/gnu/errlist.c
23 mkdir -p stdio-common
24 touch stdio-common/errlist-compat.c
25 fi
26}
27
28do_compile () {
29 :
30}
31
32do_stage () {
33 oe_runmake cross-compiling=yes install_root=${CROSS_DIR}/${TARGET_SYS} prefix="" install-headers
34
35 # Two headers -- stubs.h and features.h -- aren't installed by install-headers,
36 # so do them by hand. We can tolerate an empty stubs.h for the moment.
37 # See e.g. http://gcc.gnu.org/ml/gcc/2002-01/msg00900.html
38 mkdir -p ${CROSS_DIR}/${TARGET_SYS}/include/gnu
39 touch ${CROSS_DIR}/${TARGET_SYS}/include/gnu/stubs.h
40 cp ${S}/include/features.h ${CROSS_DIR}/${TARGET_SYS}/include/features.h
41}
42
43do_install () {
44 :
45}