summaryrefslogtreecommitdiffstats
path: root/meta/packages/glibc/glibc-cvs/eabi-patch-1
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/glibc/glibc-cvs/eabi-patch-1')
-rw-r--r--meta/packages/glibc/glibc-cvs/eabi-patch-188
1 files changed, 88 insertions, 0 deletions
diff --git a/meta/packages/glibc/glibc-cvs/eabi-patch-1 b/meta/packages/glibc/glibc-cvs/eabi-patch-1
new file mode 100644
index 0000000000..9b1fd408da
--- /dev/null
+++ b/meta/packages/glibc/glibc-cvs/eabi-patch-1
@@ -0,0 +1,88 @@
1From libc-alpha-return-17227-listarch-libc-alpha=sources dot redhat dot com at sources dot redhat dot com Tue Mar 22 15:57:25 2005
2Return-Path: <libc-alpha-return-17227-listarch-libc-alpha=sources dot redhat dot com at sources dot redhat dot com>
3Delivered-To: listarch-libc-alpha at sources dot redhat dot com
4Received: (qmail 12343 invoked by alias); 22 Mar 2005 15:57:24 -0000
5Mailing-List: contact libc-alpha-help at sources dot redhat dot com; run by ezmlm
6Precedence: bulk
7List-Subscribe: <mailto:libc-alpha-subscribe at sources dot redhat dot com>
8List-Archive: <http://sources.redhat.com/ml/libc-alpha/>
9List-Post: <mailto:libc-alpha at sources dot redhat dot com>
10List-Help: <mailto:libc-alpha-help at sources dot redhat dot com>, <http://sources dot redhat dot com/ml/#faqs>
11Sender: libc-alpha-owner at sources dot redhat dot com
12Delivered-To: mailing list libc-alpha at sources dot redhat dot com
13Received: (qmail 12264 invoked from network); 22 Mar 2005 15:57:19 -0000
14Received: from unknown (HELO nevyn.them.org) (66.93.172.17)
15 by sourceware dot org with SMTP; 22 Mar 2005 15:57:19 -0000
16Received: from drow by nevyn.them.org with local (Exim 4.50 #1 (Debian))
17 id 1DDll5-0006ip-R3; Tue, 22 Mar 2005 10:57:31 -0500
18Date: Tue, 22 Mar 2005 10:57:31 -0500
19From: Daniel Jacobowitz <drow at false dot org>
20To: libc-alpha at sources dot redhat dot com
21Cc: Phil Blundell <pb at reciva dot com>
22Subject: Common bits for the ARM EABI port
23Message-ID: <20050322155731.GA25613@nevyn.them.org>
24Mail-Followup-To: libc-alpha at sources dot redhat dot com,
25 Phil Blundell <pb at reciva dot com>
26Mime-Version: 1.0
27Content-Type: text/plain; charset=us-ascii
28Content-Disposition: inline
29User-Agent: Mutt/1.5.6+20040907i
30
31The changes to common files for the ARM EABI port; search the new directory,
32use GLIBC_2.4 as a base version, and generate ld-linux.so.3 (so that old and
33new ABI libraries can be installed on the same system, in case someone needs
34to do that). Generic ARM changes coming up next.
35
36I noticed that the "configure: Regenerated" messages are often left out of
37glibc changelogs; should I skip them?
38
39--
40Daniel Jacobowitz
41CodeSourcery, LLC
42
432005-03-22 Daniel Jacobowitz <dan@codesourcery.com>
44
45 * configure.in: Add arm*-*-linux-gnueabi support. Remove
46 unused arm32 entry from $machine.
47 * configure: Regenerated.
48 * shlib-versions: Add arm*-*-linux-gnueabi.
49
50Index: glibc/configure.in
51===================================================================
52--- glibc.orig/configure.in 2005-03-18 17:10:34.000000000 -0500
53+++ glibc/configure.in 2005-03-21 10:04:41.000000000 -0500
54@@ -423,7 +423,12 @@ changequote(,)dnl
55 test -n "$base_machine" || case "$machine" in
56 a29k | am29000) base_machine=a29k machine=a29k ;;
57 alpha*) base_machine=alpha machine=alpha/$machine ;;
58-arm*) base_machine=arm machine=arm/arm32/$machine ;;
59+arm*) base_machine=arm
60+ case $config_os in
61+ linux-gnueabi) machine=arm/eabi/$machine ;;
62+ *) machine=arm/$machine ;;
63+ esac
64+ ;;
65 c3[012]) base_machine=cx0 machine=cx0/c30 ;;
66 c4[04]) base_machine=cx0 machine=cx0/c40 ;;
67 hppa*64*) base_machine=hppa machine=hppa/hppa64 ;;
68Index: glibc/shlib-versions
69===================================================================
70--- glibc.orig/shlib-versions 2005-02-13 21:53:05.000000000 -0500
71+++ glibc/shlib-versions 2005-03-21 10:06:54.000000000 -0500
72@@ -31,6 +31,7 @@ cris-.*-linux.* DEFAULT GLIBC_2.2
73 x86_64-.*-linux.* DEFAULT GLIBC_2.2.5
74 powerpc64-.*-linux.* DEFAULT GLIBC_2.3
75 .*-.*-gnu-gnu.* DEFAULT GLIBC_2.2.6
76+arm.*-.*-linux-gnueabi DEFAULT GLIBC_2.4
77
78 # Configuration WORDSIZE[32|64] Alternate configuration
79 # ------------- ---------- -----------------------
80@@ -80,6 +81,7 @@ i.86-.*-linux.* ld=ld-linux.so.2
81 sparc64-.*-linux.* ld=ld-linux.so.2 GLIBC_2.2
82 sparc.*-.*-linux.* ld=ld-linux.so.2
83 alpha.*-.*-linux.* ld=ld-linux.so.2
84+arm.*-.*-linux-gnueabi ld=ld-linux.so.3
85 arm.*-.*-linux.* ld=ld-linux.so.2
86 sh.*-.*-linux.* ld=ld-linux.so.2 GLIBC_2.2
87 ia64-.*-linux.* ld=ld-linux-ia64.so.2 GLIBC_2.2
88