diff options
Diffstat (limited to 'meta/packages/glibc/glibc-2.4/glibc-2.4-compile.patch')
-rw-r--r-- | meta/packages/glibc/glibc-2.4/glibc-2.4-compile.patch | 29 |
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/packages/glibc/glibc-2.4/glibc-2.4-compile.patch b/meta/packages/glibc/glibc-2.4/glibc-2.4-compile.patch new file mode 100644 index 0000000000..ea9f55ae7f --- /dev/null +++ b/meta/packages/glibc/glibc-2.4/glibc-2.4-compile.patch | |||
@@ -0,0 +1,29 @@ | |||
1 | --- glibc-2.4/csu/libc-start.c.ark 2006-03-13 03:07:15.000000000 +0100 | ||
2 | +++ glibc-2.4/csu/libc-start.c 2006-03-13 03:08:51.000000000 +0100 | ||
3 | @@ -59,6 +59,11 @@ | ||
4 | # define LIBC_START_MAIN BP_SYM (__libc_start_main) | ||
5 | #endif | ||
6 | |||
7 | +#ifdef SHARED | ||
8 | +#include <pthread-functions.h> | ||
9 | +extern struct pthread_functions __libc_pthread_functions; | ||
10 | +#endif | ||
11 | + | ||
12 | #ifdef MAIN_AUXVEC_ARG | ||
13 | /* main gets passed a pointer to the auxiliary. */ | ||
14 | # define MAIN_AUXVEC_DECL , void * | ||
15 | --- glibc-2.4/nscd/Makefile.ark 2006-03-13 14:05:47.000000000 +0100 | ||
16 | +++ glibc-2.4/nscd/Makefile 2006-03-13 14:06:12.000000000 +0100 | ||
17 | @@ -67,8 +67,10 @@ | ||
18 | # contains only the basic kernel interface headers, not something like | ||
19 | # libselinux. So the simplest thing is to presume that the standard | ||
20 | # system headers will be ok for this file. | ||
21 | -$(objpfx)nscd_stat.o: sysincludes = # nothing | ||
22 | -$(objpfx)selinux.o: sysincludes = # nothing | ||
23 | +# Except, of course, this breaks crosscompiling with kernel headers in | ||
24 | +# a nonstandard location... | ||
25 | +#$(objpfx)nscd_stat.o: sysincludes = # nothing | ||
26 | +#$(objpfx)selinux.o: sysincludes = # nothing | ||
27 | |||
28 | distribute := nscd.h nscd-client.h dbg_log.h \ | ||
29 | $(addsuffix .c, $(filter-out xmalloc,$(all-nscd-modules))) \ | ||