diff options
Diffstat (limited to 'meta/packages/glibc/glibc-2.4/dyn-ldconfig.patch')
-rw-r--r-- | meta/packages/glibc/glibc-2.4/dyn-ldconfig.patch | 62 |
1 files changed, 62 insertions, 0 deletions
diff --git a/meta/packages/glibc/glibc-2.4/dyn-ldconfig.patch b/meta/packages/glibc/glibc-2.4/dyn-ldconfig.patch new file mode 100644 index 0000000000..1041965d05 --- /dev/null +++ b/meta/packages/glibc/glibc-2.4/dyn-ldconfig.patch | |||
@@ -0,0 +1,62 @@ | |||
1 | --- elf/Makefile 13 Mar 2003 21:50:57 -0000 1.258 | ||
2 | +++ elf/Makefile 27 Mar 2003 20:36:07 -0000 | ||
3 | @@ -109,12 +109,13 @@ | ||
4 | |||
5 | ifeq (yes,$(use-ldconfig)) | ||
6 | ifeq (yes,$(build-shared)) | ||
7 | -others-static += ldconfig | ||
8 | +#others-static += ldconfig | ||
9 | others += ldconfig | ||
10 | install-rootsbin += ldconfig | ||
11 | |||
12 | ldconfig-modules := cache readlib xmalloc xstrdup chroot_canon | ||
13 | extra-objs += $(ldconfig-modules:=.o) | ||
14 | +CPPFLAGS-readlib.c = -DNOT_IN_libc=1 | ||
15 | |||
16 | # To find xmalloc.c and xstrdup.c | ||
17 | vpath %.c ../locale/programs | ||
18 | --- elf/ldconfig.c 13 Jan 2003 08:53:14 -0000 1.31 | ||
19 | +++ elf/ldconfig.c 27 Mar 2003 20:36:09 -0000 | ||
20 | @@ -149,6 +149,9 @@ | ||
21 | static int | ||
22 | is_hwcap_platform (const char *name) | ||
23 | { | ||
24 | +#if 1 | ||
25 | + return 0; | ||
26 | +#else | ||
27 | int hwcap_idx = _dl_string_hwcap (name); | ||
28 | |||
29 | if (hwcap_idx != -1 && ((1 << hwcap_idx) & hwcap_mask)) | ||
30 | @@ -164,6 +167,7 @@ | ||
31 | #endif | ||
32 | |||
33 | return 0; | ||
34 | +#endif | ||
35 | } | ||
36 | |||
37 | /* Get hwcap (including platform) encoding of path. */ | ||
38 | @@ -175,6 +179,7 @@ | ||
39 | uint64_t hwcap = 0; | ||
40 | uint64_t h; | ||
41 | |||
42 | +#if 0 | ||
43 | size_t len; | ||
44 | |||
45 | len = strlen (str); | ||
46 | @@ -210,6 +215,7 @@ | ||
47 | *ptr = '\0'; | ||
48 | } | ||
49 | |||
50 | +#endif | ||
51 | free (str); | ||
52 | return hwcap; | ||
53 | } | ||
54 | --- elf/Versions.old 2004-06-26 13:18:35.000000000 +0100 | ||
55 | +++ elf/Versions 2004-06-26 14:41:09.000000000 +0100 | ||
56 | @@ -54,5 +54,6 @@ | ||
57 | _dl_get_tls_static_info; _dl_allocate_tls_init; | ||
58 | _dl_tls_setup; _dl_rtld_di_serinfo; | ||
59 | _dl_make_stack_executable; | ||
60 | + _dl_cache_libcmp; | ||
61 | } | ||
62 | } | ||