summaryrefslogtreecommitdiffstats
path: root/meta/packages/glibc/glibc-2.10.1
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/glibc/glibc-2.10.1')
-rw-r--r--meta/packages/glibc/glibc-2.10.1/etc/ld.so.conf2
-rw-r--r--meta/packages/glibc/glibc-2.10.1/fhs-linux-paths.patch11
-rw-r--r--meta/packages/glibc/glibc-2.10.1/generate-supported.mk11
3 files changed, 24 insertions, 0 deletions
diff --git a/meta/packages/glibc/glibc-2.10.1/etc/ld.so.conf b/meta/packages/glibc/glibc-2.10.1/etc/ld.so.conf
new file mode 100644
index 0000000000..ddd777db2a
--- /dev/null
+++ b/meta/packages/glibc/glibc-2.10.1/etc/ld.so.conf
@@ -0,0 +1,2 @@
1/usr/local/lib
2include /etc/ld.so.conf.d/*
diff --git a/meta/packages/glibc/glibc-2.10.1/fhs-linux-paths.patch b/meta/packages/glibc/glibc-2.10.1/fhs-linux-paths.patch
new file mode 100644
index 0000000000..1f32f6d7f2
--- /dev/null
+++ b/meta/packages/glibc/glibc-2.10.1/fhs-linux-paths.patch
@@ -0,0 +1,11 @@
1--- glibc-2.1.1/sysdeps/unix/sysv/linux/paths.h~ Thu May 27 13:16:33 1999
2+++ glibc-2.1.1/sysdeps/unix/sysv/linux/paths.h Thu May 27 13:17:55 1999
3@@ -71,7 +71,7 @@
4 /* Provide trailing slash, since mostly used for building pathnames. */
5 #define _PATH_DEV "/dev/"
6 #define _PATH_TMP "/tmp/"
7-#define _PATH_VARDB "/var/db/"
8+#define _PATH_VARDB "/var/lib/misc/"
9 #define _PATH_VARRUN "/var/run/"
10 #define _PATH_VARTMP "/var/tmp/"
11
diff --git a/meta/packages/glibc/glibc-2.10.1/generate-supported.mk b/meta/packages/glibc/glibc-2.10.1/generate-supported.mk
new file mode 100644
index 0000000000..d2a28c2dc6
--- /dev/null
+++ b/meta/packages/glibc/glibc-2.10.1/generate-supported.mk
@@ -0,0 +1,11 @@
1#!/usr/bin/make
2
3include $(IN)
4
5all:
6 rm -f $(OUT)
7 touch $(OUT)
8 for locale in $(SUPPORTED-LOCALES); do \
9 [ $$locale = true ] && continue; \
10 echo $$locale | sed 's,/, ,' >> $(OUT); \
11 done