diff options
Diffstat (limited to 'meta/packages/glib-2.0/glib-2.0_2.10.3.bb')
-rw-r--r-- | meta/packages/glib-2.0/glib-2.0_2.10.3.bb | 48 |
1 files changed, 48 insertions, 0 deletions
diff --git a/meta/packages/glib-2.0/glib-2.0_2.10.3.bb b/meta/packages/glib-2.0/glib-2.0_2.10.3.bb new file mode 100644 index 0000000000..df0f3bd82c --- /dev/null +++ b/meta/packages/glib-2.0/glib-2.0_2.10.3.bb | |||
@@ -0,0 +1,48 @@ | |||
1 | DESCRIPTION = "GLib is a general-purpose utility library, \ | ||
2 | which provides many useful data types, macros, \ | ||
3 | type conversions, string utilities, file utilities, a main \ | ||
4 | loop abstraction, and so on. It works on many \ | ||
5 | UNIX-like platforms, Windows, OS/2 and BeOS." | ||
6 | LICENSE = "LGPL" | ||
7 | SECTION = "libs" | ||
8 | PRIORITY = "optional" | ||
9 | DEPENDS += "glib-2.0-native gtk-doc" | ||
10 | DEPENDS += "virtual/libiconv virtual/libintl" | ||
11 | PACKAGES =+ "glib-2.0-utils " | ||
12 | PR = "r3" | ||
13 | |||
14 | LEAD_SONAME = "libglib-2.0.*" | ||
15 | FILES_glib-2.0-utils = "${bindir}/*" | ||
16 | |||
17 | EXTRA_OECONF = "--disable-debug" | ||
18 | |||
19 | SRC_URI = "http://download.gnome.org/sources/glib/2.10//glib-${PV}.tar.bz2 \ | ||
20 | file://atomic_fix.patch;patch=1 \ | ||
21 | file://glibconfig-sysdefs.h" | ||
22 | |||
23 | S = "${WORKDIR}/glib-${PV}" | ||
24 | |||
25 | inherit autotools pkgconfig gettext | ||
26 | |||
27 | python () { | ||
28 | if bb.data.getVar("USE_NLS", d, 1) == "no": | ||
29 | raise bb.parse.SkipPackage("${PN} requires native language support.") | ||
30 | } | ||
31 | |||
32 | acpaths = "" | ||
33 | do_configure_prepend () { | ||
34 | install -m 0644 ${WORKDIR}/glibconfig-sysdefs.h . | ||
35 | } | ||
36 | |||
37 | do_stage () { | ||
38 | oe_libinstall -so -C glib libglib-2.0 ${STAGING_LIBDIR} | ||
39 | oe_libinstall -so -C gmodule libgmodule-2.0 ${STAGING_LIBDIR} | ||
40 | oe_libinstall -so -C gthread libgthread-2.0 ${STAGING_LIBDIR} | ||
41 | oe_libinstall -so -C gobject libgobject-2.0 ${STAGING_LIBDIR} | ||
42 | autotools_stage_includes | ||
43 | install -d ${STAGING_INCDIR}/glib-2.0/glib | ||
44 | install -m 0755 ${S}/glibconfig.h ${STAGING_INCDIR}/glib-2.0/glibconfig.h | ||
45 | install -d ${STAGING_DATADIR}/aclocal | ||
46 | install -m 0644 ${S}/m4macros/glib-2.0.m4 ${STAGING_DATADIR}/aclocal/glib-2.0.m4 | ||
47 | install -m 0644 ${S}/m4macros/glib-gettext.m4 ${STAGING_DATADIR}/aclocal/glib-gettext.m4 | ||
48 | } | ||