summaryrefslogtreecommitdiffstats
path: root/meta/packages/gettext/gettext_0.14.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/gettext/gettext_0.14.1.bb')
-rw-r--r--meta/packages/gettext/gettext_0.14.1.bb43
1 files changed, 0 insertions, 43 deletions
diff --git a/meta/packages/gettext/gettext_0.14.1.bb b/meta/packages/gettext/gettext_0.14.1.bb
deleted file mode 100644
index f5ccfa88f6..0000000000
--- a/meta/packages/gettext/gettext_0.14.1.bb
+++ /dev/null
@@ -1,43 +0,0 @@
1DESCRIPTION = "The GNU internationalization library."
2HOMEPAGE = "http://www.gnu.org/software/gettext/gettext.html"
3SECTION = "libs"
4LICENSE = "GPL"
5PR = "r11"
6PROVIDES = "virtual/libintl"
7
8SRC_URI = "${GNU_MIRROR}/gettext/gettext-${PV}.tar.gz \
9 file://gettext-vpath.patch;patch=1;pnum=1 \
10 file://fixchicken.patch;patch=1;pnum=1 \
11 file://linklib_from_0.17.patch;patch=1 \
12 file://getline.m4.patch;patch=1 \
13 file://disable_java.patch;patch=1"
14
15SRC_URI_append_linux-uclibc = " file://gettext-error_print_progname.patch;patch=1"
16SRC_URI_append_linux-uclibcgnueabi = " file://gettext-error_print_progname.patch;patch=1"
17
18PARALLEL_MAKE = ""
19
20inherit autotools
21
22EXTRA_OECONF += "--without-lisp"
23acpaths = '-I ${S}/autoconf-lib-link/m4/ \
24 -I ${S}/gettext-runtime/m4 \
25 -I ${S}/gettext-tools/m4'
26
27FILES_${PN} += "${libdir}/libgettextlib-${PV}.so ${libdir}/libgettextsrc-${PV}.so"
28
29do_configure_prepend() {
30 rm -f ${S}/config/m4/libtool.m4
31 install -m 0644 ${STAGING_DATADIR}/aclocal/libtool.m4 ${S}/config/m4/
32}
33
34do_stage () {
35 autotools_stage_all
36
37 # config.rpath is needed by some configure macros and needs to be autoinstalled.
38 # automake will do this but config.rpath needs to be visible to automake
39 for i in `ls -d ${STAGING_DATADIR}/automake*`
40 do
41 cp ${STAGING_DATADIR}/gettext/config.rpath $i
42 done
43}