diff options
Diffstat (limited to 'meta/packages/gettext/gettext-native_0.17.bb')
-rw-r--r-- | meta/packages/gettext/gettext-native_0.17.bb | 67 |
1 files changed, 67 insertions, 0 deletions
diff --git a/meta/packages/gettext/gettext-native_0.17.bb b/meta/packages/gettext/gettext-native_0.17.bb new file mode 100644 index 0000000000..c73a19d78d --- /dev/null +++ b/meta/packages/gettext/gettext-native_0.17.bb | |||
@@ -0,0 +1,67 @@ | |||
1 | require gettext_${PV}.bb | ||
2 | PR = "r3" | ||
3 | |||
4 | DEPENDS = "" | ||
5 | PROVIDES = "" | ||
6 | |||
7 | inherit native | ||
8 | |||
9 | S = "${WORKDIR}/gettext-${PV}" | ||
10 | FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gettext-${PV}" | ||
11 | |||
12 | M4 = "\ | ||
13 | ansi-c++.m4 \ | ||
14 | codeset.m4 \ | ||
15 | gettext.m4 \ | ||
16 | glibc21.m4 \ | ||
17 | glibc2.m4 \ | ||
18 | iconv.m4 \ | ||
19 | intdiv0.m4 \ | ||
20 | intldir.m4 \ | ||
21 | intl.m4 \ | ||
22 | intlmacosx.m4 \ | ||
23 | intmax.m4 \ | ||
24 | inttypes_h.m4 \ | ||
25 | inttypes-pri.m4 \ | ||
26 | lcmessage.m4 \ | ||
27 | lock.m4 \ | ||
28 | longlong.m4 \ | ||
29 | nls.m4 \ | ||
30 | po.m4 \ | ||
31 | printf-posix.m4 \ | ||
32 | progtest.m4 \ | ||
33 | size_max.m4 \ | ||
34 | stdint_h.m4 \ | ||
35 | uintmax_t.m4 \ | ||
36 | visibility.m4 \ | ||
37 | wchar_t.m4 \ | ||
38 | wint_t.m4 \ | ||
39 | xsize.m4 \ | ||
40 | lib-ld.m4 \ | ||
41 | lib-link.m4 \ | ||
42 | lib-prefix.m4 \ | ||
43 | " | ||
44 | |||
45 | do_stage_append() { | ||
46 | for i in ${M4}; do | ||
47 | src="gettext-runtime/m4/$i" | ||
48 | if [ ! -f $src ]; then | ||
49 | src="gettext-tools/m4/$i" | ||
50 | fi | ||
51 | if [ ! -f $src ]; then | ||
52 | src="autoconf-lib-link/m4/$i" | ||
53 | fi | ||
54 | if [ ! -f $src ]; then | ||
55 | echo "can't find $i" >&2 | ||
56 | exit 1 | ||
57 | fi | ||
58 | install -m 0644 $src ${STAGING_DATADIR}/aclocal/$i | ||
59 | done | ||
60 | |||
61 | # config.rpath is needed by some configure macros and needs to be autoinstalled. | ||
62 | # automake will do this but config.rpath needs to be visible to automake | ||
63 | for i in `ls -d ${STAGING_DATADIR}/automake*` | ||
64 | do | ||
65 | cp ${STAGING_DATADIR}/gettext/config.rpath $i | ||
66 | done | ||
67 | } | ||