diff options
Diffstat (limited to 'meta/packages/gdb/gdb_6.4.bb')
-rw-r--r-- | meta/packages/gdb/gdb_6.4.bb | 49 |
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/packages/gdb/gdb_6.4.bb b/meta/packages/gdb/gdb_6.4.bb new file mode 100644 index 0000000000..2647c5529e --- /dev/null +++ b/meta/packages/gdb/gdb_6.4.bb | |||
@@ -0,0 +1,49 @@ | |||
1 | DESCRIPTION = "gdb - GNU debugger" | ||
2 | HOMEPAGE = "http://www.gnu.org/software/gdb/" | ||
3 | LICENSE="GPL" | ||
4 | SECTION = "devel" | ||
5 | PRIORITY = "optional" | ||
6 | DEPENDS = "ncurses readline" | ||
7 | RDEPENDS_openmn = "libthread-db1" | ||
8 | PR = "r2" | ||
9 | |||
10 | PACKAGES =+ 'gdbserver ' | ||
11 | FILES_gdbserver = '${bindir}/gdbserver' | ||
12 | |||
13 | inherit autotools gettext | ||
14 | |||
15 | SRC_URI = "${GNU_MIRROR}/gdb/gdb-${PV}.tar.gz \ | ||
16 | # file://uclibc.patch;patch=1 \ | ||
17 | file://kill_arm_map_symbols.patch;patch=1 \ | ||
18 | file://gdbserver-cflags-last.diff;patch=1;pnum=0" | ||
19 | |||
20 | LDFLAGS_append = " -s" | ||
21 | export CC_FOR_BUILD = "${BUILD_CC}" | ||
22 | export CXX_FOR_BUILD = "${BUILD_CXX}" | ||
23 | export CPP_FOR_BUILD = "${BUILD_CPP}" | ||
24 | export CFLAGS_FOR_BUILD = "${BUILD_CFLAGS}" | ||
25 | export CXXFLAGS_FOR_BUILD = "${BUILD_CXXFLAGS}" | ||
26 | export CPPFLAGS_FOR_BUILD = "${BUILD_CPPFLAGS}" | ||
27 | export CFLAGS_append=" -L${STAGING_LIBDIR}" | ||
28 | EXTRA_OEMAKE = "'SUBDIRS=intl mmalloc libiberty opcodes bfd sim gdb etc utils'" | ||
29 | |||
30 | EXTRA_OECONF = "--disable-gdbtk --disable-tui --disable-x \ | ||
31 | --with-curses --disable-multilib --with-readline --disable-sim \ | ||
32 | --program-prefix=''" | ||
33 | |||
34 | S = "${WORKDIR}/gdb-${PV}" | ||
35 | B = "${WORKDIR}/build-${TARGET_SYS}" | ||
36 | |||
37 | do_configure () { | ||
38 | # override this function to avoid the autoconf/automake/aclocal/autoheader | ||
39 | # calls for now | ||
40 | (cd ${S} && gnu-configize) || die "failure in running gnu-configize" | ||
41 | CPPFLAGS="" oe_runconf | ||
42 | } | ||
43 | |||
44 | do_install () { | ||
45 | make -C bfd/doc chew LDFLAGS= CFLAGS=-O2 | ||
46 | oe_runmake DESTDIR='${D}' install | ||
47 | install -d ${D}${bindir} | ||
48 | install -m 0755 gdb/gdbserver/gdbserver ${D}${bindir} | ||
49 | } | ||