summaryrefslogtreecommitdiffstats
path: root/meta/packages/gdb/gdb_6.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/gdb/gdb_6.3.bb')
-rw-r--r--meta/packages/gdb/gdb_6.3.bb50
1 files changed, 50 insertions, 0 deletions
diff --git a/meta/packages/gdb/gdb_6.3.bb b/meta/packages/gdb/gdb_6.3.bb
new file mode 100644
index 0000000000..3e755cee67
--- /dev/null
+++ b/meta/packages/gdb/gdb_6.3.bb
@@ -0,0 +1,50 @@
1DESCRIPTION = "gdb - GNU debugger"
2HOMEPAGE = "http://www.gnu.org/software/gdb/"
3LICENSE="GPL"
4SECTION = "devel"
5PRIORITY = "optional"
6MAINTAINER = "Pawel Osiczko <p.osiczko@tetrapyloctomy.org>"
7DEPENDS = "ncurses readline"
8RDEPENDS_openmn = "libthread-db1"
9PR = "r2"
10
11PACKAGES =+ 'gdbserver '
12FILES_gdbserver = '${bindir}/gdbserver'
13
14inherit autotools gettext
15
16SRC_URI = "${GNU_MIRROR}/gdb/gdb-${PV}.tar.gz \
17 file://uclibc.patch;patch=1 \
18 file://kill_arm_map_symbols.patch;patch=1 \
19 file://gdbserver-cflags-last.diff;patch=1;pnum=0"
20
21LDFLAGS_append = " -s"
22export CC_FOR_BUILD = "${BUILD_CC}"
23export CXX_FOR_BUILD = "${BUILD_CXX}"
24export CPP_FOR_BUILD = "${BUILD_CPP}"
25export CFLAGS_FOR_BUILD = "${BUILD_CFLAGS}"
26export CXXFLAGS_FOR_BUILD = "${BUILD_CXXFLAGS}"
27export CPPFLAGS_FOR_BUILD = "${BUILD_CPPFLAGS}"
28export CFLAGS_append=" -L${STAGING_LIBDIR}"
29EXTRA_OEMAKE = "'SUBDIRS=intl mmalloc libiberty opcodes bfd sim gdb etc utils'"
30
31EXTRA_OECONF = "--disable-gdbtk --disable-tui --disable-x \
32 --with-curses --disable-multilib --with-readline --disable-sim \
33 --program-prefix=''"
34
35S = "${WORKDIR}/gdb-${PV}"
36B = "${WORKDIR}/build-${TARGET_SYS}"
37
38do_configure () {
39# override this function to avoid the autoconf/automake/aclocal/autoheader
40# calls for now
41 (cd ${S} && gnu-configize) || die "failure in running gnu-configize"
42 CPPFLAGS="" oe_runconf
43}
44
45do_install () {
46 make -C bfd/doc chew LDFLAGS= CFLAGS=-O2
47 oe_runmake DESTDIR='${D}' install
48 install -d ${D}${bindir}
49 install -m 0755 gdb/gdbserver/gdbserver ${D}${bindir}
50}