summaryrefslogtreecommitdiffstats
path: root/meta/packages/gdb/gdb-cross_6.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/gdb/gdb-cross_6.3.bb')
-rw-r--r--meta/packages/gdb/gdb-cross_6.3.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/packages/gdb/gdb-cross_6.3.bb b/meta/packages/gdb/gdb-cross_6.3.bb
new file mode 100644
index 0000000000..a6823b6373
--- /dev/null
+++ b/meta/packages/gdb/gdb-cross_6.3.bb
@@ -0,0 +1,36 @@
1LICENSE = "GPL"
2DESCRIPTION = "gdb - GNU debugger"
3SECTION = "base"
4PRIORITY = "optional"
5MAINTAINER = "Phil Blundell <pb@nexus.co.uk>"
6DEPENDS = "ncurses-native"
7
8inherit autotools sdk
9
10S = "${WORKDIR}/gdb-${PV}"
11SRC_URI = "${GNU_MIRROR}/gdb/gdb-${PV}.tar.gz \
12 file://sim-install.patch;patch=1"
13
14FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gdb-${PV}"
15
16export CC_FOR_BUILD = "${BUILD_CC}"
17export CXX_FOR_BUILD = "${BUILD_CXX}"
18export CPP_FOR_BUILD = "${BUILD_CPP}"
19export CFLAGS_FOR_BUILD = "${BUILD_CFLAGS}"
20export CXXFLAGS_FOR_BUILD = "${BUILD_CXXFLAGS}"
21export CPPFLAGS_FOR_BUILD = "${BUILD_CPPFLAGS}"
22
23EXTRA_OEMAKE = "'SUBDIRS=intl mmalloc libiberty opcodes bfd sim gdb etc utils' LDFLAGS='${BUILD_LDFLAGS}'"
24
25EXTRA_OECONF = "--with-curses --with-readline"
26
27do_configure () {
28# override this function to avoid the autoconf/automake/aclocal/autoheader
29# calls for now
30 gnu-configize
31 oe_runconf
32}
33
34do_stage() {
35 :
36}