diff options
Diffstat (limited to 'meta/packages/gdb/files/libiberty-cross.patch')
-rw-r--r-- | meta/packages/gdb/files/libiberty-cross.patch | 630 |
1 files changed, 630 insertions, 0 deletions
diff --git a/meta/packages/gdb/files/libiberty-cross.patch b/meta/packages/gdb/files/libiberty-cross.patch new file mode 100644 index 0000000000..0d1897f9e0 --- /dev/null +++ b/meta/packages/gdb/files/libiberty-cross.patch | |||
@@ -0,0 +1,630 @@ | |||
1 | --- libiberty/configure.in.old 2004-03-31 21:25:25.000000000 +0100 | ||
2 | +++ libiberty/configure.in 2004-03-31 21:18:02.000000000 +0100 | ||
3 | @@ -100,6 +100,7 @@ | ||
4 | AC_CHECK_TOOL(RANLIB, ranlib, :) | ||
5 | |||
6 | LIB_AC_PROG_CC | ||
7 | +AC_PROG_CC_WORKS | ||
8 | |||
9 | AC_PROG_CC_C_O | ||
10 | # autoconf is lame and doesn't give us any substitution variable for this. | ||
11 | @@ -402,7 +403,6 @@ | ||
12 | |||
13 | # We haven't set the list of objects yet. Use the standard autoconf | ||
14 | # tests. This will only work if the compiler works. | ||
15 | - AC_PROG_CC_WORKS | ||
16 | AC_REPLACE_FUNCS($funcs) | ||
17 | libiberty_AC_FUNC_C_ALLOCA | ||
18 | AC_FUNC_VFORK | ||
19 | |||
20 | --- libiberty/configure.old 2003-06-19 21:05:35.000000000 +0100 | ||
21 | +++ libiberty/configure 2004-03-31 21:35:12.000000000 +0100 | ||
22 | @@ -1000,13 +1000,60 @@ | ||
23 | fi | ||
24 | |||
25 | |||
26 | +echo $ac_n "checking whether the C compiler ($CC $CFLAGS $LDFLAGS) works""... $ac_c" 1>&6 | ||
27 | +echo "configure:1005: checking whether the C compiler ($CC $CFLAGS $LDFLAGS) works" >&5 | ||
28 | + | ||
29 | +ac_ext=c | ||
30 | +# CFLAGS is not in ac_cpp because -g, -O, etc. are not valid cpp options. | ||
31 | +ac_cpp='$CPP $CPPFLAGS' | ||
32 | +ac_compile='${CC-cc} -c $CFLAGS $CPPFLAGS conftest.$ac_ext 1>&5' | ||
33 | +ac_link='${CC-cc} -o conftest${ac_exeext} $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS 1>&5' | ||
34 | +cross_compiling=$ac_cv_prog_cc_cross | ||
35 | + | ||
36 | +cat > conftest.$ac_ext << EOF | ||
37 | + | ||
38 | +#line 1016 "configure" | ||
39 | +#include "confdefs.h" | ||
40 | + | ||
41 | +main(){return(0);} | ||
42 | +EOF | ||
43 | +if { (eval echo configure:1021: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then | ||
44 | + ac_cv_prog_cc_works=yes | ||
45 | + # If we can't run a trivial program, we are probably using a cross compiler. | ||
46 | + if (./conftest; exit) 2>/dev/null; then | ||
47 | + ac_cv_prog_cc_cross=no | ||
48 | + else | ||
49 | + ac_cv_prog_cc_cross=yes | ||
50 | + fi | ||
51 | +else | ||
52 | + echo "configure: failed program was:" >&5 | ||
53 | + cat conftest.$ac_ext >&5 | ||
54 | + ac_cv_prog_cc_works=no | ||
55 | +fi | ||
56 | +rm -fr conftest* | ||
57 | +ac_ext=c | ||
58 | +# CFLAGS is not in ac_cpp because -g, -O, etc. are not valid cpp options. | ||
59 | +ac_cpp='$CPP $CPPFLAGS' | ||
60 | +ac_compile='${CC-cc} -c $CFLAGS $CPPFLAGS conftest.$ac_ext 1>&5' | ||
61 | +ac_link='${CC-cc} -o conftest${ac_exeext} $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS 1>&5' | ||
62 | +cross_compiling=$ac_cv_prog_cc_cross | ||
63 | + | ||
64 | +echo "$ac_t""$ac_cv_prog_cc_works" 1>&6 | ||
65 | +if test $ac_cv_prog_cc_works = no; then | ||
66 | + { echo "configure: error: installation or configuration problem: C compiler cannot create executables." 1>&2; exit 1; } | ||
67 | +fi | ||
68 | +echo $ac_n "checking whether the C compiler ($CC $CFLAGS $LDFLAGS) is a cross-compiler""... $ac_c" 1>&6 | ||
69 | +echo "configure:1047: checking whether the C compiler ($CC $CFLAGS $LDFLAGS) is a cross-compiler" >&5 | ||
70 | +echo "$ac_t""$ac_cv_prog_cc_cross" 1>&6 | ||
71 | +cross_compiling=$ac_cv_prog_cc_cross | ||
72 | + | ||
73 | |||
74 | if test "x$CC" != xcc; then | ||
75 | echo $ac_n "checking whether $CC and cc understand -c and -o together""... $ac_c" 1>&6 | ||
76 | -echo "configure:1007: checking whether $CC and cc understand -c and -o together" >&5 | ||
77 | +echo "configure:1054: checking whether $CC and cc understand -c and -o together" >&5 | ||
78 | else | ||
79 | echo $ac_n "checking whether cc understands -c and -o together""... $ac_c" 1>&6 | ||
80 | -echo "configure:1010: checking whether cc understands -c and -o together" >&5 | ||
81 | +echo "configure:1057: checking whether cc understands -c and -o together" >&5 | ||
82 | fi | ||
83 | set dummy $CC; ac_cc="`echo $2 | | ||
84 | sed -e 's/[^a-zA-Z0-9_]/_/g' -e 's/^[0-9]/_/'`" | ||
85 | @@ -1018,16 +1065,16 @@ | ||
86 | # We do the test twice because some compilers refuse to overwrite an | ||
87 | # existing .o file with -o, though they will create one. | ||
88 | ac_try='${CC-cc} -c conftest.c -o conftest.o 1>&5' | ||
89 | -if { (eval echo configure:1022: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; } && | ||
90 | - test -f conftest.o && { (eval echo configure:1023: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }; | ||
91 | +if { (eval echo configure:1069: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; } && | ||
92 | + test -f conftest.o && { (eval echo configure:1070: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }; | ||
93 | then | ||
94 | eval ac_cv_prog_cc_${ac_cc}_c_o=yes | ||
95 | if test "x$CC" != xcc; then | ||
96 | # Test first that cc exists at all. | ||
97 | - if { ac_try='cc -c conftest.c 1>&5'; { (eval echo configure:1028: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }; }; then | ||
98 | + if { ac_try='cc -c conftest.c 1>&5'; { (eval echo configure:1075: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }; }; then | ||
99 | ac_try='cc -c conftest.c -o conftest.o 1>&5' | ||
100 | - if { (eval echo configure:1030: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; } && | ||
101 | - test -f conftest.o && { (eval echo configure:1031: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }; | ||
102 | + if { (eval echo configure:1077: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; } && | ||
103 | + test -f conftest.o && { (eval echo configure:1078: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }; | ||
104 | then | ||
105 | # cc works too. | ||
106 | : | ||
107 | @@ -1063,7 +1110,7 @@ | ||
108 | |||
109 | |||
110 | echo $ac_n "checking for POSIXized ISC""... $ac_c" 1>&6 | ||
111 | -echo "configure:1067: checking for POSIXized ISC" >&5 | ||
112 | +echo "configure:1114: checking for POSIXized ISC" >&5 | ||
113 | if test -d /etc/conf/kconfig.d && | ||
114 | grep _POSIX_VERSION /usr/include/sys/unistd.h >/dev/null 2>&1 | ||
115 | then | ||
116 | @@ -1084,12 +1131,12 @@ | ||
117 | fi | ||
118 | |||
119 | echo $ac_n "checking for working const""... $ac_c" 1>&6 | ||
120 | -echo "configure:1088: checking for working const" >&5 | ||
121 | +echo "configure:1135: checking for working const" >&5 | ||
122 | if eval "test \"`echo '$''{'ac_cv_c_const'+set}'`\" = set"; then | ||
123 | echo $ac_n "(cached) $ac_c" 1>&6 | ||
124 | else | ||
125 | cat > conftest.$ac_ext <<EOF | ||
126 | -#line 1093 "configure" | ||
127 | +#line 1140 "configure" | ||
128 | #include "confdefs.h" | ||
129 | |||
130 | int main() { | ||
131 | @@ -1138,7 +1185,7 @@ | ||
132 | |||
133 | ; return 0; } | ||
134 | EOF | ||
135 | -if { (eval echo configure:1142: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then | ||
136 | +if { (eval echo configure:1189: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then | ||
137 | rm -rf conftest* | ||
138 | ac_cv_c_const=yes | ||
139 | else | ||
140 | @@ -1159,21 +1206,21 @@ | ||
141 | fi | ||
142 | |||
143 | echo $ac_n "checking for inline""... $ac_c" 1>&6 | ||
144 | -echo "configure:1163: checking for inline" >&5 | ||
145 | +echo "configure:1210: checking for inline" >&5 | ||
146 | if eval "test \"`echo '$''{'ac_cv_c_inline'+set}'`\" = set"; then | ||
147 | echo $ac_n "(cached) $ac_c" 1>&6 | ||
148 | else | ||
149 | ac_cv_c_inline=no | ||
150 | for ac_kw in inline __inline__ __inline; do | ||
151 | cat > conftest.$ac_ext <<EOF | ||
152 | -#line 1170 "configure" | ||
153 | +#line 1217 "configure" | ||
154 | #include "confdefs.h" | ||
155 | |||
156 | int main() { | ||
157 | } $ac_kw foo() { | ||
158 | ; return 0; } | ||
159 | EOF | ||
160 | -if { (eval echo configure:1177: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then | ||
161 | +if { (eval echo configure:1224: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then | ||
162 | rm -rf conftest* | ||
163 | ac_cv_c_inline=$ac_kw; break | ||
164 | else | ||
165 | @@ -1199,14 +1246,14 @@ | ||
166 | esac | ||
167 | |||
168 | echo $ac_n "checking whether byte ordering is bigendian""... $ac_c" 1>&6 | ||
169 | -echo "configure:1203: checking whether byte ordering is bigendian" >&5 | ||
170 | +echo "configure:1250: checking whether byte ordering is bigendian" >&5 | ||
171 | if eval "test \"`echo '$''{'ac_cv_c_bigendian'+set}'`\" = set"; then | ||
172 | echo $ac_n "(cached) $ac_c" 1>&6 | ||
173 | else | ||
174 | ac_cv_c_bigendian=unknown | ||
175 | # See if sys/param.h defines the BYTE_ORDER macro. | ||
176 | cat > conftest.$ac_ext <<EOF | ||
177 | -#line 1210 "configure" | ||
178 | +#line 1257 "configure" | ||
179 | #include "confdefs.h" | ||
180 | #include <sys/types.h> | ||
181 | #include <sys/param.h> | ||
182 | @@ -1217,11 +1264,11 @@ | ||
183 | #endif | ||
184 | ; return 0; } | ||
185 | EOF | ||
186 | -if { (eval echo configure:1221: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then | ||
187 | +if { (eval echo configure:1268: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then | ||
188 | rm -rf conftest* | ||
189 | # It does; now see whether it defined to BIG_ENDIAN or not. | ||
190 | cat > conftest.$ac_ext <<EOF | ||
191 | -#line 1225 "configure" | ||
192 | +#line 1272 "configure" | ||
193 | #include "confdefs.h" | ||
194 | #include <sys/types.h> | ||
195 | #include <sys/param.h> | ||
196 | @@ -1232,7 +1279,7 @@ | ||
197 | #endif | ||
198 | ; return 0; } | ||
199 | EOF | ||
200 | -if { (eval echo configure:1236: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then | ||
201 | +if { (eval echo configure:1283: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then | ||
202 | rm -rf conftest* | ||
203 | ac_cv_c_bigendian=yes | ||
204 | else | ||
205 | @@ -1252,7 +1299,7 @@ | ||
206 | echo $ac_n "cross-compiling... " 2>&6 | ||
207 | else | ||
208 | cat > conftest.$ac_ext <<EOF | ||
209 | -#line 1256 "configure" | ||
210 | +#line 1303 "configure" | ||
211 | #include "confdefs.h" | ||
212 | main () { | ||
213 | /* Are we little or big endian? From Harbison&Steele. */ | ||
214 | @@ -1265,7 +1312,7 @@ | ||
215 | exit (u.c[sizeof (long) - 1] == 1); | ||
216 | } | ||
217 | EOF | ||
218 | -if { (eval echo configure:1269: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext} && (./conftest; exit) 2>/dev/null | ||
219 | +if { (eval echo configure:1316: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext} && (./conftest; exit) 2>/dev/null | ||
220 | then | ||
221 | ac_cv_c_bigendian=no | ||
222 | else | ||
223 | @@ -1283,7 +1330,7 @@ | ||
224 | echo "$ac_t""$ac_cv_c_bigendian" 1>&6 | ||
225 | if test $ac_cv_c_bigendian = unknown; then | ||
226 | echo $ac_n "checking to probe for byte ordering""... $ac_c" 1>&6 | ||
227 | -echo "configure:1287: checking to probe for byte ordering" >&5 | ||
228 | +echo "configure:1334: checking to probe for byte ordering" >&5 | ||
229 | |||
230 | cat >conftest.c <<EOF | ||
231 | short ascii_mm[] = { 0x4249, 0x4765, 0x6E44, 0x6961, 0x6E53, 0x7953, 0 }; | ||
232 | @@ -1352,7 +1399,7 @@ | ||
233 | # SVR4 /usr/ucb/install, which tries to use the nonexistent group "staff" | ||
234 | # ./install, which can be erroneously created by make from ./install.sh. | ||
235 | echo $ac_n "checking for a BSD compatible install""... $ac_c" 1>&6 | ||
236 | -echo "configure:1356: checking for a BSD compatible install" >&5 | ||
237 | +echo "configure:1403: checking for a BSD compatible install" >&5 | ||
238 | if test -z "$INSTALL"; then | ||
239 | if eval "test \"`echo '$''{'ac_cv_path_install'+set}'`\" = set"; then | ||
240 | echo $ac_n "(cached) $ac_c" 1>&6 | ||
241 | @@ -1413,7 +1460,7 @@ | ||
242 | # able to link anything, it had better be able to at least compile | ||
243 | # something. | ||
244 | echo $ac_n "checking how to run the C preprocessor""... $ac_c" 1>&6 | ||
245 | -echo "configure:1417: checking how to run the C preprocessor" >&5 | ||
246 | +echo "configure:1464: checking how to run the C preprocessor" >&5 | ||
247 | # On Suns, sometimes $CPP names a directory. | ||
248 | if test -n "$CPP" && test -d "$CPP"; then | ||
249 | CPP= | ||
250 | @@ -1428,13 +1475,13 @@ | ||
251 | # On the NeXT, cc -E runs the code through the compiler's parser, | ||
252 | # not just through cpp. | ||
253 | cat > conftest.$ac_ext <<EOF | ||
254 | -#line 1432 "configure" | ||
255 | +#line 1479 "configure" | ||
256 | #include "confdefs.h" | ||
257 | #include <assert.h> | ||
258 | Syntax Error | ||
259 | EOF | ||
260 | ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out" | ||
261 | -{ (eval echo configure:1438: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; } | ||
262 | +{ (eval echo configure:1485: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; } | ||
263 | ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$"` | ||
264 | if test -z "$ac_err"; then | ||
265 | : | ||
266 | @@ -1445,13 +1492,13 @@ | ||
267 | rm -rf conftest* | ||
268 | CPP="${CC-cc} -E -traditional-cpp" | ||
269 | cat > conftest.$ac_ext <<EOF | ||
270 | -#line 1449 "configure" | ||
271 | +#line 1496 "configure" | ||
272 | #include "confdefs.h" | ||
273 | #include <assert.h> | ||
274 | Syntax Error | ||
275 | EOF | ||
276 | ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out" | ||
277 | -{ (eval echo configure:1455: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; } | ||
278 | +{ (eval echo configure:1502: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; } | ||
279 | ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$"` | ||
280 | if test -z "$ac_err"; then | ||
281 | : | ||
282 | @@ -1462,13 +1509,13 @@ | ||
283 | rm -rf conftest* | ||
284 | CPP="${CC-cc} -nologo -E" | ||
285 | cat > conftest.$ac_ext <<EOF | ||
286 | -#line 1466 "configure" | ||
287 | +#line 1513 "configure" | ||
288 | #include "confdefs.h" | ||
289 | #include <assert.h> | ||
290 | Syntax Error | ||
291 | EOF | ||
292 | ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out" | ||
293 | -{ (eval echo configure:1472: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; } | ||
294 | +{ (eval echo configure:1519: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; } | ||
295 | ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$"` | ||
296 | if test -z "$ac_err"; then | ||
297 | : | ||
298 | @@ -1496,17 +1543,17 @@ | ||
299 | do | ||
300 | ac_safe=`echo "$ac_hdr" | sed 'y%./+-%__p_%'` | ||
301 | echo $ac_n "checking for $ac_hdr""... $ac_c" 1>&6 | ||
302 | -echo "configure:1500: checking for $ac_hdr" >&5 | ||
303 | +echo "configure:1547: checking for $ac_hdr" >&5 | ||
304 | if eval "test \"`echo '$''{'ac_cv_header_$ac_safe'+set}'`\" = set"; then | ||
305 | echo $ac_n "(cached) $ac_c" 1>&6 | ||
306 | else | ||
307 | cat > conftest.$ac_ext <<EOF | ||
308 | -#line 1505 "configure" | ||
309 | +#line 1552 "configure" | ||
310 | #include "confdefs.h" | ||
311 | #include <$ac_hdr> | ||
312 | EOF | ||
313 | ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out" | ||
314 | -{ (eval echo configure:1510: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; } | ||
315 | +{ (eval echo configure:1557: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; } | ||
316 | ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$"` | ||
317 | if test -z "$ac_err"; then | ||
318 | rm -rf conftest* | ||
319 | @@ -1533,12 +1580,12 @@ | ||
320 | done | ||
321 | |||
322 | echo $ac_n "checking for sys/wait.h that is POSIX.1 compatible""... $ac_c" 1>&6 | ||
323 | -echo "configure:1537: checking for sys/wait.h that is POSIX.1 compatible" >&5 | ||
324 | +echo "configure:1584: checking for sys/wait.h that is POSIX.1 compatible" >&5 | ||
325 | if eval "test \"`echo '$''{'ac_cv_header_sys_wait_h'+set}'`\" = set"; then | ||
326 | echo $ac_n "(cached) $ac_c" 1>&6 | ||
327 | else | ||
328 | cat > conftest.$ac_ext <<EOF | ||
329 | -#line 1542 "configure" | ||
330 | +#line 1589 "configure" | ||
331 | #include "confdefs.h" | ||
332 | #include <sys/types.h> | ||
333 | #include <sys/wait.h> | ||
334 | @@ -1554,7 +1601,7 @@ | ||
335 | s = WIFEXITED (s) ? WEXITSTATUS (s) : 1; | ||
336 | ; return 0; } | ||
337 | EOF | ||
338 | -if { (eval echo configure:1558: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then | ||
339 | +if { (eval echo configure:1605: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then | ||
340 | rm -rf conftest* | ||
341 | ac_cv_header_sys_wait_h=yes | ||
342 | else | ||
343 | @@ -1575,12 +1622,12 @@ | ||
344 | fi | ||
345 | |||
346 | echo $ac_n "checking whether time.h and sys/time.h may both be included""... $ac_c" 1>&6 | ||
347 | -echo "configure:1579: checking whether time.h and sys/time.h may both be included" >&5 | ||
348 | +echo "configure:1626: checking whether time.h and sys/time.h may both be included" >&5 | ||
349 | if eval "test \"`echo '$''{'ac_cv_header_time'+set}'`\" = set"; then | ||
350 | echo $ac_n "(cached) $ac_c" 1>&6 | ||
351 | else | ||
352 | cat > conftest.$ac_ext <<EOF | ||
353 | -#line 1584 "configure" | ||
354 | +#line 1631 "configure" | ||
355 | #include "confdefs.h" | ||
356 | #include <sys/types.h> | ||
357 | #include <sys/time.h> | ||
358 | @@ -1589,7 +1636,7 @@ | ||
359 | struct tm *tp; | ||
360 | ; return 0; } | ||
361 | EOF | ||
362 | -if { (eval echo configure:1593: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then | ||
363 | +if { (eval echo configure:1640: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then | ||
364 | rm -rf conftest* | ||
365 | ac_cv_header_time=yes | ||
366 | else | ||
367 | @@ -1611,19 +1658,19 @@ | ||
368 | |||
369 | |||
370 | echo $ac_n "checking whether errno must be declared""... $ac_c" 1>&6 | ||
371 | -echo "configure:1615: checking whether errno must be declared" >&5 | ||
372 | +echo "configure:1662: checking whether errno must be declared" >&5 | ||
373 | if eval "test \"`echo '$''{'libiberty_cv_declare_errno'+set}'`\" = set"; then | ||
374 | echo $ac_n "(cached) $ac_c" 1>&6 | ||
375 | else | ||
376 | cat > conftest.$ac_ext <<EOF | ||
377 | -#line 1620 "configure" | ||
378 | +#line 1667 "configure" | ||
379 | #include "confdefs.h" | ||
380 | #include <errno.h> | ||
381 | int main() { | ||
382 | int x = errno; | ||
383 | ; return 0; } | ||
384 | EOF | ||
385 | -if { (eval echo configure:1627: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then | ||
386 | +if { (eval echo configure:1674: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then | ||
387 | rm -rf conftest* | ||
388 | libiberty_cv_declare_errno=no | ||
389 | else | ||
390 | @@ -1645,12 +1692,12 @@ | ||
391 | |||
392 | |||
393 | echo $ac_n "checking for ANSI C header files""... $ac_c" 1>&6 | ||
394 | -echo "configure:1649: checking for ANSI C header files" >&5 | ||
395 | +echo "configure:1696: checking for ANSI C header files" >&5 | ||
396 | if eval "test \"`echo '$''{'ac_cv_header_stdc'+set}'`\" = set"; then | ||
397 | echo $ac_n "(cached) $ac_c" 1>&6 | ||
398 | else | ||
399 | cat > conftest.$ac_ext <<EOF | ||
400 | -#line 1654 "configure" | ||
401 | +#line 1701 "configure" | ||
402 | #include "confdefs.h" | ||
403 | #include <stdlib.h> | ||
404 | #include <stdarg.h> | ||
405 | @@ -1658,7 +1705,7 @@ | ||
406 | #include <float.h> | ||
407 | EOF | ||
408 | ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out" | ||
409 | -{ (eval echo configure:1662: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; } | ||
410 | +{ (eval echo configure:1709: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; } | ||
411 | ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$"` | ||
412 | if test -z "$ac_err"; then | ||
413 | rm -rf conftest* | ||
414 | @@ -1675,7 +1722,7 @@ | ||
415 | if test $ac_cv_header_stdc = yes; then | ||
416 | # SunOS 4.x string.h does not declare mem*, contrary to ANSI. | ||
417 | cat > conftest.$ac_ext <<EOF | ||
418 | -#line 1679 "configure" | ||
419 | +#line 1726 "configure" | ||
420 | #include "confdefs.h" | ||
421 | #include <string.h> | ||
422 | EOF | ||
423 | @@ -1693,7 +1740,7 @@ | ||
424 | if test $ac_cv_header_stdc = yes; then | ||
425 | # ISC 2.0.2 stdlib.h does not declare free, contrary to ANSI. | ||
426 | cat > conftest.$ac_ext <<EOF | ||
427 | -#line 1697 "configure" | ||
428 | +#line 1744 "configure" | ||
429 | #include "confdefs.h" | ||
430 | #include <stdlib.h> | ||
431 | EOF | ||
432 | @@ -1714,7 +1761,7 @@ | ||
433 | : | ||
434 | else | ||
435 | cat > conftest.$ac_ext <<EOF | ||
436 | -#line 1718 "configure" | ||
437 | +#line 1765 "configure" | ||
438 | #include "confdefs.h" | ||
439 | #include <ctype.h> | ||
440 | #define ISLOWER(c) ('a' <= (c) && (c) <= 'z') | ||
441 | @@ -1725,7 +1772,7 @@ | ||
442 | exit (0); } | ||
443 | |||
444 | EOF | ||
445 | -if { (eval echo configure:1729: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext} && (./conftest; exit) 2>/dev/null | ||
446 | +if { (eval echo configure:1776: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext} && (./conftest; exit) 2>/dev/null | ||
447 | then | ||
448 | : | ||
449 | else | ||
450 | @@ -1749,12 +1796,12 @@ | ||
451 | fi | ||
452 | |||
453 | echo $ac_n "checking for uintptr_t""... $ac_c" 1>&6 | ||
454 | -echo "configure:1753: checking for uintptr_t" >&5 | ||
455 | +echo "configure:1800: checking for uintptr_t" >&5 | ||
456 | if eval "test \"`echo '$''{'ac_cv_type_uintptr_t'+set}'`\" = set"; then | ||
457 | echo $ac_n "(cached) $ac_c" 1>&6 | ||
458 | else | ||
459 | cat > conftest.$ac_ext <<EOF | ||
460 | -#line 1758 "configure" | ||
461 | +#line 1805 "configure" | ||
462 | #include "confdefs.h" | ||
463 | #include <sys/types.h> | ||
464 | #if STDC_HEADERS | ||
465 | @@ -1790,12 +1837,12 @@ | ||
466 | |||
467 | |||
468 | echo $ac_n "checking for pid_t""... $ac_c" 1>&6 | ||
469 | -echo "configure:1794: checking for pid_t" >&5 | ||
470 | +echo "configure:1841: checking for pid_t" >&5 | ||
471 | if eval "test \"`echo '$''{'ac_cv_type_pid_t'+set}'`\" = set"; then | ||
472 | echo $ac_n "(cached) $ac_c" 1>&6 | ||
473 | else | ||
474 | cat > conftest.$ac_ext <<EOF | ||
475 | -#line 1799 "configure" | ||
476 | +#line 1846 "configure" | ||
477 | #include "confdefs.h" | ||
478 | #include <sys/types.h> | ||
479 | #if STDC_HEADERS | ||
480 | @@ -1895,12 +1942,12 @@ | ||
481 | realpath canonicalize_file_name | ||
482 | do | ||
483 | echo $ac_n "checking for $ac_func""... $ac_c" 1>&6 | ||
484 | -echo "configure:1899: checking for $ac_func" >&5 | ||
485 | +echo "configure:1946: checking for $ac_func" >&5 | ||
486 | if eval "test \"`echo '$''{'ac_cv_func_$ac_func'+set}'`\" = set"; then | ||
487 | echo $ac_n "(cached) $ac_c" 1>&6 | ||
488 | else | ||
489 | cat > conftest.$ac_ext <<EOF | ||
490 | -#line 1904 "configure" | ||
491 | +#line 1951 "configure" | ||
492 | #include "confdefs.h" | ||
493 | /* System header to define __stub macros and hopefully few prototypes, | ||
494 | which can conflict with char $ac_func(); below. */ | ||
495 | @@ -1923,7 +1970,7 @@ | ||
496 | |||
497 | ; return 0; } | ||
498 | EOF | ||
499 | -if { (eval echo configure:1927: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then | ||
500 | +if { (eval echo configure:1974: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then | ||
501 | rm -rf conftest* | ||
502 | eval "ac_cv_func_$ac_func=yes" | ||
503 | else | ||
504 | @@ -2152,53 +2199,6 @@ | ||
505 | |||
506 | # We haven't set the list of objects yet. Use the standard autoconf | ||
507 | # tests. This will only work if the compiler works. | ||
508 | - echo $ac_n "checking whether the C compiler ($CC $CFLAGS $LDFLAGS) works""... $ac_c" 1>&6 | ||
509 | -echo "configure:2157: checking whether the C compiler ($CC $CFLAGS $LDFLAGS) works" >&5 | ||
510 | - | ||
511 | -ac_ext=c | ||
512 | -# CFLAGS is not in ac_cpp because -g, -O, etc. are not valid cpp options. | ||
513 | -ac_cpp='$CPP $CPPFLAGS' | ||
514 | -ac_compile='${CC-cc} -c $CFLAGS $CPPFLAGS conftest.$ac_ext 1>&5' | ||
515 | -ac_link='${CC-cc} -o conftest${ac_exeext} $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS 1>&5' | ||
516 | -cross_compiling=$ac_cv_prog_cc_cross | ||
517 | - | ||
518 | -cat > conftest.$ac_ext << EOF | ||
519 | - | ||
520 | -#line 2168 "configure" | ||
521 | -#include "confdefs.h" | ||
522 | - | ||
523 | -main(){return(0);} | ||
524 | -EOF | ||
525 | -if { (eval echo configure:2173: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then | ||
526 | - ac_cv_prog_cc_works=yes | ||
527 | - # If we can't run a trivial program, we are probably using a cross compiler. | ||
528 | - if (./conftest; exit) 2>/dev/null; then | ||
529 | - ac_cv_prog_cc_cross=no | ||
530 | - else | ||
531 | - ac_cv_prog_cc_cross=yes | ||
532 | - fi | ||
533 | -else | ||
534 | - echo "configure: failed program was:" >&5 | ||
535 | - cat conftest.$ac_ext >&5 | ||
536 | - ac_cv_prog_cc_works=no | ||
537 | -fi | ||
538 | -rm -fr conftest* | ||
539 | -ac_ext=c | ||
540 | -# CFLAGS is not in ac_cpp because -g, -O, etc. are not valid cpp options. | ||
541 | -ac_cpp='$CPP $CPPFLAGS' | ||
542 | -ac_compile='${CC-cc} -c $CFLAGS $CPPFLAGS conftest.$ac_ext 1>&5' | ||
543 | -ac_link='${CC-cc} -o conftest${ac_exeext} $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS 1>&5' | ||
544 | -cross_compiling=$ac_cv_prog_cc_cross | ||
545 | - | ||
546 | -echo "$ac_t""$ac_cv_prog_cc_works" 1>&6 | ||
547 | -if test $ac_cv_prog_cc_works = no; then | ||
548 | - { echo "configure: error: installation or configuration problem: C compiler cannot create executables." 1>&2; exit 1; } | ||
549 | -fi | ||
550 | -echo $ac_n "checking whether the C compiler ($CC $CFLAGS $LDFLAGS) is a cross-compiler""... $ac_c" 1>&6 | ||
551 | -echo "configure:2199: checking whether the C compiler ($CC $CFLAGS $LDFLAGS) is a cross-compiler" >&5 | ||
552 | -echo "$ac_t""$ac_cv_prog_cc_cross" 1>&6 | ||
553 | -cross_compiling=$ac_cv_prog_cc_cross | ||
554 | - | ||
555 | for ac_func in $funcs | ||
556 | do | ||
557 | echo $ac_n "checking for $ac_func""... $ac_c" 1>&6 | ||
558 | @@ -2900,7 +2900,7 @@ | ||
559 | esac | ||
560 | |||
561 | |||
562 | -for ac_hdr in stdlib.h unistd.h sys/stat.h sys/types.h | ||
563 | +for ac_hdr in unistd.h | ||
564 | do | ||
565 | ac_safe=`echo "$ac_hdr" | sed 'y%./+-%__p_%'` | ||
566 | echo $ac_n "checking for $ac_hdr""... $ac_c" 1>&6 | ||
567 | @@ -3032,24 +3032,11 @@ | ||
568 | #include <fcntl.h> | ||
569 | #include <sys/mman.h> | ||
570 | |||
571 | -#if HAVE_SYS_TYPES_H | ||
572 | -# include <sys/types.h> | ||
573 | -#endif | ||
574 | - | ||
575 | -#if HAVE_STDLIB_H | ||
576 | -# include <stdlib.h> | ||
577 | -#endif | ||
578 | - | ||
579 | -#if HAVE_SYS_STAT_H | ||
580 | -# include <sys/stat.h> | ||
581 | -#endif | ||
582 | - | ||
583 | -#if HAVE_UNISTD_H | ||
584 | -# include <unistd.h> | ||
585 | -#endif | ||
586 | - | ||
587 | /* This mess was copied from the GNU getpagesize.h. */ | ||
588 | #ifndef HAVE_GETPAGESIZE | ||
589 | +# ifdef HAVE_UNISTD_H | ||
590 | +# include <unistd.h> | ||
591 | +# endif | ||
592 | |||
593 | /* Assume that all systems that can run configure have sys/param.h. */ | ||
594 | # ifndef HAVE_SYS_PARAM_H | ||
595 | @@ -3157,7 +3144,7 @@ | ||
596 | } | ||
597 | |||
598 | EOF | ||
599 | -if { (eval echo configure:3161: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext} && (./conftest; exit) 2>/dev/null | ||
600 | +if { (eval echo configure:3148: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext} && (./conftest; exit) 2>/dev/null | ||
601 | then | ||
602 | ac_cv_func_mmap_fixed_mapped=yes | ||
603 | else | ||
604 | @@ -3181,7 +3168,7 @@ | ||
605 | |||
606 | |||
607 | echo $ac_n "checking for working strncmp""... $ac_c" 1>&6 | ||
608 | -echo "configure:3185: checking for working strncmp" >&5 | ||
609 | +echo "configure:3172: checking for working strncmp" >&5 | ||
610 | if eval "test \"`echo '$''{'ac_cv_func_strncmp_works'+set}'`\" = set"; then | ||
611 | echo $ac_n "(cached) $ac_c" 1>&6 | ||
612 | else | ||
613 | @@ -3189,7 +3176,7 @@ | ||
614 | ac_cv_func_strncmp_works=no | ||
615 | else | ||
616 | cat > conftest.$ac_ext <<EOF | ||
617 | -#line 3193 "configure" | ||
618 | +#line 3180 "configure" | ||
619 | #include "confdefs.h" | ||
620 | |||
621 | /* Test by Jim Wilson and Kaveh Ghazi. | ||
622 | @@ -3253,7 +3240,7 @@ | ||
623 | } | ||
624 | |||
625 | EOF | ||
626 | -if { (eval echo configure:3257: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext} && (./conftest; exit) 2>/dev/null | ||
627 | +if { (eval echo configure:3244: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext} && (./conftest; exit) 2>/dev/null | ||
628 | then | ||
629 | ac_cv_func_strncmp_works=yes | ||
630 | else | ||