summaryrefslogtreecommitdiffstats
path: root/meta/packages/gcc/gcc_4.2.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/gcc/gcc_4.2.2.bb')
-rw-r--r--meta/packages/gcc/gcc_4.2.2.bb98
1 files changed, 6 insertions, 92 deletions
diff --git a/meta/packages/gcc/gcc_4.2.2.bb b/meta/packages/gcc/gcc_4.2.2.bb
index 6c5a17e151..7238aed4d7 100644
--- a/meta/packages/gcc/gcc_4.2.2.bb
+++ b/meta/packages/gcc/gcc_4.2.2.bb
@@ -1,96 +1,10 @@
1DESCRIPTION = "The GNU cc and gcc C compilers." 1PR = "r6"
2HOMEPAGE = "http://www.gnu.org/software/gcc/"
3SECTION = "devel"
4LICENSE = "GPL"
5PR = "r8"
6 2
7inherit autotools gettext 3require gcc-${PV}.inc
4require gcc-configure-target.inc
5require gcc-package-target.inc
8 6
9require gcc-package.inc 7SRC_URI_append = "file://fortran-cross-compile-hack.patch;patch=1"
10 8
11SRC_URI = "ftp://ftp.gnu.org/pub/gnu/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \ 9ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_INCDIR}"
12 file://100-uclibc-conf.patch;patch=1 \
13 file://103-uclibc-conf-noupstream.patch;patch=1 \
14 file://200-uclibc-locale.patch;patch=1 \
15 file://203-uclibc-locale-no__x.patch;patch=1 \
16 file://204-uclibc-locale-wchar_fix.patch;patch=1 \
17 file://205-uclibc-locale-update.patch;patch=1 \
18 file://300-libstdc++-pic.patch;patch=1 \
19 file://301-missing-execinfo_h.patch;patch=1 \
20 file://302-c99-snprintf.patch;patch=1 \
21 file://303-c99-complex-ugly-hack.patch;patch=1 \
22 file://304-index_macro.patch;patch=1 \
23 file://305-libmudflap-susv3-legacy.patch;patch=1 \
24 file://306-libstdc++-namespace.patch;patch=1 \
25 file://307-locale_facets.patch;patch=1 \
26 file://402-libbackend_dep_gcov-iov.h.patch;patch=1 \
27 file://602-sdk-libstdc++-includes.patch;patch=1 \
28 file://740-sh-pr24836.patch;patch=1 \
29 file://800-arm-bigendian.patch;patch=1 \
30 file://801-arm-bigendian-eabi.patch;patch=1 \
31 file://904-flatten-switch-stmt-00.patch;patch=1 \
32 file://arm-nolibfloat.patch;patch=1 \
33 file://arm-softfloat.patch;patch=1 \
34 file://gcc41-configure.in.patch;patch=1 \
35 file://arm-thumb.patch;patch=1 \
36 file://arm-thumb-cache.patch;patch=1 \
37 file://ldflags.patch;patch=1 \
38 file://zecke-xgcc-cpp.patch;patch=1 \
39 file://unbreak-armv4t.patch;patch=1 \
40 file://fix-ICE-in-arm_unwind_emit_set.diff;patch=1 \
41 file://cache-amnesia.patch;patch=1 \
42 file://gfortran.patch;patch=1 \
43 file://gcc-4.0.2-e300c2c3.patch;patch=1 \
44 file://pr34130.patch;patch=1 \
45 file://fortran-static-linking.patch;patch=1 \
46 file://intermask-bigendian.patch;patch=1 \
47"
48 10
49SRC_URI_append_ep93xx = " \
50 file://arm-crunch-saveregs.patch;patch=1 \
51 file://arm-crunch-20000320.patch;patch=1 \
52 file://arm-crunch-compare.patch;patch=1 \
53 file://arm-crunch-compare-unordered.patch;patch=1 \
54 file://arm-crunch-compare-geu.patch;patch=1 \
55 file://arm-crunch-eabi-ieee754.patch;patch=1 \
56 file://arm-crunch-eabi-ieee754-div.patch;patch=1 \
57 file://arm-crunch-64bit-disable0.patch;patch=1 \
58 file://arm-crunch-offset.patch;patch=1 \
59 file://arm-crunch-fp_consts.patch;patch=1 \
60 file://arm-crunch-neg2.patch;patch=1 \
61 file://arm-crunch-predicates3.patch;patch=1 \
62 file://arm-crunch-cfcvtds-disable.patch;patch=1 \
63 file://arm-crunch-floatsi-disable.patch;patch=1 \
64 file://arm-crunch-truncsi-disable.patch;patch=1 \
65 file://arm-crunch-cfcvt64-disable.patch;patch=1 \
66 file://arm-crunch-cirrus-bugfixes.patch;patch=1 \
67 "
68
69PACKAGE_ARCH_ep93xx = "${MACHINE_ARCH}"
70
71SRC_URI_append_sh3 = " file://sh3-installfix-fixheaders.patch;patch=1 "
72
73#Set the fortran bits
74# 'i,fortran' or '', not 'f77' like gcc3 had
75FORTRAN = ""
76FORTRAN_linux-gnueabi = ",fortran"
77
78DEPENDS += " gmp mpfr "
79
80#Set the java bits
81JAVA = ""
82JAVA_arm = ""
83
84LANGUAGES = "c,c++${FORTRAN}${JAVA}"
85require gcc3-build.inc
86ARCH_FLAGS_FOR_TARGET=-isystem${STAGING_INCDIR}
87
88
89EXTRA_OECONF += " --disable-libssp --disable-bootstrap "
90
91# We know some one is including us, but we only want to apply this fortran hack for the real gcc
92python __anonymous () {
93 import bb
94 if bb.data.getVar('PN', d, True) == "gcc":
95 bb.data.setVar('SRC_URI_append', ' file://fortran-cross-compile-hack.patch;patch=1', d)
96}