summaryrefslogtreecommitdiffstats
path: root/meta/packages/gcc/gcc_4.1.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/gcc/gcc_4.1.1.bb')
-rw-r--r--meta/packages/gcc/gcc_4.1.1.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta/packages/gcc/gcc_4.1.1.bb b/meta/packages/gcc/gcc_4.1.1.bb
new file mode 100644
index 0000000000..e2d3d25ea8
--- /dev/null
+++ b/meta/packages/gcc/gcc_4.1.1.bb
@@ -0,0 +1,47 @@
1PR = "r6"
2DESCRIPTION = "The GNU cc and gcc C compilers."
3HOMEPAGE = "http://www.gnu.org/software/gcc/"
4SECTION = "devel"
5LICENSE = "GPL"
6
7inherit autotools gettext
8
9require gcc-package.inc
10
11SRC_URI = "http://ftp.gnu.org/pub/gnu/gcc/gcc-4.1.1/gcc-4.1.1.tar.bz2 \
12 file://100-uclibc-conf.patch;patch=1 \
13 file://110-arm-eabi.patch;patch=1 \
14 file://200-uclibc-locale.patch;patch=1 \
15 file://300-libstdc++-pic.patch;patch=1 \
16 file://301-missing-execinfo_h.patch;patch=1 \
17 file://302-c99-snprintf.patch;patch=1 \
18 file://303-c99-complex-ugly-hack.patch;patch=1 \
19 file://304-index_macro.patch;patch=1 \
20 file://602-sdk-libstdc++-includes.patch;patch=1 \
21 file://740-sh-pr24836.patch;patch=1 \
22 file://800-arm-bigendian.patch;patch=1 \
23 file://arm-nolibfloat.patch;patch=1 \
24 file://arm-softfloat.patch;patch=1 \
25 file://gcc41-configure.in.patch;patch=1 \
26 file://arm-thumb.patch;patch=1 \
27 file://arm-thumb-cache.patch;patch=1 \
28 file://ldflags.patch;patch=1 \
29 file://cse.patch;patch=1 \
30 file://zecke-xgcc-cpp.patch;patch=1 "
31
32SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 "
33
34#Set the fortran bits
35FORTRAN = ""
36HAS_GFORTRAN = "no"
37HAS_G2C = "no"
38
39#Set the java bits
40JAVA_arm = ""
41
42LANGUAGES = "c,c++"
43require gcc3-build.inc
44
45
46EXTRA_OECONF += " --disable-libssp "
47