summaryrefslogtreecommitdiffstats
path: root/meta/packages/gcc/gcc-cross_4.1.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/gcc/gcc-cross_4.1.1.bb')
-rw-r--r--meta/packages/gcc/gcc-cross_4.1.1.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta/packages/gcc/gcc-cross_4.1.1.bb b/meta/packages/gcc/gcc-cross_4.1.1.bb
new file mode 100644
index 0000000000..4c530175f3
--- /dev/null
+++ b/meta/packages/gcc/gcc-cross_4.1.1.bb
@@ -0,0 +1,18 @@
1require gcc_${PV}.bb
2# path mangling, needed by the cross packaging
3require gcc-paths-cross.inc
4inherit cross
5FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gcc-${PV}"
6# NOTE: split PR. If the main .oe changes something that affects its *build*
7# remember to increment this one too.
8PR = "r6"
9
10DEPENDS = "virtual/${TARGET_PREFIX}binutils virtual/${TARGET_PREFIX}libc-for-gcc gmp-native mpfr-native"
11PROVIDES = "virtual/${TARGET_PREFIX}gcc virtual/${TARGET_PREFIX}g++"
12
13# cross build
14require gcc3-build-cross.inc
15# cross packaging
16require gcc-package-cross.inc
17
18EXTRA_OECONF += "--with-mpfr=${STAGING_DIR}/${BUILD_SYS}"