summaryrefslogtreecommitdiffstats
path: root/meta/packages/gcc/gcc-cross-sdk_4.1.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/gcc/gcc-cross-sdk_4.1.2.bb')
-rw-r--r--meta/packages/gcc/gcc-cross-sdk_4.1.2.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/packages/gcc/gcc-cross-sdk_4.1.2.bb b/meta/packages/gcc/gcc-cross-sdk_4.1.2.bb
new file mode 100644
index 0000000000..c95c2e5953
--- /dev/null
+++ b/meta/packages/gcc/gcc-cross-sdk_4.1.2.bb
@@ -0,0 +1,41 @@
1DESCRIPTION = "The GNU cc and gcc C compilers."
2HOMEPAGE = "http://www.gnu.org/software/gcc/"
3SECTION = "devel"
4LICENSE = "GPL"
5PR = "r0"
6
7inherit sdk
8
9FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gcc-${PV}"
10
11DEPENDS = "virtual/${TARGET_PREFIX}binutils virtual/${TARGET_PREFIX}libc-for-gcc"
12PACKAGES = "${PN}"
13
14require gcc_${PV}.bb
15require gcc4-build-sdk.inc
16require gcc-package-sdk.inc
17
18SRC_URI = "ftp://ftp.gnu.org/pub/gnu/gcc/gcc-4.1.2/gcc-4.1.2.tar.bz2 \
19 file://100-uclibc-conf.patch;patch=1 \
20 file://110-arm-eabi.patch;patch=1 \
21 file://200-uclibc-locale.patch;patch=1 \
22 file://300-libstdc++-pic.patch;patch=1 \
23 file://301-missing-execinfo_h.patch;patch=1 \
24 file://302-c99-snprintf.patch;patch=1 \
25 file://303-c99-complex-ugly-hack.patch;patch=1 \
26 file://304-index_macro.patch;patch=1 \
27 file://602-sdk-libstdc++-includes.patch;patch=1 \
28 file://740-sh-pr24836.patch;patch=1 \
29 file://800-arm-bigendian.patch;patch=1 \
30 file://arm-nolibfloat.patch;patch=1 \
31 file://arm-softfloat.patch;patch=1 \
32 file://gcc41-configure.in.patch;patch=1 \
33 file://arm-thumb.patch;patch=1 \
34 file://arm-thumb-cache.patch;patch=1 \
35 file://ldflags.patch;patch=1 \
36 file://unbreak-armv4t.patch;patch=1 \
37 file://fix-ICE-in-arm_unwind_emit_set.diff;patch=1 \
38 "
39
40SRC_URI_append_sh3 = " file://sh3-installfix-fixheaders.patch;patch=1 "
41