summaryrefslogtreecommitdiffstats
path: root/meta/packages/gcc/gcc-4.3.3/zecke-xgcc-cpp.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/gcc/gcc-4.3.3/zecke-xgcc-cpp.patch')
-rw-r--r--meta/packages/gcc/gcc-4.3.3/zecke-xgcc-cpp.patch24
1 files changed, 18 insertions, 6 deletions
diff --git a/meta/packages/gcc/gcc-4.3.3/zecke-xgcc-cpp.patch b/meta/packages/gcc/gcc-4.3.3/zecke-xgcc-cpp.patch
index 3ccd124764..a7722cbfc4 100644
--- a/meta/packages/gcc/gcc-4.3.3/zecke-xgcc-cpp.patch
+++ b/meta/packages/gcc/gcc-4.3.3/zecke-xgcc-cpp.patch
@@ -2,15 +2,27 @@ upstream: n/a
2comment: Use the preprocessor we have just compiled instead the one of 2comment: Use the preprocessor we have just compiled instead the one of
3the system. There might be incompabilities between us and them. 3the system. There might be incompabilities between us and them.
4 4
5Index: gcc-4.1.1/Makefile.in 5Index: gcc-4.3.1/Makefile.in
6=================================================================== 6===================================================================
7--- gcc-4.1.1.orig/Makefile.in 2006-08-06 13:32:44.000000000 +0200 7--- gcc-4.3.1.orig/Makefile.in 2008-08-19 01:09:56.000000000 -0700
8+++ gcc-4.1.1/Makefile.in 2006-08-06 13:32:46.000000000 +0200 8+++ gcc-4.3.1/Makefile.in 2008-08-19 01:13:27.000000000 -0700
9@@ -194,6 +194,7 @@ 9@@ -204,6 +204,7 @@
10 AR="$(AR_FOR_TARGET)"; export AR; \
10 AS="$(COMPILER_AS_FOR_TARGET)"; export AS; \ 11 AS="$(COMPILER_AS_FOR_TARGET)"; export AS; \
11 CC="$(CC_FOR_TARGET)"; export CC; \ 12 CC="$(CC_FOR_TARGET)"; export CC; \
12 CFLAGS="$(CFLAGS_FOR_TARGET)"; export CFLAGS; \
13+ CPP="$(CC_FOR_TARGET) -E"; export CPP; \ 13+ CPP="$(CC_FOR_TARGET) -E"; export CPP; \
14 CFLAGS="$(CFLAGS_FOR_TARGET) $(SYSROOT_CFLAGS_FOR_TARGET) $(DEBUG_PREFIX_CFLAGS_FOR_TARGET)"; export CFLAGS; \
15 CONFIG_SHELL="$(SHELL)"; export CONFIG_SHELL; \
16 CPPFLAGS="$(CPPFLAGS_FOR_TARGET)"; export CPPFLAGS; \
17Index: gcc-4.3.1/Makefile.tpl
18===================================================================
19--- gcc-4.3.1.orig/Makefile.tpl 2008-08-21 00:07:58.000000000 -0700
20+++ gcc-4.3.1/Makefile.tpl 2008-08-21 00:09:52.000000000 -0700
21@@ -223,6 +223,7 @@
22 AR="$(AR_FOR_TARGET)"; export AR; \
23 AS="$(COMPILER_AS_FOR_TARGET)"; export AS; \
24 CC="$(CC_FOR_TARGET)"; export CC; \
25+ CPP="$(CC_FOR_TARGET) -E"; export CPP; \
26 CFLAGS="$(CFLAGS_FOR_TARGET) $(SYSROOT_CFLAGS_FOR_TARGET) $(DEBUG_PREFIX_CFLAGS_FOR_TARGET)"; export CFLAGS; \
14 CONFIG_SHELL="$(SHELL)"; export CONFIG_SHELL; \ 27 CONFIG_SHELL="$(SHELL)"; export CONFIG_SHELL; \
15 CPPFLAGS="$(CPPFLAGS_FOR_TARGET)"; export CPPFLAGS; \ 28 CPPFLAGS="$(CPPFLAGS_FOR_TARGET)"; export CPPFLAGS; \
16 CXXFLAGS="$(CXXFLAGS_FOR_TARGET)"; export CXXFLAGS; \