summaryrefslogtreecommitdiffstats
path: root/meta/packages/gcc/gcc-4.3.1/debian/ppc64-ada.dpatch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/gcc/gcc-4.3.1/debian/ppc64-ada.dpatch')
-rw-r--r--meta/packages/gcc/gcc-4.3.1/debian/ppc64-ada.dpatch257
1 files changed, 257 insertions, 0 deletions
diff --git a/meta/packages/gcc/gcc-4.3.1/debian/ppc64-ada.dpatch b/meta/packages/gcc/gcc-4.3.1/debian/ppc64-ada.dpatch
new file mode 100644
index 0000000000..db9a229c40
--- /dev/null
+++ b/meta/packages/gcc/gcc-4.3.1/debian/ppc64-ada.dpatch
@@ -0,0 +1,257 @@
1#! /bin/sh -e
2
3# DP: Add gcc/ada/system-linux-ppc64.ads and use it in gcc/ada/Makefile.in
4# DP:
5
6dir=
7if [ $# -eq 3 -a "$2" = '-d' ]; then
8 pdir="-d $3"
9 dir="$3/"
10elif [ $# -ne 1 ]; then
11 echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
12 exit 1
13fi
14case "$1" in
15 -patch)
16 patch $pdir -f --no-backup-if-mismatch -p1 < $0
17 ;;
18 -unpatch)
19 patch $pdir -f --no-backup-if-mismatch -R -p1 < $0
20 ;;
21 *)
22 echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
23 exit 1
24esac
25exit 0
26
27diff -urN src.orig/gcc/ada/Makefile.in src/gcc/ada/Makefile.in
28--- src.orig/gcc/ada/Makefile.in 2005-05-02 16:39:32.000000000 +0200
29+++ src/gcc/ada/Makefile.in 2005-05-02 16:36:37.000000000 +0200
30@@ -1346,6 +1346,31 @@
31 LIBRARY_VERSION := $(LIB_VERSION)
32 endif
33
34+ifeq ($(strip $(filter-out powerpc64% linux%,$(arch) $(osys))),)
35+ LIBGNAT_TARGET_PAIRS = \
36+ a-intnam.ads<a-intnam-linux.ads \
37+ s-inmaop.adb<s-inmaop-posix.adb \
38+ s-intman.adb<s-intman-posix.adb \
39+ s-osinte.adb<s-osinte-posix.adb \
40+ s-osinte.ads<s-osinte-linux.ads \
41+ s-osprim.adb<s-osprim-posix.adb \
42+ s-taprop.adb<s-taprop-linux.adb \
43+ s-taspri.ads<s-taspri-linux.ads \
44+ s-tpopsp.adb<s-tpopsp-posix-foreign.adb \
45+ s-parame.adb<s-parame-linux.adb \
46+ system.ads<system-linux-ppc64.ads
47+
48+ TOOLS_TARGET_PAIRS = \
49+ mlib-tgt.adb<mlib-tgt-linux.adb \
50+ indepsw.adb<indepsw-linux.adb
51+
52+ THREADSLIB = -lpthread
53+ GNATLIB_SHARED = gnatlib-shared-dual
54+ GMEM_LIB = gmemlib
55+ PREFIX_OBJS = $(PREFIX_REAL_OBJS)
56+ LIBRARY_VERSION := $(LIB_VERSION)
57+endif
58+
59 ifeq ($(strip $(filter-out sparc% linux%,$(arch) $(osys))),)
60 LIBGNAT_TARGET_PAIRS = \
61 a-intnam.ads<a-intnam-linux.ads \
62diff -urN src.orig/gcc/ada/system-linux-ppc64.ads src/gcc/ada/system-linux-ppc64.ads
63--- src.orig/gcc/ada/system-linux-ppc64.ads 1970-01-01 01:00:00.000000000 +0100
64+++ src/gcc/ada/system-linux-ppc64.ads 2005-05-02 16:33:38.000000000 +0200
65@@ -0,0 +1,151 @@
66+------------------------------------------------------------------------------
67+-- --
68+-- GNAT RUN-TIME COMPONENTS --
69+-- --
70+-- S Y S T E M --
71+-- --
72+-- S p e c --
73+-- (GNU-Linux/PPC64 Version) --
74+-- --
75+-- Copyright (C) 1992-2004 Free Software Foundation, Inc. --
76+-- --
77+-- This specification is derived from the Ada Reference Manual for use with --
78+-- GNAT. The copyright notice above, and the license provisions that follow --
79+-- apply solely to the contents of the part following the private keyword. --
80+-- --
81+-- GNAT is free software; you can redistribute it and/or modify it under --
82+-- terms of the GNU General Public License as published by the Free Soft- --
83+-- ware Foundation; either version 2, or (at your option) any later ver- --
84+-- sion. GNAT is distributed in the hope that it will be useful, but WITH- --
85+-- OUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY --
86+-- or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License --
87+-- for more details. You should have received a copy of the GNU General --
88+-- Public License distributed with GNAT; see file COPYING. If not, write --
89+-- to the Free Software Foundation, 59 Temple Place - Suite 330, Boston, --
90+-- MA 02111-1307, USA. --
91+-- --
92+-- As a special exception, if other files instantiate generics from this --
93+-- unit, or you link this unit with other files to produce an executable, --
94+-- this unit does not by itself cause the resulting executable to be --
95+-- covered by the GNU General Public License. This exception does not --
96+-- however invalidate any other reasons why the executable file might be --
97+-- covered by the GNU Public License. --
98+-- --
99+-- GNAT was originally developed by the GNAT team at New York University. --
100+-- Extensive contributions were provided by Ada Core Technologies Inc. --
101+-- --
102+------------------------------------------------------------------------------
103+
104+package System is
105+pragma Pure (System);
106+-- Note that we take advantage of the implementation permission to
107+-- make this unit Pure instead of Preelaborable, see RM 13.7(36)
108+
109+ type Name is (SYSTEM_NAME_GNAT);
110+ System_Name : constant Name := SYSTEM_NAME_GNAT;
111+
112+ -- System-Dependent Named Numbers
113+
114+ Min_Int : constant := Long_Long_Integer'First;
115+ Max_Int : constant := Long_Long_Integer'Last;
116+
117+ Max_Binary_Modulus : constant := 2 ** Long_Long_Integer'Size;
118+ Max_Nonbinary_Modulus : constant := Integer'Last;
119+
120+ Max_Base_Digits : constant := Long_Long_Float'Digits;
121+ Max_Digits : constant := Long_Long_Float'Digits;
122+
123+ Max_Mantissa : constant := 63;
124+ Fine_Delta : constant := 2.0 ** (-Max_Mantissa);
125+
126+ Tick : constant := 0.000_001;
127+
128+ -- Storage-related Declarations
129+
130+ type Address is private;
131+ Null_Address : constant Address;
132+
133+ Storage_Unit : constant := 8;
134+ Word_Size : constant := 64;
135+ Memory_Size : constant := 2 ** 64;
136+
137+ -- Address comparison
138+
139+ function "<" (Left, Right : Address) return Boolean;
140+ function "<=" (Left, Right : Address) return Boolean;
141+ function ">" (Left, Right : Address) return Boolean;
142+ function ">=" (Left, Right : Address) return Boolean;
143+ function "=" (Left, Right : Address) return Boolean;
144+
145+ pragma Import (Intrinsic, "<");
146+ pragma Import (Intrinsic, "<=");
147+ pragma Import (Intrinsic, ">");
148+ pragma Import (Intrinsic, ">=");
149+ pragma Import (Intrinsic, "=");
150+
151+ -- Other System-Dependent Declarations
152+
153+ type Bit_Order is (High_Order_First, Low_Order_First);
154+ Default_Bit_Order : constant Bit_Order := High_Order_First;
155+
156+ -- Priority-related Declarations (RM D.1)
157+
158+ Max_Priority : constant Positive := 30;
159+ Max_Interrupt_Priority : constant Positive := 31;
160+
161+ subtype Any_Priority is Integer range 0 .. 31;
162+ subtype Priority is Any_Priority range 0 .. 30;
163+ subtype Interrupt_Priority is Any_Priority range 31 .. 31;
164+
165+ Default_Priority : constant Priority := 15;
166+
167+private
168+
169+ type Address is mod Memory_Size;
170+ Null_Address : constant Address := 0;
171+
172+ --------------------------------------
173+ -- System Implementation Parameters --
174+ --------------------------------------
175+
176+ -- These parameters provide information about the target that is used
177+ -- by the compiler. They are in the private part of System, where they
178+ -- can be accessed using the special circuitry in the Targparm unit
179+ -- whose source should be consulted for more detailed descriptions
180+ -- of the individual switch values.
181+
182+ AAMP : constant Boolean := False;
183+ Backend_Divide_Checks : constant Boolean := False;
184+ Backend_Overflow_Checks : constant Boolean := False;
185+ Command_Line_Args : constant Boolean := True;
186+ Configurable_Run_Time : constant Boolean := False;
187+ Denorm : constant Boolean := True;
188+ Duration_32_Bits : constant Boolean := False;
189+ Exit_Status_Supported : constant Boolean := True;
190+ Fractional_Fixed_Ops : constant Boolean := False;
191+ Frontend_Layout : constant Boolean := False;
192+ Functions_Return_By_DSP : constant Boolean := False;
193+ Machine_Overflows : constant Boolean := False;
194+ Machine_Rounds : constant Boolean := True;
195+ OpenVMS : constant Boolean := False;
196+ Preallocated_Stacks : constant Boolean := False;
197+ Signed_Zeros : constant Boolean := True;
198+ Stack_Check_Default : constant Boolean := False;
199+ Stack_Check_Probes : constant Boolean := False;
200+ Support_64_Bit_Divides : constant Boolean := True;
201+ Support_Aggregates : constant Boolean := True;
202+ Support_Composite_Assign : constant Boolean := True;
203+ Support_Composite_Compare : constant Boolean := True;
204+ Support_Long_Shifts : constant Boolean := True;
205+ Suppress_Standard_Library : constant Boolean := False;
206+ Use_Ada_Main_Program_Name : constant Boolean := False;
207+ ZCX_By_Default : constant Boolean := True;
208+ GCC_ZCX_Support : constant Boolean := True;
209+ Front_End_ZCX_Support : constant Boolean := False;
210+
211+ -- Obsolete entries, to be removed eventually (bootstrap issues!)
212+
213+ High_Integrity_Mode : constant Boolean := False;
214+ Long_Shifts_Inlined : constant Boolean := True;
215+
216+end System;
217diff -urN tmp/gcc/ada/s-auxdec.ads src/gcc/ada/s-auxdec.ads
218--- tmp/gcc/ada/s-auxdec.ads 2004-06-11 12:47:36.000000000 +0200
219+++ src/gcc/ada/s-auxdec.ads 2005-05-03 11:34:17.000000000 +0200
220@@ -108,13 +108,13 @@
221 pragma Warnings (Off);
222
223 type F_Float is digits 6;
224- pragma Float_Representation (VAX_Float, F_Float);
225+-- pragma Float_Representation (VAX_Float, F_Float);
226
227 type D_Float is digits 9;
228- pragma Float_Representation (Vax_Float, D_Float);
229+-- pragma Float_Representation (Vax_Float, D_Float);
230
231 type G_Float is digits 15;
232- pragma Float_Representation (Vax_Float, G_Float);
233+-- pragma Float_Representation (Vax_Float, G_Float);
234
235 -- Floating point type declarations for IEEE floating point data types
236
237--- tmp/gcc/ada/s-vaflop.ads 2003-10-21 15:42:18.000000000 +0200
238+++ src/gcc/ada/s-vaflop.ads 2005-05-03 15:24:24.000000000 +0200
239@@ -40,15 +40,15 @@
240 -- Suppress warnings if not on Alpha/VAX
241
242 type D is digits 9;
243- pragma Float_Representation (VAX_Float, D);
244+-- pragma Float_Representation (VAX_Float, D);
245 -- D Float type on Vax
246
247 type G is digits 15;
248- pragma Float_Representation (VAX_Float, G);
249+-- pragma Float_Representation (VAX_Float, G);
250 -- G Float type on Vax
251
252 type F is digits 6;
253- pragma Float_Representation (VAX_Float, F);
254+-- pragma Float_Representation (VAX_Float, F);
255 -- F Float type on Vax
256
257 type S is digits 6;