summaryrefslogtreecommitdiffstats
path: root/meta/packages/gcc/gcc-4.3.1/debian/libssp-gnu.dpatch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/gcc/gcc-4.3.1/debian/libssp-gnu.dpatch')
-rw-r--r--meta/packages/gcc/gcc-4.3.1/debian/libssp-gnu.dpatch52
1 files changed, 52 insertions, 0 deletions
diff --git a/meta/packages/gcc/gcc-4.3.1/debian/libssp-gnu.dpatch b/meta/packages/gcc/gcc-4.3.1/debian/libssp-gnu.dpatch
new file mode 100644
index 0000000000..a0c6acd9fc
--- /dev/null
+++ b/meta/packages/gcc/gcc-4.3.1/debian/libssp-gnu.dpatch
@@ -0,0 +1,52 @@
1#! /bin/sh -e
2
3# DP: GNU/k*BSD support
4# Author: Aurelien Jarno <aurel32@debian.org>
5# Status: Submitted: http://gcc.gnu.org/ml/gcc-patches/2007-04/msg01962.html
6
7dir=
8if [ $# -eq 3 -a "$2" = '-d' ]; then
9 pdir="-d $3"
10 dir="$3/"
11elif [ $# -ne 1 ]; then
12 echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
13 exit 1
14fi
15case "$1" in
16 -patch)
17 patch $pdir -f --no-backup-if-mismatch -p1 < $0
18 ;;
19 -unpatch)
20 patch $pdir -f --no-backup-if-mismatch -R -p1 < $0
21 ;;
22 *)
23 echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
24 exit 1
25esac
26exit 0
27
28# append the patch here and adjust the -p? flag in the patch calls.
29
30--- src.orig/gcc/configure 2008-03-01 15:51:06 +0100
31+++ src/gcc/configure 2008-03-01 16:02:24 +0100
32@@ -17110,7 +17110,7 @@
33 else
34 gcc_cv_libc_provides_ssp=no
35 case "$target" in
36- *-*-linux*)
37+ *-*-*-gnu*)
38 if test x$host != x$target || test "x$TARGET_SYSTEM_ROOT" != x; then
39 if test "x$with_sysroot" = x; then
40 glibc_header_dir="${exec_prefix}/${target_noncanonical}/sys-include"
41--- src.orig/gcc/configure.ac 2008-02-01 19:55:55 +0100
42+++ src/gcc/configure.ac 2008-03-01 16:02:06 +0100
43@@ -3379,7 +3379,7 @@
44 gcc_cv_libc_provides_ssp,
45 [gcc_cv_libc_provides_ssp=no
46 case "$target" in
47- *-*-linux*)
48+ *-*-*-gnu*)
49 if test x$host != x$target || test "x$TARGET_SYSTEM_ROOT" != x; then
50 if test "x$with_sysroot" = x; then
51 glibc_header_dir="${exec_prefix}/${target_noncanonical}/sys-include"
52