summaryrefslogtreecommitdiffstats
path: root/meta/packages/gcc/gcc-4.3.1/debian/libffi-configure.dpatch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/gcc/gcc-4.3.1/debian/libffi-configure.dpatch')
-rw-r--r--meta/packages/gcc/gcc-4.3.1/debian/libffi-configure.dpatch45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta/packages/gcc/gcc-4.3.1/debian/libffi-configure.dpatch b/meta/packages/gcc/gcc-4.3.1/debian/libffi-configure.dpatch
new file mode 100644
index 0000000000..8cc9d23550
--- /dev/null
+++ b/meta/packages/gcc/gcc-4.3.1/debian/libffi-configure.dpatch
@@ -0,0 +1,45 @@
1#! /bin/sh -e
2
3# DP: Add --enable-libffi option to toplevel configure script
4
5dir=
6if [ $# -eq 3 -a "$2" = '-d' ]; then
7 pdir="-d $3"
8 dir="$3/"
9elif [ $# -ne 1 ]; then
10 echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
11 exit 1
12fi
13case "$1" in
14 -patch)
15 patch $pdir -f --no-backup-if-mismatch -p0 < $0
16 cd ${dir} && autoconf
17 ;;
18 -unpatch)
19 patch $pdir -f --no-backup-if-mismatch -R -p0 < $0
20 ;;
21 *)
22 echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
23 exit 1
24esac
25exit 0
26
27--- configure.ac.orig 2007-08-27 13:42:57.000000000 +0200
28+++ configure.ac 2007-09-01 15:57:19.664811738 +0200
29@@ -347,6 +347,16 @@
30 ENABLE_LIBSSP=$enableval,
31 ENABLE_LIBSSP=yes)
32
33+AC_ARG_ENABLE(libffi,
34+[ --enable-libffi build libffi directory],
35+ENABLE_LIBFFI=$enableval,
36+ENABLE_LIBFFI=yes)
37+if test "${ENABLE_LIBFFI}" != "yes" ; then
38+ noconfigdirs="$noconfigdirs target-libffi"
39+else
40+ libgcj="`echo $libgcj | sed 's/target-libffi *//'`"
41+fi
42+
43 # Save it here so that, even in case of --enable-libgcj, if the Java
44 # front-end isn't enabled, we still get libgcj disabled.
45 libgcj_saved=$libgcj