summaryrefslogtreecommitdiffstats
path: root/meta/packages/gcc/gcc-4.3.1/debian/deb-protoize.dpatch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/gcc/gcc-4.3.1/debian/deb-protoize.dpatch')
-rw-r--r--meta/packages/gcc/gcc-4.3.1/debian/deb-protoize.dpatch47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta/packages/gcc/gcc-4.3.1/debian/deb-protoize.dpatch b/meta/packages/gcc/gcc-4.3.1/debian/deb-protoize.dpatch
new file mode 100644
index 0000000000..f86ee09942
--- /dev/null
+++ b/meta/packages/gcc/gcc-4.3.1/debian/deb-protoize.dpatch
@@ -0,0 +1,47 @@
1#! /bin/sh -e
2
3# DP: build protoize/unprotoize binaries
4
5if [ $# -eq 3 -a "$2" = '-d' ]; then
6 pdir="-d $3"
7elif [ $# -ne 1 ]; then
8 echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
9 exit 1
10fi
11case "$1" in
12 -patch) patch $pdir -f --no-backup-if-mismatch -p0 < $0;;
13 -unpatch) patch $pdir -f --no-backup-if-mismatch -R -p0 < $0;;
14 *)
15 echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
16 exit 1
17esac
18exit 0
19
20--- gcc/Makefile.in.orig 2007-09-06 21:31:39.864036975 +0200
21+++ gcc/Makefile.in 2007-09-06 21:33:57.836118252 +0200
22@@ -137,7 +137,7 @@
23
24 # Selection of languages to be made.
25 CONFIG_LANGUAGES = @all_selected_languages@
26-LANGUAGES = c gcov$(exeext) gcov-dump$(exeext) $(CONFIG_LANGUAGES)
27+LANGUAGES = c proto gcov$(exeext) gcov-dump$(exeext) $(CONFIG_LANGUAGES)
28
29 # Various ways of specifying flags for compilations:
30 # CFLAGS is for the user to override to, e.g., do a cross build with -O2.
31@@ -3280,14 +3280,14 @@
32 protoize.o: protoize.c $(srcdir)/../include/getopt.h $(CONFIG_H) $(SYSTEM_H) \
33 coretypes.h $(TM_H) Makefile version.h cppdefault.h intl.h
34 (SHLIB_LINK='$(SHLIB_LINK)'; \
35- $(CC) -c $(ALL_CFLAGS) $(ALL_CPPFLAGS) \
36+ $(CC) -c $(ALL_CFLAGS) $(ALL_CPPFLAGS) -Wno-error \
37 $(DRIVER_DEFINES) \
38 $(srcdir)/protoize.c $(OUTPUT_OPTION))
39
40 unprotoize.o: protoize.c $(srcdir)/../include/getopt.h $(CONFIG_H) \
41 $(SYSTEM_H) coretypes.h $(TM_H) Makefile version.h cppdefault.h intl.h
42 (SHLIB_LINK='$(SHLIB_LINK)'; \
43- $(CC) -c -DUNPROTOIZE $(ALL_CFLAGS) $(ALL_CPPFLAGS) \
44+ $(CC) -c -DUNPROTOIZE $(ALL_CFLAGS) $(ALL_CPPFLAGS) -Wno-error \
45 $(DRIVER_DEFINES) \
46 $(srcdir)/protoize.c $(OUTPUT_OPTION))
47