summaryrefslogtreecommitdiffstats
path: root/meta/packages/gcc/gcc-4.3.1/debian/cross-include.dpatch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/gcc/gcc-4.3.1/debian/cross-include.dpatch')
-rw-r--r--meta/packages/gcc/gcc-4.3.1/debian/cross-include.dpatch39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/packages/gcc/gcc-4.3.1/debian/cross-include.dpatch b/meta/packages/gcc/gcc-4.3.1/debian/cross-include.dpatch
new file mode 100644
index 0000000000..c2622903ec
--- /dev/null
+++ b/meta/packages/gcc/gcc-4.3.1/debian/cross-include.dpatch
@@ -0,0 +1,39 @@
1#! /bin/sh -e
2
3# DP: Set cross include path to .../include, not .../sys-include
4# DP: This should be a fix for famous limits.h issue
5
6dir=
7if [ $# -eq 3 -a "$2" = '-d' ]; then
8 pdir="-d $3"
9 dir="$3/"
10elif [ $# -ne 1 ]; then
11 echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
12 exit 1
13fi
14case "$1" in
15 -patch)
16 patch $pdir -f --no-backup-if-mismatch -p0 < $0
17 cd ${dir}gcc && autoconf
18 ;;
19 -unpatch)
20 patch $pdir -f --no-backup-if-mismatch -R -p0 < $0
21 cd ${dir}gcc && autoconf
22 ;;
23 *)
24 echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
25 exit 1
26esac
27exit 0
28
29--- gcc/configure.ac.orig 2005-08-24 06:24:11.000000000 +0400
30+++ gcc/configure.ac 2005-12-06 00:40:45.000000000 +0300
31@@ -681,7 +681,7 @@
32 ], [
33 TARGET_SYSTEM_ROOT=
34 TARGET_SYSTEM_ROOT_DEFINE=
35- CROSS_SYSTEM_HEADER_DIR='$(gcc_tooldir)/sys-include'
36+ CROSS_SYSTEM_HEADER_DIR='$(prefix)/$(target_noncanonical)/include'
37 ])
38 AC_SUBST(TARGET_SYSTEM_ROOT)
39 AC_SUBST(TARGET_SYSTEM_ROOT_DEFINE)