summaryrefslogtreecommitdiffstats
path: root/meta/packages/gcc/gcc-4.3.0.inc
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/gcc/gcc-4.3.0.inc')
-rw-r--r--meta/packages/gcc/gcc-4.3.0.inc53
1 files changed, 53 insertions, 0 deletions
diff --git a/meta/packages/gcc/gcc-4.3.0.inc b/meta/packages/gcc/gcc-4.3.0.inc
new file mode 100644
index 0000000000..1d7184ca7a
--- /dev/null
+++ b/meta/packages/gcc/gcc-4.3.0.inc
@@ -0,0 +1,53 @@
1# No uclibc, armeb and thumb patches - really needs checking
2DEFAULT_PREFERENCE = "-99"
3
4require gcc-common.inc
5
6DEPENDS = "mpfr gmp"
7
8SRC_URI = "ftp://ftp.gnu.org/pub/gnu/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
9# file://100-uclibc-conf.patch;patch=1 \
10# file://103-uclibc-conf-noupstream.patch;patch=1 \
11# file://200-uclibc-locale.patch;patch=1 \
12# file://203-uclibc-locale-no__x.patch;patch=1 \
13# file://204-uclibc-locale-wchar_fix.patch;patch=1 \
14# file://205-uclibc-locale-update.patch;patch=1 \
15 file://300-libstdc++-pic.patch;patch=1 \
16 file://301-missing-execinfo_h.patch;patch=1 \
17# file://302-c99-snprintf.patch;patch=1 \
18# file://303-c99-complex-ugly-hack.patch;patch=1 \
19 file://304-index_macro.patch;patch=1 \
20 file://305-libmudflap-susv3-legacy.patch;patch=1 \
21# file://306-libstdc++-namespace.patch;patch=1 \
22# file://307-locale_facets.patch;patch=1 \
23# file://402-libbackend_dep_gcov-iov.h.patch;patch=1 \
24 file://602-sdk-libstdc++-includes.patch;patch=1 \
25 file://740-sh-pr24836.patch;patch=1 \
26# file://800-arm-bigendian.patch;patch=1 \
27# file://801-arm-bigendian-eabi.patch;patch=1 \
28 file://904-flatten-switch-stmt-00.patch;patch=1 \
29 file://arm-nolibfloat.patch;patch=1 \
30 file://arm-softfloat.patch;patch=1 \
31# file://gcc41-configure.in.patch;patch=1 \
32# file://arm-thumb.patch;patch=1 \
33# file://arm-thumb-cache.patch;patch=1 \
34 file://ldflags.patch;patch=1 \
35 file://zecke-xgcc-cpp.patch;patch=1 \
36# file://unbreak-armv4t.patch;patch=1 \
37 file://fix-ICE-in-arm_unwind_emit_set.diff;patch=1 \
38 file://cache-amnesia.patch;patch=1 \
39 file://gfortran.patch;patch=1 \
40# file://gcc-4.0.2-e300c2c3.patch;patch=1 \
41# file://pr34130.patch;patch=1 \
42# file://fortran-static-linking.patch;patch=1 \
43# file://intermask-bigendian.patch;patch=1 \
44"
45
46SRC_URI_append_sh3 = " file://sh3-installfix-fixheaders.patch;patch=1 "
47
48# Language Overrides
49FORTRAN = ""
50JAVA = ""
51
52EXTRA_OECONF_BASE = " --disable-libssp --disable-bootstrap --disable-libgomp --disable-libmudflap"
53