summaryrefslogtreecommitdiffstats
path: root/meta/packages/gcc/gcc-4.1.2.inc
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/gcc/gcc-4.1.2.inc')
-rw-r--r--meta/packages/gcc/gcc-4.1.2.inc60
1 files changed, 0 insertions, 60 deletions
diff --git a/meta/packages/gcc/gcc-4.1.2.inc b/meta/packages/gcc/gcc-4.1.2.inc
deleted file mode 100644
index f590778e47..0000000000
--- a/meta/packages/gcc/gcc-4.1.2.inc
+++ /dev/null
@@ -1,60 +0,0 @@
1require gcc-common.inc
2
3DEPENDS =+ "mpfr gmp"
4
5SRC_URI = "ftp://ftp.gnu.org/pub/gnu/gcc/gcc-4.1.2/gcc-4.1.2.tar.bz2 \
6 file://100-uclibc-conf.patch;patch=1 \
7 file://110-arm-eabi.patch;patch=1 \
8 file://200-uclibc-locale.patch;patch=1 \
9 file://300-libstdc++-pic.patch;patch=1 \
10 file://301-missing-execinfo_h.patch;patch=1 \
11 file://302-c99-snprintf.patch;patch=1 \
12 file://303-c99-complex-ugly-hack.patch;patch=1 \
13 file://304-index_macro.patch;patch=1 \
14 file://602-sdk-libstdc++-includes.patch;patch=1 \
15 file://740-sh-pr24836.patch;patch=1 \
16 file://800-arm-bigendian.patch;patch=1 \
17 file://arm-nolibfloat.patch;patch=1 \
18 file://arm-softfloat.patch;patch=1 \
19 file://gcc41-configure.in.patch;patch=1 \
20 file://arm-thumb.patch;patch=1 \
21 file://arm-thumb-cache.patch;patch=1 \
22 file://ldflags.patch;patch=1 \
23 file://zecke-xgcc-cpp.patch;patch=1 \
24 file://unbreak-armv4t.patch;patch=1 \
25 file://fix-ICE-in-arm_unwind_emit_set.diff;patch=1 \
26 file://cache-amnesia.patch;patch=1 \
27 file://gfortran.patch;patch=1 \
28 file://gcc-4.0.2-e300c2c3.patch;patch=1 \
29 file://pr34130.patch;patch=1 \
30 "
31
32SRC_URI_append_sh3 = " file://sh3-installfix-fixheaders.patch;patch=1 "
33
34SRC_URI_avr32 = "http://www.angstrom-distribution.org/unstable/sources/gcc-4.1.2-atmel.1.1.0.tar.gz \
35# file://100-uclibc-conf.patch;patch=1 \
36# file://200-uclibc-locale.patch;patch=1 \
37# file://300-libstdc++-pic.patch;patch=1 \
38 file://301-missing-execinfo_h.patch;patch=1 \
39 file://302-c99-snprintf.patch;patch=1 \
40 file://303-c99-complex-ugly-hack.patch;patch=1 \
41 file://304-index_macro.patch;patch=1 \
42 file://602-sdk-libstdc++-includes.patch;patch=1 \
43 file://gcc41-configure.in.patch;patch=1 \
44 file://ldflags.patch;patch=1 \
45 file://zecke-xgcc-cpp.patch;patch=1 \
46 file://cache-amnesia.patch;patch=1 \
47 "
48
49do_compile_prepend_avr32() {
50 ln -sf ${S}/libstdc++-v3/config/os/uclibc/ ${S}/libstdc++-v3/config/os/uclibc-linux
51}
52
53
54# Language Overrides
55FORTRAN = ""
56JAVA = ""
57
58EXTRA_OECONF_BASE = "--disable-libssp --disable-libmudflap"
59
60ARM_INSTRUCTION_SET = "arm"