summaryrefslogtreecommitdiffstats
path: root/meta/packages/gcc/gcc-4.0.2/100-uclibc-conf.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/gcc/gcc-4.0.2/100-uclibc-conf.patch')
-rw-r--r--meta/packages/gcc/gcc-4.0.2/100-uclibc-conf.patch556
1 files changed, 556 insertions, 0 deletions
diff --git a/meta/packages/gcc/gcc-4.0.2/100-uclibc-conf.patch b/meta/packages/gcc/gcc-4.0.2/100-uclibc-conf.patch
new file mode 100644
index 0000000000..35445522f8
--- /dev/null
+++ b/meta/packages/gcc/gcc-4.0.2/100-uclibc-conf.patch
@@ -0,0 +1,556 @@
1From:
2http://buildroot.uclibc.org/cgi-bin/viewcvs.cgi/*checkout*/trunk/buildroot/toolchain/gcc/4.0.2/100-uclibc-conf.patch?rev=13898
3
4--- gcc-4.0.2/gcc/config/t-linux-uclibc
5+++ gcc-4.0.2/gcc/config/t-linux-uclibc
6@@ -0,0 +1,5 @@
7+# Remove glibc specific files added in t-linux
8+SHLIB_MAPFILES := $(filter-out $(srcdir)/config/libgcc-glibc.ver, $(SHLIB_MAPFILES))
9+
10+# Use unwind-dw2-fde instead of unwind-dw2-fde-glibc
11+LIB2ADDEH := $(subst unwind-dw2-fde-glibc.c,unwind-dw2-fde.c,$(LIB2ADDEH))
12--- gcc-4.0.2/gcc/config.gcc
13+++ gcc-4.0.2/gcc/config.gcc
14@@ -1778,7 +1778,7 @@
15 ;;
16 sh-*-elf* | sh[12346l]*-*-elf* | sh*-*-kaos* | \
17 sh-*-symbianelf* | sh[12346l]*-*-symbianelf* | \
18- sh-*-linux* | sh[346lbe]*-*-linux* | \
19+ sh*-*-linux* | sh[346lbe]*-*-linux* | \
20 sh-*-netbsdelf* | shl*-*-netbsdelf* | sh5-*-netbsd* | sh5l*-*-netbsd* | \
21 sh64-*-netbsd* | sh64l*-*-netbsd*)
22 tmake_file="${tmake_file} sh/t-sh sh/t-elf"
23@@ -2234,10 +2234,16 @@
24 *)
25 echo "*** Configuration ${target} not supported" 1>&2
26 exit 1
27 ;;
28 esac
29+
30+# Rather than hook into each target, just do it after all the linux
31+# targets have been processed
32+case ${target} in
33+*-linux-uclibc*) tm_defines="${tm_defines} USE_UCLIBC" ; tmake_file="${tmake_file} t-linux-uclibc"
34+esac
35
36 case ${target} in
37 i[34567]86-*-linux*aout* | i[34567]86-*-linux*libc1)
38 tmake_file="${tmake_file} i386/t-gmm_malloc"
39 ;;
40--- gcc-4.0.2/gcc/config/alpha/linux-elf.h
41+++ gcc-4.0.2/gcc/config/alpha/linux-elf.h
42@@ -27,7 +27,11 @@
43 #define SUBTARGET_EXTRA_SPECS \
44 { "elf_dynamic_linker", ELF_DYNAMIC_LINKER },
45
46+#ifdef USE_UCLIBC
47+#define ELF_DYNAMIC_LINKER "/lib/ld-uClibc.so.0"
48+#else
49 #define ELF_DYNAMIC_LINKER "/lib/ld-linux.so.2"
50+#endif
51
52 #define LINK_SPEC "-m elf64alpha %{G*} %{relax:-relax} \
53 %{O*:-O3} %{!O*:-O1} \
54--- gcc-4.0.2/gcc/config/arm/linux-elf.h
55+++ gcc-4.0.2/gcc/config/arm/linux-elf.h
56@@ -81,14 +81,19 @@
57 #define ENDFILE_SPEC \
58 "%{!shared:crtend.o%s} %{shared:crtendS.o%s} crtn.o%s"
59
60+#ifdef USE_UCLIBC
61+#define ELF_DYNAMIC_LINKER "/lib/ld-uClibc.so.0"
62+#else
63+#define ELF_DYNAMIC_LINKER "/lib/ld-linux.so.2"
64+#endif
65 #undef LINK_SPEC
66 #define LINK_SPEC "%{h*} %{version:-v} \
67 %{b} %{Wl,*:%*} \
68 %{static:-Bstatic} \
69 %{shared:-shared} \
70 %{symbolic:-Bsymbolic} \
71 %{rdynamic:-export-dynamic} \
72- %{!dynamic-linker:-dynamic-linker /lib/ld-linux.so.2} \
73+ %{!dynamic-linker:-dynamic-linker " ELF_DYNAMIC_LINKER "} \
74 -X \
75 %{mbig-endian:-EB}" \
76 SUBTARGET_EXTRA_LINK_SPEC
77--- gcc-4.0.2/gcc/config/cris/linux.h
78+++ gcc-4.0.2/gcc/config/cris/linux.h
79@@ -79,6 +79,25 @@
80 #undef CRIS_DEFAULT_CPU_VERSION
81 #define CRIS_DEFAULT_CPU_VERSION CRIS_CPU_NG
82
83+#ifdef USE_UCLIBC
84+
85+#undef CRIS_SUBTARGET_VERSION
86+#define CRIS_SUBTARGET_VERSION " - cris-axis-linux-uclibc"
87+
88+#undef CRIS_LINK_SUBTARGET_SPEC
89+#define CRIS_LINK_SUBTARGET_SPEC \
90+ "-mcrislinux\
91+ -rpath-link include/asm/../..%s\
92+ %{shared} %{static}\
93+ %{symbolic:-Bdynamic} %{shlib:-Bdynamic} %{static:-Bstatic}\
94+ %{!shared: \
95+ %{!static: \
96+ %{rdynamic:-export-dynamic} \
97+ %{!dynamic-linker:-dynamic-linker /lib/ld-uClibc.so.0}}} \
98+ %{!r:%{O2|O3: --gc-sections}}"
99+
100+#else /* USE_UCLIBC */
101+
102 #undef CRIS_SUBTARGET_VERSION
103 #define CRIS_SUBTARGET_VERSION " - cris-axis-linux-gnu"
104
105@@ -93,6 +112,8 @@
106 %{!shared:%{!static:%{rdynamic:-export-dynamic}}}\
107 %{!r:%{O2|O3: --gc-sections}}"
108
109+#endif /* USE_UCLIBC */
110+
111
112 /* Node: Run-time Target */
113
114--- gcc-4.0.2/gcc/config/i386/linux.h
115+++ gcc-4.0.2/gcc/config/i386/linux.h
116@@ -107,6 +107,11 @@
117 #define LINK_EMULATION "elf_i386"
118 #define DYNAMIC_LINKER "/lib/ld-linux.so.2"
119
120+#ifdef USE_UCLIBC
121+#undef DYNAMIC_LINKER
122+#define DYNAMIC_LINKER "/lib/ld-uClibc.so.0"
123+#endif
124+
125 #undef SUBTARGET_EXTRA_SPECS
126 #define SUBTARGET_EXTRA_SPECS \
127 { "link_emulation", LINK_EMULATION },\
128--- gcc-4.0.2/gcc/config/i386/linux64.h
129+++ gcc-4.0.2/gcc/config/i386/linux64.h
130@@ -54,14 +54,21 @@
131 When the -shared link option is used a final link is not being
132 done. */
133
134+#ifdef USE_UCLIBC
135+#define ELF32_DYNAMIC_LINKER "/lib/ld-uClibc.so.0"
136+#define ELF64_DYNAMIC_LINKER "/lib/ld64-uClibc.so.0"
137+#else
138+#define ELF32_DYNAMIC_LINKER "/lib/ld-linux.so.2"
139+#define ELF64_DYNAMIC_LINKER "/lib64/ld-linux-x86-64.so.2"
140+#endif
141 #undef LINK_SPEC
142 #define LINK_SPEC "%{!m32:-m elf_x86_64} %{m32:-m elf_i386} \
143 %{shared:-shared} \
144 %{!shared: \
145 %{!static: \
146 %{rdynamic:-export-dynamic} \
147- %{m32:%{!dynamic-linker:-dynamic-linker /lib/ld-linux.so.2}} \
148- %{!m32:%{!dynamic-linker:-dynamic-linker /lib64/ld-linux-x86-64.so.2}}} \
149+ %{m32:%{!dynamic-linker:-dynamic-linker " ELF32_DYNAMIC_LINKER "}} \
150+ %{!m32:%{!dynamic-linker:-dynamic-linker " ELF64_DYNAMIC_LINKER "}}} \
151 %{static:-static}}"
152
153 #define MULTILIB_DEFAULTS { "m64" }
154--- gcc-4.0.2/gcc/config/ia64/linux.h
155+++ gcc-4.0.2/gcc/config/ia64/linux.h
156@@ -37,13 +37,18 @@
157 /* Define this for shared library support because it isn't in the main
158 linux.h file. */
159
160+#ifdef USE_UCLIBC
161+#define ELF_DYNAMIC_LINKER "/lib/ld-uClibc.so.0"
162+#else
163+#define ELF_DYNAMIC_LINKER "/lib/ld-linux-ia64.so.2"
164+#endif
165 #undef LINK_SPEC
166 #define LINK_SPEC "\
167 %{shared:-shared} \
168 %{!shared: \
169 %{!static: \
170 %{rdynamic:-export-dynamic} \
171- %{!dynamic-linker:-dynamic-linker /lib/ld-linux-ia64.so.2}} \
172+ %{!dynamic-linker:-dynamic-linker " ELF_DYNAMIC_LINKER "}} \
173 %{static:-static}}"
174
175
176--- gcc-4.0.2/gcc/config/m68k/linux.h
177+++ gcc-4.0.2/gcc/config/m68k/linux.h
178@@ -127,12 +127,17 @@
179
180 /* If ELF is the default format, we should not use /lib/elf. */
181
182+#ifdef USE_UCLIBC
183+#define ELF_DYNAMIC_LINKER "/lib/ld-uClibc.so.0"
184+#else
185+#define ELF_DYNAMIC_LINKER "/lib/ld.so.1"
186+#endif
187 #undef LINK_SPEC
188 #define LINK_SPEC "-m m68kelf %{shared} \
189 %{!shared: \
190 %{!static: \
191 %{rdynamic:-export-dynamic} \
192- %{!dynamic-linker*:-dynamic-linker /lib/ld.so.1}} \
193+ %{!dynamic-linker*:-dynamic-linker " ELF_DYNAMIC_LINKER "}} \
194 %{static}}"
195
196 /* For compatibility with linux/a.out */
197--- gcc-4.0.2/gcc/config/mips/linux.h
198+++ gcc-4.0.2/gcc/config/mips/linux.h
199@@ -108,14 +108,19 @@
200
201 /* Borrowed from sparc/linux.h */
202 #undef LINK_SPEC
203+#ifdef USE_UCLIBC
204+#define ELF_DYNAMIC_LINKER "/lib/ld-uClibc.so.0"
205+#else
206+#define ELF_DYNAMIC_LINKER "/lib/ld.so.1"
207+#endif
208 #define LINK_SPEC \
209 "%(endian_spec) \
210 %{shared:-shared} \
211 %{!shared: \
212 %{!ibcs: \
213 %{!static: \
214 %{rdynamic:-export-dynamic} \
215- %{!dynamic-linker:-dynamic-linker /lib/ld.so.1}} \
216+ %{!dynamic-linker:-dynamic-linker " ELF_DYNAMIC_LINKER "}} \
217 %{static:-static}}}"
218
219 #undef SUBTARGET_ASM_SPEC
220--- gcc-4.0.2/gcc/config/pa/pa-linux.h
221+++ gcc-4.0.2/gcc/config/pa/pa-linux.h
222@@ -82,13 +82,18 @@
223 /* Define this for shared library support because it isn't in the main
224 linux.h file. */
225
226+#ifdef USE_UCLIBC
227+#define ELF_DYNAMIC_LINKER "/lib/ld-uClibc.so.0"
228+#else
229+#define ELF_DYNAMIC_LINKER "/lib/ld.so.1"
230+#endif
231 #undef LINK_SPEC
232 #define LINK_SPEC "\
233 %{shared:-shared} \
234 %{!shared: \
235 %{!static: \
236 %{rdynamic:-export-dynamic} \
237- %{!dynamic-linker:-dynamic-linker /lib/ld.so.1}} \
238+ %{!dynamic-linker:-dynamic-linker " ELF_DYNAMIC_LINKER "}} \
239 %{static:-static}}"
240
241 /* glibc's profiling functions don't need gcc to allocate counters. */
242--- gcc-4.0.2/gcc/config/rs6000/linux.h
243+++ gcc-4.0.2/gcc/config/rs6000/linux.h
244@@ -69,7 +69,11 @@
245 #define LINK_START_DEFAULT_SPEC "%(link_start_linux)"
246
247 #undef LINK_OS_DEFAULT_SPEC
248+#ifdef USE_UCLIBC
249+#define LINK_OS_DEFAULT_SPEC "%(link_os_linux_uclibc)"
250+#else
251 #define LINK_OS_DEFAULT_SPEC "%(link_os_linux)"
252+#endif
253
254 #define LINK_GCC_C_SEQUENCE_SPEC \
255 "%{static:--start-group} %G %L %{static:--end-group}%{!static:%G}"
256--- gcc-4.0.2/gcc/config/rs6000/sysv4.h
257+++ gcc-4.0.2/gcc/config/rs6000/sysv4.h
258@@ -949,6 +949,7 @@
259 mcall-linux : %(link_os_linux) ; \
260 mcall-gnu : %(link_os_gnu) ; \
261 mcall-netbsd : %(link_os_netbsd) ; \
262+ mcall-linux-uclibc : %(link_os_linux_uclibc); \
263 mcall-openbsd: %(link_os_openbsd) ; \
264 : %(link_os_default) }"
265
266@@ -1127,6 +1128,10 @@
267 %{rdynamic:-export-dynamic} \
268 %{!dynamic-linker:-dynamic-linker /lib/ld.so.1}}}"
269
270+#define LINK_OS_LINUX_UCLIBC_SPEC "-m elf32ppclinux %{!shared: %{!static: \
271+ %{rdynamic:-export-dynamic} \
272+ %{!dynamic-linker:-dynamic-linker /lib/ld-uClibc.so.0}}}"
273+
274 #if defined(HAVE_LD_EH_FRAME_HDR)
275 # define LINK_EH_SPEC "%{!static:--eh-frame-hdr} "
276 #endif
277@@ -1293,6 +1298,7 @@
278 { "link_os_sim", LINK_OS_SIM_SPEC }, \
279 { "link_os_freebsd", LINK_OS_FREEBSD_SPEC }, \
280 { "link_os_linux", LINK_OS_LINUX_SPEC }, \
281+ { "link_os_linux_uclibc", LINK_OS_LINUX_UCLIBC_SPEC }, \
282 { "link_os_gnu", LINK_OS_GNU_SPEC }, \
283 { "link_os_netbsd", LINK_OS_NETBSD_SPEC }, \
284 { "link_os_openbsd", LINK_OS_OPENBSD_SPEC }, \
285--- gcc-4.0.2/gcc/config/s390/linux.h
286+++ gcc-4.0.2/gcc/config/s390/linux.h
287@@ -77,6 +77,13 @@
288 #define MULTILIB_DEFAULTS { "m31" }
289 #endif
290
291+#ifdef USE_UCLIBC
292+#define ELF31_DYNAMIC_LINKER "/lib/ld-uClibc.so.0"
293+#define ELF64_DYNAMIC_LINKER "/lib/ld64-uClibc.so.0"
294+#else
295+#define ELF31_DYNAMIC_LINKER "/lib/ld.so.1"
296+#define ELF64_DYNAMIC_LINKER "/lib/ld64.so.1"
297+#endif
298 #undef LINK_SPEC
299 #define LINK_SPEC \
300 "%{m31:-m elf_s390}%{m64:-m elf64_s390} \
301@@ -86,8 +93,8 @@
302 %{!static: \
303 %{rdynamic:-export-dynamic} \
304 %{!dynamic-linker: \
305- %{m31:-dynamic-linker /lib/ld.so.1} \
306- %{m64:-dynamic-linker /lib/ld64.so.1}}}}"
307+ %{m31:-dynamic-linker " ELF31_DYNAMIC_LINKER "} \
308+ %{m64:-dynamic-linker " ELF64_DYNAMIC_LINKER "}}}}"
309
310
311 #define TARGET_ASM_FILE_END file_end_indicate_exec_stack
312--- gcc-4.0.2/gcc/config/sh/linux.h
313+++ gcc-4.0.2/gcc/config/sh/linux.h
314@@ -67,11 +67,16 @@
315 #undef SUBTARGET_LINK_EMUL_SUFFIX
316 #define SUBTARGET_LINK_EMUL_SUFFIX "_linux"
317 #undef SUBTARGET_LINK_SPEC
318+#ifdef USE_UCLIBC
319+#define ELF_DYNAMIC_LINKER "/lib/ld-uClibc.so.0"
320+#else
321+#define ELF_DYNAMIC_LINKER "/lib/ld-linux.so.2"
322+#endif
323 #define SUBTARGET_LINK_SPEC \
324 "%{shared:-shared} \
325 %{!static: \
326 %{rdynamic:-export-dynamic} \
327- %{!dynamic-linker:-dynamic-linker /lib/ld-linux.so.2}} \
328+ %{!dynamic-linker:-dynamic-linker " ELF_DYNAMIC_LINKER "}} \
329 %{static:-static}"
330
331 #undef LIB_SPEC
332--- gcc-4.0.2/gcc/config/sparc/linux.h
333+++ gcc-4.0.2/gcc/config/sparc/linux.h
334@@ -130,14 +130,19 @@
335
336 /* If ELF is the default format, we should not use /lib/elf. */
337
338+#ifdef USE_UCLIBC
339+#define ELF_DYNAMIC_LINKER "/lib/ld-uClibc.so.0"
340+#else
341+#define ELF_DYNAMIC_LINKER "/lib/ld-linux.so.2"
342+#endif
343 #undef LINK_SPEC
344 #define LINK_SPEC "-m elf32_sparc -Y P,/usr/lib %{shared:-shared} \
345 %{!mno-relax:%{!r:-relax}} \
346 %{!shared: \
347 %{!ibcs: \
348 %{!static: \
349 %{rdynamic:-export-dynamic} \
350- %{!dynamic-linker:-dynamic-linker /lib/ld-linux.so.2}} \
351+ %{!dynamic-linker:-dynamic-linker " ELF_DYNAMIC_LINKER "}} \
352 %{static:-static}}}"
353
354 /* The sun bundled assembler doesn't accept -Yd, (and neither does gas).
355--- gcc-4.0.2/gcc/config/sparc/linux64.h
356+++ gcc-4.0.2/gcc/config/sparc/linux64.h
357@@ -167,12 +166,17 @@
358 { "link_arch_default", LINK_ARCH_DEFAULT_SPEC }, \
359 { "link_arch", LINK_ARCH_SPEC },
360
361+#ifdef USE_UCLIBC
362+#define ELF_DYNAMIC_LINKER "/lib/ld-uClibc.so.0"
363+#else
364+#define ELF_DYNAMIC_LINKER "/lib/ld-linux.so.2"
365+#endif
366 #define LINK_ARCH32_SPEC "-m elf32_sparc -Y P,/usr/lib %{shared:-shared} \
367 %{!shared: \
368 %{!ibcs: \
369 %{!static: \
370 %{rdynamic:-export-dynamic} \
371- %{!dynamic-linker:-dynamic-linker /lib/ld-linux.so.2}} \
372+ %{!dynamic-linker:-dynamic-linker " ELF_DYNAMIC_LINKER "}} \
373 %{static:-static}}} \
374 "
375
376--- gcc-4.0.2/libtool.m4
377+++ gcc-4.0.2/libtool.m4
378@@ -682,6 +682,11 @@
379 lt_cv_deplibs_check_method=pass_all
380 ;;
381
382+linux-uclibc*)
383+ lt_cv_deplibs_check_method=pass_all
384+ lt_cv_file_magic_test_file=`echo /lib/libuClibc-*.so`
385+ ;;
386+
387 netbsd* | knetbsd*-gnu)
388 if echo __ELF__ | $CC -E - | grep __ELF__ > /dev/null; then
389 [lt_cv_deplibs_check_method='match_pattern /lib[^/\.]+\.so\.[0-9]+\.[0-9]+$']
390--- gcc-4.0.2/ltconfig
391+++ gcc-4.0.2/ltconfig
392@@ -603,6 +603,7 @@
393
394 # Transform linux* to *-*-linux-gnu*, to support old configure scripts.
395 case $host_os in
396+linux-uclibc*) ;;
397 linux-gnu*) ;;
398 linux*) host=`echo $host | sed 's/^\(.*-.*-linux\)\(.*\)$/\1-gnu\2/'`
399 esac
400@@ -1274,6 +1275,23 @@
401 dynamic_linker='GNU/Linux ld.so'
402 ;;
403
404+linux-uclibc*)
405+ version_type=linux
406+ need_lib_prefix=no
407+ need_version=no
408+ library_names_spec='${libname}${release}.so$versuffix ${libname}${release}.so$major $libname.so'
409+ soname_spec='${libname}${release}.so$major'
410+ finish_cmds='PATH="\$PATH:/sbin" ldconfig -n $libdir'
411+ shlibpath_var=LD_LIBRARY_PATH
412+ shlibpath_overrides_runpath=no
413+ # This implies no fast_install, which is unacceptable.
414+ # Some rework will be needed to allow for fast_install
415+ # before this can be enabled.
416+ hardcode_into_libs=yes
417+ # Assume using the uClibc dynamic linker.
418+ dynamic_linker="uClibc ld.so"
419+ ;;
420+
421 netbsd*)
422 need_lib_prefix=no
423 need_version=no
424--- gcc-4.0.2/libffi/configure
425+++ gcc-4.0.2/libffi/configure
426@@ -3457,6 +3457,11 @@
427 lt_cv_deplibs_check_method=pass_all
428 ;;
429
430+linux-uclibc*)
431+ lt_cv_deplibs_check_method=pass_all
432+ lt_cv_file_magic_test_file=`echo /lib/libuClibc-*.so`
433+ ;;
434+
435 netbsd* | knetbsd*-gnu)
436 if echo __ELF__ | $CC -E - | grep __ELF__ > /dev/null; then
437 lt_cv_deplibs_check_method='match_pattern /lib[^/\.]+\.so\.[0-9]+\.[0-9]+$'
438--- gcc-4.0.2/libgfortran/configure
439+++ gcc-4.0.2/libgfortran/configure
440@@ -3681,6 +3681,11 @@
441 lt_cv_deplibs_check_method=pass_all
442 ;;
443
444+linux-uclibc*)
445+ lt_cv_deplibs_check_method=pass_all
446+ lt_cv_file_magic_test_file=`echo /lib/libuClibc-*.so`
447+ ;;
448+
449 netbsd* | knetbsd*-gnu)
450 if echo __ELF__ | $CC -E - | grep __ELF__ > /dev/null; then
451 lt_cv_deplibs_check_method='match_pattern /lib[^/\.]+\.so\.[0-9]+\.[0-9]+$'
452--- gcc-4.0.2/libjava/configure
453+++ gcc-4.0.2/libjava/configure
454@@ -4351,6 +4351,11 @@
455 lt_cv_deplibs_check_method=pass_all
456 ;;
457
458+linux-uclibc*)
459+ lt_cv_deplibs_check_method=pass_all
460+ lt_cv_file_magic_test_file=`echo /lib/libuClibc-*.so`
461+ ;;
462+
463 netbsd* | knetbsd*-gnu)
464 if echo __ELF__ | $CC -E - | grep __ELF__ > /dev/null; then
465 lt_cv_deplibs_check_method='match_pattern /lib[^/\.]+\.so\.[0-9]+\.[0-9]+$'
466--- gcc-4.0.2/libmudflap/configure
467+++ gcc-4.0.2/libmudflap/configure
468@@ -5380,6 +5380,11 @@
469 lt_cv_deplibs_check_method=pass_all
470 ;;
471
472+linux-uclibc*)
473+ lt_cv_deplibs_check_method=pass_all
474+ lt_cv_file_magic_test_file=`echo /lib/libuClibc-*.so`
475+ ;;
476+
477 netbsd* | knetbsd*-gnu)
478 if echo __ELF__ | $CC -E - | grep __ELF__ > /dev/null; then
479 lt_cv_deplibs_check_method='match_pattern /lib[^/\.]+\.so\.[0-9]+\.[0-9]+$'
480--- gcc-4.0.2/libobjc/configure
481+++ gcc-4.0.2/libobjc/configure
482@@ -3283,6 +3283,11 @@
483 lt_cv_deplibs_check_method=pass_all
484 ;;
485
486+linux-uclibc*)
487+ lt_cv_deplibs_check_method=pass_all
488+ lt_cv_file_magic_test_file=`echo /lib/libuClibc-*.so`
489+ ;;
490+
491 netbsd* | knetbsd*-gnu)
492 if echo __ELF__ | $CC -E - | grep __ELF__ > /dev/null; then
493 lt_cv_deplibs_check_method='match_pattern /lib[^/\.]+\.so\.[0-9]+\.[0-9]+$'
494--- gcc-4.0.2/boehm-gc/configure
495+++ gcc-4.0.2/boehm-gc/configure
496@@ -4320,6 +4320,11 @@
497 lt_cv_deplibs_check_method=pass_all
498 ;;
499
500+linux-uclibc*)
501+ lt_cv_deplibs_check_method=pass_all
502+ lt_cv_file_magic_test_file=`echo /lib/libuClibc-*.so`
503+ ;;
504+
505 netbsd* | knetbsd*-gnu)
506 if echo __ELF__ | $CC -E - | grep __ELF__ > /dev/null; then
507 lt_cv_deplibs_check_method='match_pattern /lib[^/\.]+\.so\.[0-9]+\.[0-9]+$'
508--- gcc-4.0.2/configure
509+++ gcc-4.0.2/configure
510@@ -1141,7 +1141,7 @@
511 ;;
512 "")
513 case "${target}" in
514- *-*-linux*-gnu | *-*-gnu* | *-*-k*bsd*-gnu)
515+ *-*-linux*-gnu | *-*-gnu* | *-*-k*bsd*-gnu | *-*-linux-uclibc*)
516 # Enable libmudflap by default in GNU and friends.
517 ;;
518 *-*-freebsd*)
519--- gcc-4.0.2/configure.in
520+++ gcc-4.0.2/configure.in
521@@ -350,7 +350,7 @@
522 ;;
523 "")
524 case "${target}" in
525- *-*-linux*-gnu | *-*-gnu* | *-*-k*bsd*-gnu)
526+ *-*-linux*-gnu | *-*-gnu* | *-*-k*bsd*-gnu | *-*-linux-uclibc*)
527 # Enable libmudflap by default in GNU and friends.
528 ;;
529 *-*-freebsd*)
530--- gcc-4.0.2/contrib/regression/objs-gcc.sh
531+++ gcc-4.0.2/contrib/regression/objs-gcc.sh
532@@ -105,6 +105,10 @@
533 then
534 make all-gdb all-dejagnu all-ld || exit 1
535 make install-gdb install-dejagnu install-ld || exit 1
536+elif [ $H_REAL_TARGET = $H_REAL_HOST -a $H_REAL_TARGET = i686-pc-linux-uclibc ]
537+ then
538+ make all-gdb all-dejagnu all-ld || exit 1
539+ make install-gdb install-dejagnu install-ld || exit 1
540 elif [ $H_REAL_TARGET = $H_REAL_HOST ] ; then
541 make bootstrap || exit 1
542 make install || exit 1
543--- gcc-4.0.2/zlib/configure
544+++ gcc-4.0.2/zlib/configure
545@@ -3426,6 +3426,11 @@
546 lt_cv_deplibs_check_method=pass_all
547 ;;
548
549+linux-uclibc*)
550+ lt_cv_deplibs_check_method=pass_all
551+ lt_cv_file_magic_test_file=`echo /lib/libuClibc-*.so`
552+ ;;
553+
554 netbsd* | knetbsd*-gnu)
555 if echo __ELF__ | $CC -E - | grep __ELF__ > /dev/null; then
556 lt_cv_deplibs_check_method='match_pattern /lib[^/\.]+\.so\.[0-9]+\.[0-9]+$'