summaryrefslogtreecommitdiffstats
path: root/meta/packages/gcc/gcc-3.3.4/libibery-crosstool.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/gcc/gcc-3.3.4/libibery-crosstool.patch')
-rw-r--r--meta/packages/gcc/gcc-3.3.4/libibery-crosstool.patch683
1 files changed, 683 insertions, 0 deletions
diff --git a/meta/packages/gcc/gcc-3.3.4/libibery-crosstool.patch b/meta/packages/gcc/gcc-3.3.4/libibery-crosstool.patch
new file mode 100644
index 0000000000..2898cf18ff
--- /dev/null
+++ b/meta/packages/gcc/gcc-3.3.4/libibery-crosstool.patch
@@ -0,0 +1,683 @@
1diff -urN gcc-3.3.3.orig/libiberty/configure gcc-3.3.3/libiberty/configure
2--- gcc-3.3.3.orig/libiberty/configure 2003-11-12 12:32:29.000000000 -0500
3+++ gcc-3.3.3/libiberty/configure 2004-04-09 23:04:23.000000000 -0400
4@@ -1000,13 +1000,60 @@
5 fi
6
7
8+echo $ac_n "checking whether the C compiler ($CC $CFLAGS $LDFLAGS) works""... $ac_c" 1>&6
9+echo "configure:1005: checking whether the C compiler ($CC $CFLAGS $LDFLAGS) works" >&5
10+
11+ac_ext=c
12+# CFLAGS is not in ac_cpp because -g, -O, etc. are not valid cpp options.
13+ac_cpp='$CPP $CPPFLAGS'
14+ac_compile='${CC-cc} -c $CFLAGS $CPPFLAGS conftest.$ac_ext 1>&5'
15+ac_link='${CC-cc} -o conftest${ac_exeext} $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS 1>&5'
16+cross_compiling=$ac_cv_prog_cc_cross
17+
18+cat > conftest.$ac_ext << EOF
19+
20+#line 1016 "configure"
21+#include "confdefs.h"
22+
23+main(){return(0);}
24+EOF
25+if { (eval echo configure:1021: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
26+ ac_cv_prog_cc_works=yes
27+ # If we can't run a trivial program, we are probably using a cross compiler.
28+ if (./conftest; exit) 2>/dev/null; then
29+ ac_cv_prog_cc_cross=no
30+ else
31+ ac_cv_prog_cc_cross=yes
32+ fi
33+else
34+ echo "configure: failed program was:" >&5
35+ cat conftest.$ac_ext >&5
36+ ac_cv_prog_cc_works=no
37+fi
38+rm -fr conftest*
39+ac_ext=c
40+# CFLAGS is not in ac_cpp because -g, -O, etc. are not valid cpp options.
41+ac_cpp='$CPP $CPPFLAGS'
42+ac_compile='${CC-cc} -c $CFLAGS $CPPFLAGS conftest.$ac_ext 1>&5'
43+ac_link='${CC-cc} -o conftest${ac_exeext} $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS 1>&5'
44+cross_compiling=$ac_cv_prog_cc_cross
45+
46+echo "$ac_t""$ac_cv_prog_cc_works" 1>&6
47+if test $ac_cv_prog_cc_works = no; then
48+ { echo "configure: error: installation or configuration problem: C compiler cannot create executables." 1>&2; exit 1; }
49+fi
50+echo $ac_n "checking whether the C compiler ($CC $CFLAGS $LDFLAGS) is a cross-compiler""... $ac_c" 1>&6
51+echo "configure:1047: checking whether the C compiler ($CC $CFLAGS $LDFLAGS) is a cross-compiler" >&5
52+echo "$ac_t""$ac_cv_prog_cc_cross" 1>&6
53+cross_compiling=$ac_cv_prog_cc_cross
54+
55
56 if test "x$CC" != xcc; then
57 echo $ac_n "checking whether $CC and cc understand -c and -o together""... $ac_c" 1>&6
58-echo "configure:1007: checking whether $CC and cc understand -c and -o together" >&5
59+echo "configure:1054: checking whether $CC and cc understand -c and -o together" >&5
60 else
61 echo $ac_n "checking whether cc understands -c and -o together""... $ac_c" 1>&6
62-echo "configure:1010: checking whether cc understands -c and -o together" >&5
63+echo "configure:1057: checking whether cc understands -c and -o together" >&5
64 fi
65 set dummy $CC; ac_cc="`echo $2 |
66 sed -e 's/[^a-zA-Z0-9_]/_/g' -e 's/^[0-9]/_/'`"
67@@ -1018,16 +1065,16 @@
68 # We do the test twice because some compilers refuse to overwrite an
69 # existing .o file with -o, though they will create one.
70 ac_try='${CC-cc} -c conftest.c -o conftest.o 1>&5'
71-if { (eval echo configure:1022: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; } &&
72- test -f conftest.o && { (eval echo configure:1023: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; };
73+if { (eval echo configure:1069: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; } &&
74+ test -f conftest.o && { (eval echo configure:1070: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; };
75 then
76 eval ac_cv_prog_cc_${ac_cc}_c_o=yes
77 if test "x$CC" != xcc; then
78 # Test first that cc exists at all.
79- if { ac_try='cc -c conftest.c 1>&5'; { (eval echo configure:1028: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }; }; then
80+ if { ac_try='cc -c conftest.c 1>&5'; { (eval echo configure:1075: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }; }; then
81 ac_try='cc -c conftest.c -o conftest.o 1>&5'
82- if { (eval echo configure:1030: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; } &&
83- test -f conftest.o && { (eval echo configure:1031: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; };
84+ if { (eval echo configure:1077: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; } &&
85+ test -f conftest.o && { (eval echo configure:1078: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; };
86 then
87 # cc works too.
88 :
89@@ -1063,7 +1110,7 @@
90
91
92 echo $ac_n "checking for POSIXized ISC""... $ac_c" 1>&6
93-echo "configure:1067: checking for POSIXized ISC" >&5
94+echo "configure:1114: checking for POSIXized ISC" >&5
95 if test -d /etc/conf/kconfig.d &&
96 grep _POSIX_VERSION /usr/include/sys/unistd.h >/dev/null 2>&1
97 then
98@@ -1084,12 +1131,12 @@
99 fi
100
101 echo $ac_n "checking for working const""... $ac_c" 1>&6
102-echo "configure:1088: checking for working const" >&5
103+echo "configure:1135: checking for working const" >&5
104 if eval "test \"`echo '$''{'ac_cv_c_const'+set}'`\" = set"; then
105 echo $ac_n "(cached) $ac_c" 1>&6
106 else
107 cat > conftest.$ac_ext <<EOF
108-#line 1093 "configure"
109+#line 1140 "configure"
110 #include "confdefs.h"
111
112 int main() {
113@@ -1138,7 +1185,7 @@
114
115 ; return 0; }
116 EOF
117-if { (eval echo configure:1142: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
118+if { (eval echo configure:1189: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
119 rm -rf conftest*
120 ac_cv_c_const=yes
121 else
122@@ -1159,21 +1206,21 @@
123 fi
124
125 echo $ac_n "checking for inline""... $ac_c" 1>&6
126-echo "configure:1163: checking for inline" >&5
127+echo "configure:1210: checking for inline" >&5
128 if eval "test \"`echo '$''{'ac_cv_c_inline'+set}'`\" = set"; then
129 echo $ac_n "(cached) $ac_c" 1>&6
130 else
131 ac_cv_c_inline=no
132 for ac_kw in inline __inline__ __inline; do
133 cat > conftest.$ac_ext <<EOF
134-#line 1170 "configure"
135+#line 1217 "configure"
136 #include "confdefs.h"
137
138 int main() {
139 } $ac_kw foo() {
140 ; return 0; }
141 EOF
142-if { (eval echo configure:1177: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
143+if { (eval echo configure:1224: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
144 rm -rf conftest*
145 ac_cv_c_inline=$ac_kw; break
146 else
147@@ -1216,7 +1263,7 @@
148 # SVR4 /usr/ucb/install, which tries to use the nonexistent group "staff"
149 # ./install, which can be erroneously created by make from ./install.sh.
150 echo $ac_n "checking for a BSD compatible install""... $ac_c" 1>&6
151-echo "configure:1220: checking for a BSD compatible install" >&5
152+echo "configure:1267: checking for a BSD compatible install" >&5
153 if test -z "$INSTALL"; then
154 if eval "test \"`echo '$''{'ac_cv_path_install'+set}'`\" = set"; then
155 echo $ac_n "(cached) $ac_c" 1>&6
156@@ -1277,7 +1324,7 @@
157 # able to link anything, it had better be able to at least compile
158 # something.
159 echo $ac_n "checking how to run the C preprocessor""... $ac_c" 1>&6
160-echo "configure:1281: checking how to run the C preprocessor" >&5
161+echo "configure:1328: checking how to run the C preprocessor" >&5
162 # On Suns, sometimes $CPP names a directory.
163 if test -n "$CPP" && test -d "$CPP"; then
164 CPP=
165@@ -1292,13 +1339,13 @@
166 # On the NeXT, cc -E runs the code through the compiler's parser,
167 # not just through cpp.
168 cat > conftest.$ac_ext <<EOF
169-#line 1296 "configure"
170+#line 1343 "configure"
171 #include "confdefs.h"
172 #include <assert.h>
173 Syntax Error
174 EOF
175 ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
176-{ (eval echo configure:1302: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
177+{ (eval echo configure:1349: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
178 ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$"`
179 if test -z "$ac_err"; then
180 :
181@@ -1309,13 +1356,13 @@
182 rm -rf conftest*
183 CPP="${CC-cc} -E -traditional-cpp"
184 cat > conftest.$ac_ext <<EOF
185-#line 1313 "configure"
186+#line 1360 "configure"
187 #include "confdefs.h"
188 #include <assert.h>
189 Syntax Error
190 EOF
191 ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
192-{ (eval echo configure:1319: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
193+{ (eval echo configure:1366: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
194 ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$"`
195 if test -z "$ac_err"; then
196 :
197@@ -1326,13 +1373,13 @@
198 rm -rf conftest*
199 CPP="${CC-cc} -nologo -E"
200 cat > conftest.$ac_ext <<EOF
201-#line 1330 "configure"
202+#line 1377 "configure"
203 #include "confdefs.h"
204 #include <assert.h>
205 Syntax Error
206 EOF
207 ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
208-{ (eval echo configure:1336: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
209+{ (eval echo configure:1383: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
210 ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$"`
211 if test -z "$ac_err"; then
212 :
213@@ -1360,17 +1407,17 @@
214 do
215 ac_safe=`echo "$ac_hdr" | sed 'y%./+-%__p_%'`
216 echo $ac_n "checking for $ac_hdr""... $ac_c" 1>&6
217-echo "configure:1364: checking for $ac_hdr" >&5
218+echo "configure:1411: checking for $ac_hdr" >&5
219 if eval "test \"`echo '$''{'ac_cv_header_$ac_safe'+set}'`\" = set"; then
220 echo $ac_n "(cached) $ac_c" 1>&6
221 else
222 cat > conftest.$ac_ext <<EOF
223-#line 1369 "configure"
224+#line 1416 "configure"
225 #include "confdefs.h"
226 #include <$ac_hdr>
227 EOF
228 ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
229-{ (eval echo configure:1374: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
230+{ (eval echo configure:1421: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
231 ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$"`
232 if test -z "$ac_err"; then
233 rm -rf conftest*
234@@ -1397,12 +1444,12 @@
235 done
236
237 echo $ac_n "checking for sys/wait.h that is POSIX.1 compatible""... $ac_c" 1>&6
238-echo "configure:1401: checking for sys/wait.h that is POSIX.1 compatible" >&5
239+echo "configure:1448: checking for sys/wait.h that is POSIX.1 compatible" >&5
240 if eval "test \"`echo '$''{'ac_cv_header_sys_wait_h'+set}'`\" = set"; then
241 echo $ac_n "(cached) $ac_c" 1>&6
242 else
243 cat > conftest.$ac_ext <<EOF
244-#line 1406 "configure"
245+#line 1453 "configure"
246 #include "confdefs.h"
247 #include <sys/types.h>
248 #include <sys/wait.h>
249@@ -1418,7 +1465,7 @@
250 s = WIFEXITED (s) ? WEXITSTATUS (s) : 1;
251 ; return 0; }
252 EOF
253-if { (eval echo configure:1422: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
254+if { (eval echo configure:1469: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
255 rm -rf conftest*
256 ac_cv_header_sys_wait_h=yes
257 else
258@@ -1439,12 +1486,12 @@
259 fi
260
261 echo $ac_n "checking whether time.h and sys/time.h may both be included""... $ac_c" 1>&6
262-echo "configure:1443: checking whether time.h and sys/time.h may both be included" >&5
263+echo "configure:1490: checking whether time.h and sys/time.h may both be included" >&5
264 if eval "test \"`echo '$''{'ac_cv_header_time'+set}'`\" = set"; then
265 echo $ac_n "(cached) $ac_c" 1>&6
266 else
267 cat > conftest.$ac_ext <<EOF
268-#line 1448 "configure"
269+#line 1495 "configure"
270 #include "confdefs.h"
271 #include <sys/types.h>
272 #include <sys/time.h>
273@@ -1453,7 +1500,7 @@
274 struct tm *tp;
275 ; return 0; }
276 EOF
277-if { (eval echo configure:1457: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
278+if { (eval echo configure:1504: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
279 rm -rf conftest*
280 ac_cv_header_time=yes
281 else
282@@ -1475,19 +1522,19 @@
283
284
285 echo $ac_n "checking whether errno must be declared""... $ac_c" 1>&6
286-echo "configure:1479: checking whether errno must be declared" >&5
287+echo "configure:1526: checking whether errno must be declared" >&5
288 if eval "test \"`echo '$''{'libiberty_cv_declare_errno'+set}'`\" = set"; then
289 echo $ac_n "(cached) $ac_c" 1>&6
290 else
291 cat > conftest.$ac_ext <<EOF
292-#line 1484 "configure"
293+#line 1531 "configure"
294 #include "confdefs.h"
295 #include <errno.h>
296 int main() {
297 int x = errno;
298 ; return 0; }
299 EOF
300-if { (eval echo configure:1491: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
301+if { (eval echo configure:1538: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
302 rm -rf conftest*
303 libiberty_cv_declare_errno=no
304 else
305@@ -1509,12 +1556,12 @@
306
307
308 echo $ac_n "checking for ANSI C header files""... $ac_c" 1>&6
309-echo "configure:1513: checking for ANSI C header files" >&5
310+echo "configure:1560: checking for ANSI C header files" >&5
311 if eval "test \"`echo '$''{'ac_cv_header_stdc'+set}'`\" = set"; then
312 echo $ac_n "(cached) $ac_c" 1>&6
313 else
314 cat > conftest.$ac_ext <<EOF
315-#line 1518 "configure"
316+#line 1565 "configure"
317 #include "confdefs.h"
318 #include <stdlib.h>
319 #include <stdarg.h>
320@@ -1522,7 +1569,7 @@
321 #include <float.h>
322 EOF
323 ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
324-{ (eval echo configure:1526: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
325+{ (eval echo configure:1573: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
326 ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$"`
327 if test -z "$ac_err"; then
328 rm -rf conftest*
329@@ -1539,7 +1586,7 @@
330 if test $ac_cv_header_stdc = yes; then
331 # SunOS 4.x string.h does not declare mem*, contrary to ANSI.
332 cat > conftest.$ac_ext <<EOF
333-#line 1543 "configure"
334+#line 1590 "configure"
335 #include "confdefs.h"
336 #include <string.h>
337 EOF
338@@ -1557,7 +1604,7 @@
339 if test $ac_cv_header_stdc = yes; then
340 # ISC 2.0.2 stdlib.h does not declare free, contrary to ANSI.
341 cat > conftest.$ac_ext <<EOF
342-#line 1561 "configure"
343+#line 1608 "configure"
344 #include "confdefs.h"
345 #include <stdlib.h>
346 EOF
347@@ -1578,7 +1625,7 @@
348 :
349 else
350 cat > conftest.$ac_ext <<EOF
351-#line 1582 "configure"
352+#line 1629 "configure"
353 #include "confdefs.h"
354 #include <ctype.h>
355 #define ISLOWER(c) ('a' <= (c) && (c) <= 'z')
356@@ -1589,7 +1636,7 @@
357 exit (0); }
358
359 EOF
360-if { (eval echo configure:1593: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext} && (./conftest; exit) 2>/dev/null
361+if { (eval echo configure:1640: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext} && (./conftest; exit) 2>/dev/null
362 then
363 :
364 else
365@@ -1613,12 +1660,12 @@
366 fi
367
368 echo $ac_n "checking for uintptr_t""... $ac_c" 1>&6
369-echo "configure:1617: checking for uintptr_t" >&5
370+echo "configure:1664: checking for uintptr_t" >&5
371 if eval "test \"`echo '$''{'ac_cv_type_uintptr_t'+set}'`\" = set"; then
372 echo $ac_n "(cached) $ac_c" 1>&6
373 else
374 cat > conftest.$ac_ext <<EOF
375-#line 1622 "configure"
376+#line 1669 "configure"
377 #include "confdefs.h"
378 #include <sys/types.h>
379 #if STDC_HEADERS
380@@ -1654,12 +1701,12 @@
381
382
383 echo $ac_n "checking for pid_t""... $ac_c" 1>&6
384-echo "configure:1658: checking for pid_t" >&5
385+echo "configure:1705: checking for pid_t" >&5
386 if eval "test \"`echo '$''{'ac_cv_type_pid_t'+set}'`\" = set"; then
387 echo $ac_n "(cached) $ac_c" 1>&6
388 else
389 cat > conftest.$ac_ext <<EOF
390-#line 1663 "configure"
391+#line 1710 "configure"
392 #include "confdefs.h"
393 #include <sys/types.h>
394 #if STDC_HEADERS
395@@ -1746,12 +1793,12 @@
396 for ac_func in asprintf atexit basename bcmp bcopy bsearch bzero calloc clock
397 do
398 echo $ac_n "checking for $ac_func""... $ac_c" 1>&6
399-echo "configure:1750: checking for $ac_func" >&5
400+echo "configure:1797: checking for $ac_func" >&5
401 if eval "test \"`echo '$''{'ac_cv_func_$ac_func'+set}'`\" = set"; then
402 echo $ac_n "(cached) $ac_c" 1>&6
403 else
404 cat > conftest.$ac_ext <<EOF
405-#line 1755 "configure"
406+#line 1802 "configure"
407 #include "confdefs.h"
408 /* System header to define __stub macros and hopefully few prototypes,
409 which can conflict with char $ac_func(); below. */
410@@ -1774,7 +1821,7 @@
411
412 ; return 0; }
413 EOF
414-if { (eval echo configure:1778: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
415+if { (eval echo configure:1825: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
416 rm -rf conftest*
417 eval "ac_cv_func_$ac_func=yes"
418 else
419@@ -1801,12 +1848,12 @@
420 for ac_func in getcwd getpagesize index insque mkstemps memchr memcmp memcpy
421 do
422 echo $ac_n "checking for $ac_func""... $ac_c" 1>&6
423-echo "configure:1805: checking for $ac_func" >&5
424+echo "configure:1852: checking for $ac_func" >&5
425 if eval "test \"`echo '$''{'ac_cv_func_$ac_func'+set}'`\" = set"; then
426 echo $ac_n "(cached) $ac_c" 1>&6
427 else
428 cat > conftest.$ac_ext <<EOF
429-#line 1810 "configure"
430+#line 1857 "configure"
431 #include "confdefs.h"
432 /* System header to define __stub macros and hopefully few prototypes,
433 which can conflict with char $ac_func(); below. */
434@@ -1829,7 +1876,7 @@
435
436 ; return 0; }
437 EOF
438-if { (eval echo configure:1833: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
439+if { (eval echo configure:1880: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
440 rm -rf conftest*
441 eval "ac_cv_func_$ac_func=yes"
442 else
443@@ -1856,12 +1903,12 @@
444 for ac_func in memmove memset putenv random rename rindex sigsetmask
445 do
446 echo $ac_n "checking for $ac_func""... $ac_c" 1>&6
447-echo "configure:1860: checking for $ac_func" >&5
448+echo "configure:1907: checking for $ac_func" >&5
449 if eval "test \"`echo '$''{'ac_cv_func_$ac_func'+set}'`\" = set"; then
450 echo $ac_n "(cached) $ac_c" 1>&6
451 else
452 cat > conftest.$ac_ext <<EOF
453-#line 1865 "configure"
454+#line 1912 "configure"
455 #include "confdefs.h"
456 /* System header to define __stub macros and hopefully few prototypes,
457 which can conflict with char $ac_func(); below. */
458@@ -1884,7 +1931,7 @@
459
460 ; return 0; }
461 EOF
462-if { (eval echo configure:1888: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
463+if { (eval echo configure:1935: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
464 rm -rf conftest*
465 eval "ac_cv_func_$ac_func=yes"
466 else
467@@ -1911,12 +1958,12 @@
468 for ac_func in strcasecmp setenv strchr strdup strncasecmp strrchr strstr
469 do
470 echo $ac_n "checking for $ac_func""... $ac_c" 1>&6
471-echo "configure:1915: checking for $ac_func" >&5
472+echo "configure:1962: checking for $ac_func" >&5
473 if eval "test \"`echo '$''{'ac_cv_func_$ac_func'+set}'`\" = set"; then
474 echo $ac_n "(cached) $ac_c" 1>&6
475 else
476 cat > conftest.$ac_ext <<EOF
477-#line 1920 "configure"
478+#line 1967 "configure"
479 #include "confdefs.h"
480 /* System header to define __stub macros and hopefully few prototypes,
481 which can conflict with char $ac_func(); below. */
482@@ -1939,7 +1986,7 @@
483
484 ; return 0; }
485 EOF
486-if { (eval echo configure:1943: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
487+if { (eval echo configure:1990: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
488 rm -rf conftest*
489 eval "ac_cv_func_$ac_func=yes"
490 else
491@@ -1966,12 +2013,12 @@
492 for ac_func in strtod strtol strtoul tmpnam vasprintf vfprintf vprintf
493 do
494 echo $ac_n "checking for $ac_func""... $ac_c" 1>&6
495-echo "configure:1970: checking for $ac_func" >&5
496+echo "configure:2017: checking for $ac_func" >&5
497 if eval "test \"`echo '$''{'ac_cv_func_$ac_func'+set}'`\" = set"; then
498 echo $ac_n "(cached) $ac_c" 1>&6
499 else
500 cat > conftest.$ac_ext <<EOF
501-#line 1975 "configure"
502+#line 2022 "configure"
503 #include "confdefs.h"
504 /* System header to define __stub macros and hopefully few prototypes,
505 which can conflict with char $ac_func(); below. */
506@@ -1994,7 +2041,7 @@
507
508 ; return 0; }
509 EOF
510-if { (eval echo configure:1998: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
511+if { (eval echo configure:2045: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
512 rm -rf conftest*
513 eval "ac_cv_func_$ac_func=yes"
514 else
515@@ -2021,12 +2068,12 @@
516 for ac_func in vsprintf waitpid getrusage on_exit psignal strerror strsignal
517 do
518 echo $ac_n "checking for $ac_func""... $ac_c" 1>&6
519-echo "configure:2025: checking for $ac_func" >&5
520+echo "configure:2072: checking for $ac_func" >&5
521 if eval "test \"`echo '$''{'ac_cv_func_$ac_func'+set}'`\" = set"; then
522 echo $ac_n "(cached) $ac_c" 1>&6
523 else
524 cat > conftest.$ac_ext <<EOF
525-#line 2030 "configure"
526+#line 2077 "configure"
527 #include "confdefs.h"
528 /* System header to define __stub macros and hopefully few prototypes,
529 which can conflict with char $ac_func(); below. */
530@@ -2049,7 +2096,7 @@
531
532 ; return 0; }
533 EOF
534-if { (eval echo configure:2053: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
535+if { (eval echo configure:2100: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
536 rm -rf conftest*
537 eval "ac_cv_func_$ac_func=yes"
538 else
539@@ -2076,12 +2123,12 @@
540 for ac_func in sysconf times sbrk gettimeofday ffs
541 do
542 echo $ac_n "checking for $ac_func""... $ac_c" 1>&6
543-echo "configure:2080: checking for $ac_func" >&5
544+echo "configure:2127: checking for $ac_func" >&5
545 if eval "test \"`echo '$''{'ac_cv_func_$ac_func'+set}'`\" = set"; then
546 echo $ac_n "(cached) $ac_c" 1>&6
547 else
548 cat > conftest.$ac_ext <<EOF
549-#line 2085 "configure"
550+#line 2132 "configure"
551 #include "confdefs.h"
552 /* System header to define __stub macros and hopefully few prototypes,
553 which can conflict with char $ac_func(); below. */
554@@ -2104,7 +2151,7 @@
555
556 ; return 0; }
557 EOF
558-if { (eval echo configure:2108: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
559+if { (eval echo configure:2155: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
560 rm -rf conftest*
561 eval "ac_cv_func_$ac_func=yes"
562 else
563@@ -2131,12 +2178,12 @@
564 for ac_func in realpath canonicalize_file_name
565 do
566 echo $ac_n "checking for $ac_func""... $ac_c" 1>&6
567-echo "configure:2135: checking for $ac_func" >&5
568+echo "configure:2182: checking for $ac_func" >&5
569 if eval "test \"`echo '$''{'ac_cv_func_$ac_func'+set}'`\" = set"; then
570 echo $ac_n "(cached) $ac_c" 1>&6
571 else
572 cat > conftest.$ac_ext <<EOF
573-#line 2140 "configure"
574+#line 2187 "configure"
575 #include "confdefs.h"
576 /* System header to define __stub macros and hopefully few prototypes,
577 which can conflict with char $ac_func(); below. */
578@@ -2159,7 +2206,7 @@
579
580 ; return 0; }
581 EOF
582-if { (eval echo configure:2163: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
583+if { (eval echo configure:2210: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
584 rm -rf conftest*
585 eval "ac_cv_func_$ac_func=yes"
586 else
587@@ -2186,12 +2233,12 @@
588 for ac_func in pstat_getstatic pstat_getdynamic sysmp getsysinfo table sysctl
589 do
590 echo $ac_n "checking for $ac_func""... $ac_c" 1>&6
591-echo "configure:2190: checking for $ac_func" >&5
592+echo "configure:2237: checking for $ac_func" >&5
593 if eval "test \"`echo '$''{'ac_cv_func_$ac_func'+set}'`\" = set"; then
594 echo $ac_n "(cached) $ac_c" 1>&6
595 else
596 cat > conftest.$ac_ext <<EOF
597-#line 2195 "configure"
598+#line 2242 "configure"
599 #include "confdefs.h"
600 /* System header to define __stub macros and hopefully few prototypes,
601 which can conflict with char $ac_func(); below. */
602@@ -2214,7 +2261,7 @@
603
604 ; return 0; }
605 EOF
606-if { (eval echo configure:2218: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
607+if { (eval echo configure:2265: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
608 rm -rf conftest*
609 eval "ac_cv_func_$ac_func=yes"
610 else
611@@ -2443,53 +2490,6 @@
612
613 # We haven't set the list of objects yet. Use the standard autoconf
614 # tests. This will only work if the compiler works.
615- echo $ac_n "checking whether the C compiler ($CC $CFLAGS $LDFLAGS) works""... $ac_c" 1>&6
616-echo "configure:2448: checking whether the C compiler ($CC $CFLAGS $LDFLAGS) works" >&5
617-
618-ac_ext=c
619-# CFLAGS is not in ac_cpp because -g, -O, etc. are not valid cpp options.
620-ac_cpp='$CPP $CPPFLAGS'
621-ac_compile='${CC-cc} -c $CFLAGS $CPPFLAGS conftest.$ac_ext 1>&5'
622-ac_link='${CC-cc} -o conftest${ac_exeext} $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS 1>&5'
623-cross_compiling=$ac_cv_prog_cc_cross
624-
625-cat > conftest.$ac_ext << EOF
626-
627-#line 2459 "configure"
628-#include "confdefs.h"
629-
630-main(){return(0);}
631-EOF
632-if { (eval echo configure:2464: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
633- ac_cv_prog_cc_works=yes
634- # If we can't run a trivial program, we are probably using a cross compiler.
635- if (./conftest; exit) 2>/dev/null; then
636- ac_cv_prog_cc_cross=no
637- else
638- ac_cv_prog_cc_cross=yes
639- fi
640-else
641- echo "configure: failed program was:" >&5
642- cat conftest.$ac_ext >&5
643- ac_cv_prog_cc_works=no
644-fi
645-rm -fr conftest*
646-ac_ext=c
647-# CFLAGS is not in ac_cpp because -g, -O, etc. are not valid cpp options.
648-ac_cpp='$CPP $CPPFLAGS'
649-ac_compile='${CC-cc} -c $CFLAGS $CPPFLAGS conftest.$ac_ext 1>&5'
650-ac_link='${CC-cc} -o conftest${ac_exeext} $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS 1>&5'
651-cross_compiling=$ac_cv_prog_cc_cross
652-
653-echo "$ac_t""$ac_cv_prog_cc_works" 1>&6
654-if test $ac_cv_prog_cc_works = no; then
655- { echo "configure: error: installation or configuration problem: C compiler cannot create executables." 1>&2; exit 1; }
656-fi
657-echo $ac_n "checking whether the C compiler ($CC $CFLAGS $LDFLAGS) is a cross-compiler""... $ac_c" 1>&6
658-echo "configure:2490: checking whether the C compiler ($CC $CFLAGS $LDFLAGS) is a cross-compiler" >&5
659-echo "$ac_t""$ac_cv_prog_cc_cross" 1>&6
660-cross_compiling=$ac_cv_prog_cc_cross
661-
662 for ac_func in $funcs
663 do
664 echo $ac_n "checking for $ac_func""... $ac_c" 1>&6
665diff -urN gcc-3.3.3.orig/libiberty/configure.in gcc-3.3.3/libiberty/configure.in
666--- gcc-3.3.3.orig/libiberty/configure.in 2003-11-12 12:32:30.000000000 -0500
667+++ gcc-3.3.3/libiberty/configure.in 2004-04-09 23:04:05.000000000 -0400
668@@ -100,6 +100,7 @@
669 AC_CHECK_TOOL(RANLIB, ranlib, :)
670
671 LIB_AC_PROG_CC
672+AC_PROG_CC_WORKS
673
674 AC_PROG_CC_C_O
675 # autoconf is lame and doesn't give us any substitution variable for this.
676@@ -396,7 +397,6 @@
677
678 # We haven't set the list of objects yet. Use the standard autoconf
679 # tests. This will only work if the compiler works.
680- AC_PROG_CC_WORKS
681 AC_REPLACE_FUNCS($funcs)
682 libiberty_AC_FUNC_C_ALLOCA
683 AC_FUNC_VFORK