summaryrefslogtreecommitdiffstats
path: root/meta/packages/galago/eds-feed/disable-bonobo.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/galago/eds-feed/disable-bonobo.patch')
-rw-r--r--meta/packages/galago/eds-feed/disable-bonobo.patch62
1 files changed, 62 insertions, 0 deletions
diff --git a/meta/packages/galago/eds-feed/disable-bonobo.patch b/meta/packages/galago/eds-feed/disable-bonobo.patch
new file mode 100644
index 0000000000..3a2097877a
--- /dev/null
+++ b/meta/packages/galago/eds-feed/disable-bonobo.patch
@@ -0,0 +1,62 @@
1Index: eds-feed-0.3.2/configure.ac
2===================================================================
3--- eds-feed-0.3.2.orig/configure.ac 2005-08-28 19:11:39.000000000 +0000
4+++ eds-feed-0.3.2/configure.ac 2005-12-16 09:22:10.000000000 +0000
5@@ -65,7 +65,7 @@
6 libxml-2.0)
7
8 # Check which version of eds we're using
9-PKG_CHECK_MODULES(EDS, libebook-1.2 >= 1.1.4 libedata-book-1.2 >= 1.1.4)
10+PKG_CHECK_MODULES(EDS, libebook-1.2 >= 1.1.4)
11
12 PACKAGE_CFLAGS="$PACKAGE_CFLAGS $EDS_CFLAGS"
13 PACKAGE_LIBS="$PACKAGE_LIBS $EDS_LIBS"
14Index: eds-feed-0.3.2/src/main.c
15===================================================================
16--- eds-feed-0.3.2.orig/src/main.c 2005-08-21 07:26:02.000000000 +0000
17+++ eds-feed-0.3.2/src/main.c 2005-12-16 09:24:38.000000000 +0000
18@@ -20,17 +20,11 @@
19 */
20 #include <glib.h>
21 #include <libgalago/galago.h>
22-#include <libedata-book/Evolution-DataServer-Addressbook.h>
23
24 #include <libebook/e-book.h>
25-#include <libedata-book/e-data-book-factory.h>
26-#include <bonobo/bonobo-main.h>
27
28 #include <string.h>
29
30-#define E_DATA_BOOK_FACTORY_OAF_ID \
31- "OAFIID:GNOME_Evolution_DataServer_BookFactory"
32-
33 static EBookView *book_view = NULL;
34 static EBook *book = NULL;
35 static gulong book_view_tag = 0;
36@@ -157,8 +151,8 @@
37 galago_person_set_photo(person, NULL);
38 else
39 {
40- galago_photo_new(person, (unsigned char *)ephoto->data,
41- ephoto->length);
42+// galago_photo_new(person, (unsigned char *)ephoto->data,
43+// ephoto->length);
44 }
45 }
46
47@@ -294,15 +288,6 @@
48
49 galago_core_set_exit_with_daemon(TRUE);
50
51- if (!bonobo_init_full(NULL, NULL, bonobo_activation_orb_get(),
52- CORBA_OBJECT_NIL, CORBA_OBJECT_NIL))
53- {
54- fprintf(stderr, "Unable to initialize bonobo.\n");
55- exit(1);
56- }
57-
58- bonobo_activate();
59-
60 setup_book_view();
61 setup_services();
62