summaryrefslogtreecommitdiffstats
path: root/meta/packages/flex
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/flex')
-rw-r--r--meta/packages/flex/files/fix-gen.patch17
-rw-r--r--meta/packages/flex/files/flex-lvalue.diff36
-rw-r--r--meta/packages/flex/flex-2.5.31/include.patch27
-rw-r--r--meta/packages/flex/flex-native_2.5.31.bb10
-rw-r--r--meta/packages/flex/flex.inc11
-rw-r--r--meta/packages/flex/flex_2.5.31.bb9
6 files changed, 110 insertions, 0 deletions
diff --git a/meta/packages/flex/files/fix-gen.patch b/meta/packages/flex/files/fix-gen.patch
new file mode 100644
index 0000000000..55f4f6fdf5
--- /dev/null
+++ b/meta/packages/flex/files/fix-gen.patch
@@ -0,0 +1,17 @@
1
2#
3# Patch managed by http://www.holgerschurig.de/patcher.html
4#
5
6--- flex-2.5.31/gen.c~fix-gen
7+++ flex-2.5.31/gen.c
8@@ -1812,8 +1812,7 @@
9 if (yytext_is_array) {
10 if (!reentrant){
11 indent_puts ("static int yy_more_offset = 0;");
12- }else{
13- indent_puts ("static int yy_prev_more_offset = 0;");
14+ indent_puts ("static int yy_prev_more_offset = 0;");
15 }
16 }
17 else if (!reentrant) {
diff --git a/meta/packages/flex/files/flex-lvalue.diff b/meta/packages/flex/files/flex-lvalue.diff
new file mode 100644
index 0000000000..56ae539a6c
--- /dev/null
+++ b/meta/packages/flex/files/flex-lvalue.diff
@@ -0,0 +1,36 @@
1Patch from http://bugs.debian.org/cgi-bin/bugreport.cgi/flex-lvalue.diff?bug=194844;msg=10;att=1
2
3according to posix 0,1,2 are already setup and this avoids
4the issues with
5| filter.c: In function 'filter_apply_chain':
6| filter.c:161: error: invalid lvalue in assignment
7| filter.c:163: error: invalid lvalue in assignment
8| filter.c:184: error: invalid lvalue in assignment
9
10
11diff -ur flex-2.5.31.ORIG/filter.c flex-2.5.31/filter.c
12--- flex-2.5.31.ORIG/filter.c 2003-03-25 16:39:08.000000000 +0000
13+++ flex-2.5.31/filter.c 2003-05-27 17:00:26.000000000 +0000
14@@ -157,11 +157,8 @@
15 if (chain->filter_func) {
16 int r;
17
18- /* setup streams again */
19- if ((stdin = fdopen (0, "r")) == NULL)
20- flexfatal (_("fdopen(0) failed"));
21- if ((stdout = fdopen (1, "w")) == NULL)
22- flexfatal (_("fdopen(1) failed"));
23+ /* POSIX says we inherit fd[0-2], so we don't need
24+ to do anything to them here */
25
26 if ((r = chain->filter_func (chain)) == -1)
27 flexfatal (_("filter_func failed"));
28@@ -181,8 +178,6 @@
29 if (dup2 (pipes[1], 1) == -1)
30 flexfatal (_("dup2(pipes[1],1)"));
31 close (pipes[1]);
32- if ((stdout = fdopen (1, "w")) == NULL)
33- flexfatal (_("fdopen(1) failed"));
34
35 return true;
36 }
diff --git a/meta/packages/flex/flex-2.5.31/include.patch b/meta/packages/flex/flex-2.5.31/include.patch
new file mode 100644
index 0000000000..b60dcb29de
--- /dev/null
+++ b/meta/packages/flex/flex-2.5.31/include.patch
@@ -0,0 +1,27 @@
1
2#
3# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
4#
5
6--- flex-2.5.31/Makefile.am~include
7+++ flex-2.5.31/Makefile.am
8@@ -141,7 +141,7 @@
9 tests
10
11 localedir = $(datadir)/locale
12-AM_CPPFLAGS = -DLOCALEDIR=\"$(localedir)\" -I@includedir@ -I$(top_srcdir)/intl
13+AM_CPPFLAGS = -DLOCALEDIR=\"$(localedir)\" -I$(top_srcdir)/intl
14 LIBS = @LIBINTL@ @LIBS@
15
16 skel.c: flex.skl mkskel.sh flexint.h tables_shared.h
17--- flex-2.5.31/Makefile.in~include
18+++ flex-2.5.31/Makefile.in
19@@ -292,7 +292,7 @@
20
21
22 localedir = $(datadir)/locale
23-AM_CPPFLAGS = -DLOCALEDIR=\"$(localedir)\" -I@includedir@ -I$(top_srcdir)/intl
24+AM_CPPFLAGS = -DLOCALEDIR=\"$(localedir)\" -I$(top_srcdir)/intl
25
26 # Run GNU indent on sources. Don't run this unless all the sources compile cleanly.
27 #
diff --git a/meta/packages/flex/flex-native_2.5.31.bb b/meta/packages/flex/flex-native_2.5.31.bb
new file mode 100644
index 0000000000..ff8a42772b
--- /dev/null
+++ b/meta/packages/flex/flex-native_2.5.31.bb
@@ -0,0 +1,10 @@
1include flex.inc
2inherit native
3PR = "r2"
4
5do_stage () {
6 install -m 0755 flex ${STAGING_BINDIR}
7 oe_libinstall -a libfl ${STAGING_LIBDIR}
8 ln -sf ./flex ${STAGING_BINDIR}/flex++
9 ln -sf ./flex ${STAGING_BINDIR}/lex
10}
diff --git a/meta/packages/flex/flex.inc b/meta/packages/flex/flex.inc
new file mode 100644
index 0000000000..d6affad226
--- /dev/null
+++ b/meta/packages/flex/flex.inc
@@ -0,0 +1,11 @@
1DESCRIPTION = "Flex is a tool for generating programs that recognize lexical patterns in text."
2SECTION = "devel"
3LICENSE = "BSD"
4
5SRC_URI = "${SOURCEFORGE_MIRROR}/lex/flex-2.5.31.tar.bz2 \
6 file://flex-lvalue.diff;patch=1 \
7 file://fix-gen.patch;patch=1"
8S = "${WORKDIR}/flex-${PV}"
9
10inherit autotools
11
diff --git a/meta/packages/flex/flex_2.5.31.bb b/meta/packages/flex/flex_2.5.31.bb
new file mode 100644
index 0000000000..b96c645136
--- /dev/null
+++ b/meta/packages/flex/flex_2.5.31.bb
@@ -0,0 +1,9 @@
1include flex.inc
2PR = "r4"
3
4SRC_URI += "file://include.patch;patch=1"
5
6do_stage() {
7 oe_libinstall -a libfl ${STAGING_LIBDIR}
8}
9