diff options
Diffstat (limited to 'meta/packages/flac')
-rw-r--r-- | meta/packages/flac/flac-1.1.2/disable-xmms-plugin.patch | 21 | ||||
-rw-r--r-- | meta/packages/flac/flac-1.1.2/xmms.m4 | 148 | ||||
-rw-r--r-- | meta/packages/flac/flac_1.1.2.bb | 82 |
3 files changed, 251 insertions, 0 deletions
diff --git a/meta/packages/flac/flac-1.1.2/disable-xmms-plugin.patch b/meta/packages/flac/flac-1.1.2/disable-xmms-plugin.patch new file mode 100644 index 0000000000..e42fcbd84d --- /dev/null +++ b/meta/packages/flac/flac-1.1.2/disable-xmms-plugin.patch | |||
@@ -0,0 +1,21 @@ | |||
1 | --- flac-1.1.0/src/Makefile.am.orig 2004-12-25 01:11:45.000000000 +0100 | ||
2 | +++ flac-1.1.0/src/Makefile.am 2004-12-25 01:12:10.000000000 +0100 | ||
3 | @@ -15,10 +15,6 @@ | ||
4 | # along with this program; if not, write to the Free Software | ||
5 | # Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA. | ||
6 | |||
7 | -if FLaC__HAS_XMMS | ||
8 | -XMMS_DIRS = plugin_xmms | ||
9 | -endif | ||
10 | - | ||
11 | if FLaC__HAS_OGG | ||
12 | OGGFLAC_DIRS = libOggFLAC libOggFLAC++ | ||
13 | OGGFLAC_TEST_DIRS = test_libOggFLAC test_libOggFLAC++ | ||
14 | @@ -33,7 +29,6 @@ | ||
15 | metaflac \ | ||
16 | monkeys_audio_utilities \ | ||
17 | plugin_common \ | ||
18 | - $(XMMS_DIRS) \ | ||
19 | plugin_winamp2 \ | ||
20 | plugin_winamp3 \ | ||
21 | test_grabbag \ | ||
diff --git a/meta/packages/flac/flac-1.1.2/xmms.m4 b/meta/packages/flac/flac-1.1.2/xmms.m4 new file mode 100644 index 0000000000..6d1489bf19 --- /dev/null +++ b/meta/packages/flac/flac-1.1.2/xmms.m4 | |||
@@ -0,0 +1,148 @@ | |||
1 | # CFLAGS and library paths for XMMS | ||
2 | # written 15 December 1999 by Ben Gertzfield <che@debian.org> | ||
3 | |||
4 | dnl Usage: | ||
5 | dnl AM_PATH_XMMS([MINIMUM-VERSION, [ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND]]]) | ||
6 | dnl | ||
7 | dnl Example: | ||
8 | dnl AM_PATH_XMMS(0.9.5.1, , AC_MSG_ERROR([*** XMMS >= 0.9.5.1 not installed - please install first ***])) | ||
9 | dnl | ||
10 | dnl Defines XMMS_CFLAGS, XMMS_LIBS, XMMS_DATA_DIR, XMMS_PLUGIN_DIR, | ||
11 | dnl XMMS_VISUALIZATION_PLUGIN_DIR, XMMS_INPUT_PLUGIN_DIR, | ||
12 | dnl XMMS_OUTPUT_PLUGIN_DIR, XMMS_GENERAL_PLUGIN_DIR, XMMS_EFFECT_PLUGIN_DIR, | ||
13 | dnl and XMMS_VERSION for your plugin pleasure. | ||
14 | dnl | ||
15 | |||
16 | dnl XMMS_TEST_VERSION(AVAILABLE-VERSION, NEEDED-VERSION [, ACTION-IF-OKAY [, ACTION-IF-NOT-OKAY]]) | ||
17 | AC_DEFUN(XMMS_TEST_VERSION, [ | ||
18 | |||
19 | # Determine which version number is greater. Prints 2 to stdout if | ||
20 | # the second number is greater, 1 if the first number is greater, | ||
21 | # 0 if the numbers are equal. | ||
22 | |||
23 | # Written 15 December 1999 by Ben Gertzfield <che@debian.org> | ||
24 | # Revised 15 December 1999 by Jim Monty <monty@primenet.com> | ||
25 | |||
26 | AC_PROG_AWK | ||
27 | xmms_got_version=[` $AWK ' \ | ||
28 | BEGIN { \ | ||
29 | print vercmp(ARGV[1], ARGV[2]); \ | ||
30 | } \ | ||
31 | \ | ||
32 | function vercmp(ver1, ver2, ver1arr, ver2arr, \ | ||
33 | ver1len, ver2len, \ | ||
34 | ver1int, ver2int, len, i, p) { \ | ||
35 | \ | ||
36 | ver1len = split(ver1, ver1arr, /\./); \ | ||
37 | ver2len = split(ver2, ver2arr, /\./); \ | ||
38 | \ | ||
39 | len = ver1len > ver2len ? ver1len : ver2len; \ | ||
40 | \ | ||
41 | for (i = 1; i <= len; i++) { \ | ||
42 | p = 1000 ^ (len - i); \ | ||
43 | ver1int += ver1arr[i] * p; \ | ||
44 | ver2int += ver2arr[i] * p; \ | ||
45 | } \ | ||
46 | \ | ||
47 | if (ver1int < ver2int) \ | ||
48 | return 2; \ | ||
49 | else if (ver1int > ver2int) \ | ||
50 | return 1; \ | ||
51 | else \ | ||
52 | return 0; \ | ||
53 | }' $1 $2`] | ||
54 | |||
55 | if test $xmms_got_version -eq 2; then # failure | ||
56 | ifelse([$4], , :, $4) | ||
57 | else # success! | ||
58 | ifelse([$3], , :, $3) | ||
59 | fi | ||
60 | ]) | ||
61 | |||
62 | AC_DEFUN(AM_PATH_XMMS, | ||
63 | [ | ||
64 | AC_ARG_WITH(xmms-prefix,[ --with-xmms-prefix=PFX Prefix where XMMS is installed (optional)], | ||
65 | xmms_config_prefix="$withval", xmms_config_prefix="") | ||
66 | AC_ARG_WITH(xmms-exec-prefix,[ --with-xmms-exec-prefix=PFX Exec prefix where XMMS is installed (optional)], | ||
67 | xmms_config_exec_prefix="$withval", xmms_config_exec_prefix="") | ||
68 | |||
69 | if test x$xmms_config_exec_prefix != x; then | ||
70 | xmms_config_args="$xmms_config_args --exec-prefix=$xmms_config_exec_prefix" | ||
71 | if test x${XMMS_CONFIG+set} != xset; then | ||
72 | XMMS_CONFIG=$xmms_config_exec_prefix/bin/xmms-config | ||
73 | fi | ||
74 | fi | ||
75 | |||
76 | if test x$xmms_config_prefix != x; then | ||
77 | xmms_config_args="$xmms_config_args --prefix=$xmms_config_prefix" | ||
78 | if test x${XMMS_CONFIG+set} != xset; then | ||
79 | XMMS_CONFIG=$xmms_config_prefix/bin/xmms-config | ||
80 | fi | ||
81 | fi | ||
82 | |||
83 | AC_PATH_PROG(XMMS_CONFIG, xmms-config, no) | ||
84 | min_xmms_version=ifelse([$1], ,0.9.5.1, $1) | ||
85 | |||
86 | if test "$XMMS_CONFIG" = "no"; then | ||
87 | no_xmms=yes | ||
88 | else | ||
89 | XMMS_CFLAGS=`$XMMS_CONFIG $xmms_config_args --cflags` | ||
90 | XMMS_LIBS=`$XMMS_CONFIG $xmms_config_args --libs` | ||
91 | XMMS_VERSION=`$XMMS_CONFIG $xmms_config_args --version` | ||
92 | XMMS_DATA_DIR=`$XMMS_CONFIG $xmms_config_args --data-dir` | ||
93 | XMMS_PLUGIN_DIR=`$XMMS_CONFIG $xmms_config_args --plugin-dir` | ||
94 | XMMS_VISUALIZATION_PLUGIN_DIR=`$XMMS_CONFIG $xmms_config_args \ | ||
95 | --visualization-plugin-dir` | ||
96 | XMMS_INPUT_PLUGIN_DIR=`$XMMS_CONFIG $xmms_config_args --input-plugin-dir` | ||
97 | XMMS_OUTPUT_PLUGIN_DIR=`$XMMS_CONFIG $xmms_config_args --output-plugin-dir` | ||
98 | XMMS_EFFECT_PLUGIN_DIR=`$XMMS_CONFIG $xmms_config_args --effect-plugin-dir` | ||
99 | XMMS_GENERAL_PLUGIN_DIR=`$XMMS_CONFIG $xmms_config_args --general-plugin-dir` | ||
100 | |||
101 | XMMS_TEST_VERSION($XMMS_VERSION, $min_xmms_version, ,no_xmms=version) | ||
102 | fi | ||
103 | |||
104 | AC_MSG_CHECKING(for XMMS - version >= $min_xmms_version) | ||
105 | |||
106 | if test "x$no_xmms" = x; then | ||
107 | AC_MSG_RESULT(yes) | ||
108 | ifelse([$2], , :, [$2]) | ||
109 | else | ||
110 | AC_MSG_RESULT(no) | ||
111 | |||
112 | if test "$XMMS_CONFIG" = "no" ; then | ||
113 | echo "*** The xmms-config script installed by XMMS could not be found." | ||
114 | echo "*** If XMMS was installed in PREFIX, make sure PREFIX/bin is in" | ||
115 | echo "*** your path, or set the XMMS_CONFIG environment variable to the" | ||
116 | echo "*** full path to xmms-config." | ||
117 | else | ||
118 | if test "$no_xmms" = "version"; then | ||
119 | echo "*** An old version of XMMS, $XMMS_VERSION, was found." | ||
120 | echo "*** You need a version of XMMS newer than $min_xmms_version." | ||
121 | echo "*** The latest version of XMMS is always available from" | ||
122 | echo "*** http://www.xmms.org/" | ||
123 | echo "***" | ||
124 | |||
125 | echo "*** If you have already installed a sufficiently new version, this error" | ||
126 | echo "*** probably means that the wrong copy of the xmms-config shell script is" | ||
127 | echo "*** being found. The easiest way to fix this is to remove the old version" | ||
128 | echo "*** of XMMS, but you can also set the XMMS_CONFIG environment to point to the" | ||
129 | echo "*** correct copy of xmms-config. (In this case, you will have to" | ||
130 | echo "*** modify your LD_LIBRARY_PATH enviroment variable, or edit /etc/ld.so.conf" | ||
131 | echo "*** so that the correct libraries are found at run-time)" | ||
132 | fi | ||
133 | fi | ||
134 | XMMS_CFLAGS="" | ||
135 | XMMS_LIBS="" | ||
136 | ifelse([$3], , :, [$3]) | ||
137 | fi | ||
138 | AC_SUBST(XMMS_CFLAGS) | ||
139 | AC_SUBST(XMMS_LIBS) | ||
140 | AC_SUBST(XMMS_VERSION) | ||
141 | AC_SUBST(XMMS_DATA_DIR) | ||
142 | AC_SUBST(XMMS_PLUGIN_DIR) | ||
143 | AC_SUBST(XMMS_VISUALIZATION_PLUGIN_DIR) | ||
144 | AC_SUBST(XMMS_INPUT_PLUGIN_DIR) | ||
145 | AC_SUBST(XMMS_OUTPUT_PLUGIN_DIR) | ||
146 | AC_SUBST(XMMS_GENERAL_PLUGIN_DIR) | ||
147 | AC_SUBST(XMMS_EFFECT_PLUGIN_DIR) | ||
148 | ]) | ||
diff --git a/meta/packages/flac/flac_1.1.2.bb b/meta/packages/flac/flac_1.1.2.bb new file mode 100644 index 0000000000..ec9d1b7197 --- /dev/null +++ b/meta/packages/flac/flac_1.1.2.bb | |||
@@ -0,0 +1,82 @@ | |||
1 | DESCRIPTION = "FLAC is a Free Lossless Audio Codec." | ||
2 | MAINTAINER = "Chris Larson <kergoth@handhelds.org>" | ||
3 | LICENSE = "BSD GPL" | ||
4 | SECTION = "libs" | ||
5 | DEPENDS = "libogg" | ||
6 | PR = "r4" | ||
7 | |||
8 | SRC_URI = "${SOURCEFORGE_MIRROR}/flac/flac-${PV}.tar.gz \ | ||
9 | file://disable-xmms-plugin.patch;patch=1 \ | ||
10 | file://xmms.m4" | ||
11 | |||
12 | S = "${WORKDIR}/flac-${PV}" | ||
13 | |||
14 | inherit autotools | ||
15 | |||
16 | EXTRA_OECONF = "--disable-oggtest --disable-id3libtest \ | ||
17 | --with-ogg-libraries=${STAGING_LIBDIR} \ | ||
18 | --with-ogg-includes=${STAGING_INCDIR} \ | ||
19 | --without-xmms-prefix \ | ||
20 | --without-xmms-exec-prefix \ | ||
21 | --without-libiconv-prefix \ | ||
22 | --without-id3lib" | ||
23 | |||
24 | PACKAGES += "libflac libflac++ liboggflac liboggflac++" | ||
25 | FILES_${PN} = "${bindir}" | ||
26 | FILES_libflac = "${libdir}/libFLAC.so.*" | ||
27 | FILES_libflac++ = "${libdir}/libFLAC++.so.*" | ||
28 | FILES_liboggflac = "${libdir}/libOggFLAC.so.*" | ||
29 | FILES_liboggflac++ = "${libdir}/libOggFLAC++.so.*" | ||
30 | |||
31 | do_configure () { | ||
32 | install -d ${S}/m4 | ||
33 | install -m 0644 ${WORKDIR}/xmms.m4 ${S}/m4/ | ||
34 | autotools_do_configure | ||
35 | } | ||
36 | |||
37 | do_stage () { | ||
38 | install -d ${STAGING_DATADIR}/aclocal | ||
39 | |||
40 | oe_libinstall -a -so -C src/libOggFLAC libOggFLAC ${STAGING_LIBDIR}/ | ||
41 | install -d ${STAGING_INCDIR}/OggFLAC | ||
42 | install -m 0644 ${S}/include/OggFLAC/export.h ${STAGING_INCDIR}/OggFLAC/export.h | ||
43 | |||
44 | install -m 0644 ${S}/include/OggFLAC/all.h ${STAGING_INCDIR}/OggFLAC/all.h | ||
45 | install -m 0644 ${S}/include/OggFLAC/stream_encoder.h ${STAGING_INCDIR}/OggFLAC/stream_encoder.h | ||
46 | install -m 0644 ${S}/include/OggFLAC/stream_decoder.h ${STAGING_INCDIR}/OggFLAC/stream_decoder.h | ||
47 | install -m 0644 ${S}/src/libOggFLAC/libOggFLAC.m4 ${STAGING_DATADIR}/aclocal/ | ||
48 | |||
49 | oe_libinstall -a -so -C src/libFLAC libFLAC ${STAGING_LIBDIR}/ | ||
50 | install -d ${STAGING_INCDIR}/FLAC | ||
51 | install -m 0644 ${S}/include/FLAC/export.h ${STAGING_INCDIR}/FLAC/export.h | ||
52 | install -m 0644 ${S}/include/FLAC/metadata.h ${STAGING_INCDIR}/FLAC/metadata.h | ||
53 | install -m 0644 ${S}/include/FLAC/all.h ${STAGING_INCDIR}/FLAC/all.h | ||
54 | install -m 0644 ${S}/include/FLAC/format.h ${STAGING_INCDIR}/FLAC/format.h | ||
55 | install -m 0644 ${S}/include/FLAC/stream_encoder.h ${STAGING_INCDIR}/FLAC/stream_encoder.h | ||
56 | install -m 0644 ${S}/include/FLAC/stream_decoder.h ${STAGING_INCDIR}/FLAC/stream_decoder.h | ||
57 | install -m 0644 ${S}/include/FLAC/ordinals.h ${STAGING_INCDIR}/FLAC/ordinals.h | ||
58 | install -m 0644 ${S}/include/FLAC/seekable_stream_encoder.h ${STAGING_INCDIR}/FLAC/seekable_stream_encoder.h | ||
59 | install -m 0644 ${S}/include/FLAC/file_encoder.h ${STAGING_INCDIR}/FLAC/file_encoder.h | ||
60 | install -m 0644 ${S}/include/FLAC/seekable_stream_decoder.h ${STAGING_INCDIR}/FLAC/seekable_stream_decoder.h | ||
61 | install -m 0644 ${S}/include/FLAC/file_decoder.h ${STAGING_INCDIR}/FLAC/file_decoder.h | ||
62 | install -m 0644 ${S}/include/FLAC/assert.h ${STAGING_INCDIR}/FLAC/assert.h | ||
63 | install -m 0644 ${S}/include/FLAC/callback.h ${STAGING_INCDIR}/FLAC/callback.h | ||
64 | install -m 0644 ${S}/src/libFLAC/libFLAC.m4 ${STAGING_DATADIR}/aclocal/ | ||
65 | |||
66 | oe_libinstall -a -so -C src/libFLAC++ libFLAC++ ${STAGING_LIBDIR}/ | ||
67 | install -d ${STAGING_INCDIR}/FLAC++ | ||
68 | install -m 0644 ${S}/include/FLAC++/export.h ${STAGING_INCDIR}/FLAC++/export.h | ||
69 | install -m 0644 ${S}/include/FLAC++/metadata.h ${STAGING_INCDIR}/FLAC++/metadata.h | ||
70 | install -m 0644 ${S}/include/FLAC++/all.h ${STAGING_INCDIR}/FLAC++/all.h | ||
71 | install -m 0644 ${S}/include/FLAC++/encoder.h ${STAGING_INCDIR}/FLAC++/encoder.h | ||
72 | install -m 0644 ${S}/include/FLAC++/decoder.h ${STAGING_INCDIR}/FLAC++/decoder.h | ||
73 | install -m 0644 ${S}/src/libFLAC++/libFLAC++.m4 ${STAGING_DATADIR}/aclocal/ | ||
74 | |||
75 | oe_libinstall -a -so -C src/libOggFLAC++ libOggFLAC++ ${STAGING_LIBDIR}/ | ||
76 | install -d ${STAGING_INCDIR}/OggFLAC++ | ||
77 | install -m 0644 ${S}/include/OggFLAC++/export.h ${STAGING_INCDIR}/OggFLAC++/export.h | ||
78 | install -m 0644 ${S}/include/OggFLAC++/all.h ${STAGING_INCDIR}/OggFLAC++/all.h | ||
79 | install -m 0644 ${S}/include/OggFLAC++/encoder.h ${STAGING_INCDIR}/OggFLAC++/encoder.h | ||
80 | install -m 0644 ${S}/include/OggFLAC++/decoder.h ${STAGING_INCDIR}/OggFLAC++/decoder.h | ||
81 | install -m 0644 ${S}/src/libOggFLAC++/libOggFLAC++.m4 ${STAGING_DATADIR}/aclocal/ | ||
82 | } | ||