summaryrefslogtreecommitdiffstats
path: root/meta/packages/file
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/file')
-rw-r--r--meta/packages/file/file-native_4.16.bb8
-rw-r--r--meta/packages/file/file_4.16.bb18
-rw-r--r--meta/packages/file/files/native-fix.diff13
3 files changed, 39 insertions, 0 deletions
diff --git a/meta/packages/file/file-native_4.16.bb b/meta/packages/file/file-native_4.16.bb
new file mode 100644
index 0000000000..3228ed683c
--- /dev/null
+++ b/meta/packages/file/file-native_4.16.bb
@@ -0,0 +1,8 @@
1include file_${PV}.bb
2inherit native
3
4# avoid dependency loop
5DEPENDS = ""
6PR = "r1"
7
8SRC_URI += "file://native-fix.diff;patch=1"
diff --git a/meta/packages/file/file_4.16.bb b/meta/packages/file/file_4.16.bb
new file mode 100644
index 0000000000..3e579c5ef4
--- /dev/null
+++ b/meta/packages/file/file_4.16.bb
@@ -0,0 +1,18 @@
1DESCRIPTION = "File attempts to classify files depending \
2on their contents and prints a description if a match is found."
3SECTION = "console/utils"
4LICENSE = "BSD-ADV"
5DEPENDS = "file-native"
6
7SRC_URI = "ftp://ftp.astron.com/pub/file/file-${PV}.tar.gz"
8S = "${WORKDIR}/file-${PV}"
9
10inherit autotools
11
12do_configure_prepend() {
13 sed -i -e 's,$(top_builddir)/src/file,file,' ${S}/magic/Makefile.am
14}
15
16do_stage() {
17 autotools_stage_all
18}
diff --git a/meta/packages/file/files/native-fix.diff b/meta/packages/file/files/native-fix.diff
new file mode 100644
index 0000000000..d17215a1b4
--- /dev/null
+++ b/meta/packages/file/files/native-fix.diff
@@ -0,0 +1,13 @@
1Index: file-4.16/magic/Makefile.am
2===================================================================
3--- file-4.16.orig/magic/Makefile.am 2005-08-18 17:20:49.000000000 +0200
4+++ file-4.16/magic/Makefile.am 2006-03-08 17:01:13.000000000 +0100
5@@ -18,7 +18,7 @@
6 if IS_CROSS_COMPILE
7 FILE_COMPILE = file
8 else
9-FILE_COMPILE = $(top_builddir)/src/file
10+FILE_COMPILE = ../src/file
11 endif
12
13 magic.mgc: magic