summaryrefslogtreecommitdiffstats
path: root/meta/packages/file/file_4.18.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/file/file_4.18.bb')
-rw-r--r--meta/packages/file/file_4.18.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/packages/file/file_4.18.bb b/meta/packages/file/file_4.18.bb
new file mode 100644
index 0000000000..4c8e64c308
--- /dev/null
+++ b/meta/packages/file/file_4.18.bb
@@ -0,0 +1,25 @@
1DESCRIPTION = "File attempts to classify files depending \
2on their contents and prints a description if a match is found."
3HOMEPAGE = "http://www.darwinsys.com/file/"
4SECTION = "console/utils"
5
6# two clause BSD
7LICENSE = "BSD"
8
9DEPENDS = "file-native"
10DEPENDS_virtclass-native = ""
11
12SRC_URI = "ftp://ftp.astron.com/pub/file/file-${PV}.tar.gz \
13 file://dump \
14 file://filesystems"
15SRC_URI_append_virtclass-native = " file://native-fix.diff;patch=1"
16
17inherit autotools
18
19do_configure_prepend() {
20 sed -i -e 's,$(top_builddir)/src/file,file,' ${S}/magic/Makefile.am
21 cp ${WORKDIR}/dump ${S}/magic/Magdir/
22 cp ${WORKDIR}/filesystems ${S}/magic/Magdir/
23}
24
25BBCLASSEXTEND = "native"