summaryrefslogtreecommitdiffstats
path: root/meta/packages/fakeroot
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/fakeroot')
-rw-r--r--meta/packages/fakeroot/fakeroot-native_1.2.13.bb19
-rw-r--r--meta/packages/fakeroot/fakeroot_1.2.13.bb8
-rw-r--r--meta/packages/fakeroot/files/fix-prefix.patch18
3 files changed, 45 insertions, 0 deletions
diff --git a/meta/packages/fakeroot/fakeroot-native_1.2.13.bb b/meta/packages/fakeroot/fakeroot-native_1.2.13.bb
new file mode 100644
index 0000000000..cc3dfd2231
--- /dev/null
+++ b/meta/packages/fakeroot/fakeroot-native_1.2.13.bb
@@ -0,0 +1,19 @@
1SECTION = "base"
2PR = "r0"
3include fakeroot_${PV}.bb
4inherit native
5
6SRC_URI += "file://fix-prefix.patch;patch=1"
7S = "${WORKDIR}/fakeroot-${PV}"
8
9EXTRA_OECONF = " --program-prefix="
10
11# Compatability for the rare systems not using or having SYSV
12python () {
13 if bb.data.getVar('HOST_NONSYSV', d, True) and bb.data.getVar('HOST_NONSYSV', d, True) != '0':
14 bb.data.setVar('EXTRA_OECONF', ' --with-ipc=tcp --program-prefix= ', d)
15}
16
17do_stage_append () {
18 oe_libinstall -so libfakeroot ${STAGING_LIBDIR}/libfakeroot/
19}
diff --git a/meta/packages/fakeroot/fakeroot_1.2.13.bb b/meta/packages/fakeroot/fakeroot_1.2.13.bb
new file mode 100644
index 0000000000..8ae7ca38be
--- /dev/null
+++ b/meta/packages/fakeroot/fakeroot_1.2.13.bb
@@ -0,0 +1,8 @@
1DESCRIPTION = "Gives a fake root environment"
2SECTION = "base"
3HOMEPAGE = "http://joostje.op.het.net/fakeroot/index.html"
4LICENSE = "GPL"
5
6SRC_URI = "http://openzaurus.org/mirror/fakeroot_${PV}.tar.gz"
7
8inherit autotools
diff --git a/meta/packages/fakeroot/files/fix-prefix.patch b/meta/packages/fakeroot/files/fix-prefix.patch
new file mode 100644
index 0000000000..3884aca01c
--- /dev/null
+++ b/meta/packages/fakeroot/files/fix-prefix.patch
@@ -0,0 +1,18 @@
1
2#
3# Patch managed by http://www.holgerschurig.de/patcher.html
4#
5
6--- fakeroot-1.2.13/scripts/fakeroot.in~fix-prefix
7+++ fakeroot-1.2.13/scripts/fakeroot.in
8@@ -15,8 +15,8 @@
9 }
10
11 # strip /bin/fakeroot to find install prefix
12-PREFIX=@prefix@
13-BINDIR=@bindir@
14+BINDIR=`dirname $0`
15+PREFIX=`dirname ${BINDIR}`
16
17 LIB=lib@fakeroot_transformed@.so.0
18 PATHS=@libdir@:${PREFIX}/lib64/libfakeroot:${PREFIX}/lib32/libfakeroot