summaryrefslogtreecommitdiffstats
path: root/meta/packages/fakeroot/fakeroot_1.14.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/fakeroot/fakeroot_1.14.4.bb')
-rw-r--r--meta/packages/fakeroot/fakeroot_1.14.4.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/packages/fakeroot/fakeroot_1.14.4.bb b/meta/packages/fakeroot/fakeroot_1.14.4.bb
new file mode 100644
index 0000000000..11ae015a83
--- /dev/null
+++ b/meta/packages/fakeroot/fakeroot_1.14.4.bb
@@ -0,0 +1,32 @@
1DESCRIPTION = "Provides a fake \"root environment\" by means of LD_PRELOAD and SYSV IPC or TCP trickery"
2HOMEPAGE = "http://fakeroot.alioth.debian.org/"
3SECTION = "base"
4LICENSE = "GPLv2"
5# fakeroot needs getopt which is provided by the util-linux package
6RDEPENDS = "util-linux"
7RDEPENDS_virtclass-native = "util-linux-native"
8PR = "r0"
9
10SRC_URI = "${DEBIAN_MIRROR}/main/f/fakeroot/fakeroot_${PV}.orig.tar.bz2 \
11 file://absolutepaths.patch"
12
13inherit autotools
14
15do_configure_prepend() {
16 # fakeroot's own bootstrap includes other autoreconf stuff we don't need here
17 # so manually create the aux directory
18 mkdir -p ${S}/build-aux
19}
20
21do_install_append() {
22 install -d ${D}${STAGING_INCDIR}/fakeroot/
23 install -m 644 *.h ${D}${STAGING_INCDIR}/fakeroot
24}
25
26# Compatability for the rare systems not using or having SYSV
27python () {
28 if bb.data.inherits_class("native", d) and bb.data.getVar('HOST_NONSYSV', d, True) and bb.data.getVar('HOST_NONSYSV', d, True) != '0':
29 bb.data.setVar('EXTRA_OECONF', ' --with-ipc=tcp ', d)
30}
31
32BBCLASSEXTEND = "native"