summaryrefslogtreecommitdiffstats
path: root/meta/packages/fakeroot/fakeroot-native_1.9.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/fakeroot/fakeroot-native_1.9.4.bb')
-rw-r--r--meta/packages/fakeroot/fakeroot-native_1.9.4.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta/packages/fakeroot/fakeroot-native_1.9.4.bb b/meta/packages/fakeroot/fakeroot-native_1.9.4.bb
new file mode 100644
index 0000000000..77d6f58651
--- /dev/null
+++ b/meta/packages/fakeroot/fakeroot-native_1.9.4.bb
@@ -0,0 +1,21 @@
1require fakeroot_${PV}.bb
2
3RDEPENDS="util-linux-native"
4
5SRC_URI += "file://fix-prefix.patch;patch=1 "
6S = "${WORKDIR}/fakeroot-${PV}"
7
8inherit native
9
10EXTRA_OECONF = " --program-prefix="
11
12# Compatability for the rare systems not using or having SYSV
13python () {
14 if bb.data.getVar('HOST_NONSYSV', d, True) and bb.data.getVar('HOST_NONSYSV', d, True) != '0':
15 bb.data.setVar('EXTRA_OECONF', ' --with-ipc=tcp --program-prefix= ', d)
16}
17
18do_stage_append () {
19 oe_libinstall -so libfakeroot ${STAGING_LIBDIR}/libfakeroot/
20}
21