diff options
Diffstat (limited to 'meta/packages/exmap-console')
-rw-r--r-- | meta/packages/exmap-console/exmap_console.bb | 41 |
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/packages/exmap-console/exmap_console.bb b/meta/packages/exmap-console/exmap_console.bb new file mode 100644 index 0000000000..b5329cb9e3 --- /dev/null +++ b/meta/packages/exmap-console/exmap_console.bb | |||
@@ -0,0 +1,41 @@ | |||
1 | DESCRIPTION = "console-based exmap" | ||
2 | HOMEPAGE = "http://www.o-hand.com" | ||
3 | SECTION = "devel" | ||
4 | LICENSE = "GPL" | ||
5 | PR = "r1" | ||
6 | SRC_DATE=20061026 | ||
7 | |||
8 | SRC_URI = \ | ||
9 | "svn://svn.o-hand.com/repos/misc/trunk;module=exmap-console;proto=http" | ||
10 | |||
11 | inherit module-base | ||
12 | |||
13 | S = "${WORKDIR}/exmap-console" | ||
14 | |||
15 | export KERNEL_PATH=${STAGING_KERNEL_DIR} | ||
16 | |||
17 | do_compile() { | ||
18 | cd ${S}/src | ||
19 | make | ||
20 | |||
21 | cd ${S}/kernel | ||
22 | unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS | ||
23 | oe_runmake KERNEL_PATH=${STAGING_KERNEL_DIR} \ | ||
24 | KERNEL_SRC=${STAGING_KERNEL_DIR} \ | ||
25 | KERNEL_VERSION=${KERNEL_VERSION} \ | ||
26 | CC="${KERNEL_CC}" LD="${KERNEL_LD}" \ | ||
27 | ${MAKE_TARGETS} | ||
28 | } | ||
29 | |||
30 | sbindir="/usr/sbin" | ||
31 | |||
32 | do_install() { | ||
33 | install -d ${D}${sbindir} | ||
34 | install -m 710 ${S}/src/exmap ${D}${sbindir}/exmap | ||
35 | |||
36 | install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/misc | ||
37 | install -m 644 ${S}/kernel/exmap${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/misc/ | ||
38 | } | ||
39 | |||
40 | PACKAGES = "exmap-console" | ||
41 | FILES_exmap-console = "${sbindir}/ /lib/modules/${KERNEL_VERSION}/misc/" | ||