summaryrefslogtreecommitdiffstats
path: root/meta/packages/eds/eds-dbus/no_iconv_test.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/eds/eds-dbus/no_iconv_test.patch')
-rw-r--r--meta/packages/eds/eds-dbus/no_iconv_test.patch70
1 files changed, 70 insertions, 0 deletions
diff --git a/meta/packages/eds/eds-dbus/no_iconv_test.patch b/meta/packages/eds/eds-dbus/no_iconv_test.patch
new file mode 100644
index 0000000000..6e33c7889e
--- /dev/null
+++ b/meta/packages/eds/eds-dbus/no_iconv_test.patch
@@ -0,0 +1,70 @@
1Index: trunk/configure.in
2===================================================================
3--- trunk.orig/configure.in 2005-09-28 17:34:08.000000000 +0000
4+++ trunk/configure.in 2005-09-28 19:13:22.000000000 +0000
5@@ -213,39 +213,6 @@
6 if test $ac_cv_libiconv = no; then
7 AC_CHECK_FUNCS(gnu_get_libc_version)
8 fi
9- AC_CACHE_CHECK([if iconv() handles UTF-8], ac_cv_libiconv_utf8, AC_TRY_RUN([
10-#include <iconv.h>
11-#include <stdlib.h>
12-#include <string.h>
13-#ifdef HAVE_GNU_GET_LIBC_VERSION
14-#include <gnu/libc-version.h>
15-#endif
16-
17-int main (int argc, char **argv)
18-{
19- const char *from = "Some Text \xA4";
20- const char *utf8 = "Some Text \xC2\xA4";
21- char *transbuf = malloc (20), *trans = transbuf;
22- iconv_t cd;
23- size_t from_len = strlen (from), utf8_len = 20;
24- size_t utf8_real_len = strlen (utf8);
25-
26-#ifdef HAVE_GNU_GET_LIBC_VERSION
27- /* glibc 2.1.2's iconv is broken in hard to test ways. */
28- if (!strcmp (gnu_get_libc_version (), "2.1.2"))
29- exit (1);
30-#endif
31-
32- cd = iconv_open ("UTF-8", "ISO_8859-1");
33- if (cd == (iconv_t) -1)
34- exit (1);
35- if (iconv (cd, &from, &from_len, &trans, &utf8_len) == -1 || from_len != 0)
36- exit (1);
37- if (memcmp (utf8, transbuf, utf8_real_len) != 0)
38- exit (1);
39-
40- exit (0);
41-}], ac_cv_libiconv_utf8=yes, [ac_cv_libiconv_utf8=no; have_iconv=no], [ac_cv_libiconv_utf8=no; have_iconv=no]))
42 fi
43
44 if test "$have_iconv" = no; then
45@@ -254,25 +221,6 @@
46 AC_SUBST(ICONV_CFLAGS)
47 AC_SUBST(ICONV_LIBS)
48
49-CFLAGS="$CFLAGS -I$srcdir"
50-
51-AC_MSG_CHECKING(preferred charset formats for system iconv)
52-AC_TRY_RUN([
53-#define CONFIGURE_IN
54-#include "iconv-detect.c"
55-],[
56- AC_MSG_RESULT(found)
57-],[
58- AC_MSG_RESULT(not found)
59- AC_WARN([
60- *** The iconv-detect program was unable to determine the
61- *** preferred charset formats recognized by your system
62- *** iconv library. It is suggested that you install a
63- *** working iconv library such as the one found at
64- *** ftp://ftp.gnu.org/pub/gnu/libiconv
65- ])
66-])
67-
68 CFLAGS="$save_CFLAGS"
69 LIBS="$save_LIBS"
70