summaryrefslogtreecommitdiffstats
path: root/meta/packages/dbus/dbus_1.1.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/dbus/dbus_1.1.4.bb')
-rw-r--r--meta/packages/dbus/dbus_1.1.4.bb64
1 files changed, 64 insertions, 0 deletions
diff --git a/meta/packages/dbus/dbus_1.1.4.bb b/meta/packages/dbus/dbus_1.1.4.bb
new file mode 100644
index 0000000000..6e47790159
--- /dev/null
+++ b/meta/packages/dbus/dbus_1.1.4.bb
@@ -0,0 +1,64 @@
1DEFAULT_PREFERENCE = "-1"
2
3SECTION = "base"
4HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
5DESCRIPTION = "message bus system for applications to talk to one another"
6LICENSE = "GPL"
7DEPENDS = "expat glib-2.0 virtual/libintl"
8
9PR = "r0"
10
11SRC_URI = "http://dbus.freedesktop.org/releases/dbus/dbus-${PV}.tar.gz \
12 file://tmpdir.patch;patch=1 \
13 file://dbus-1.init \
14 file://cross.patch;patch=1 \
15 file://fix-install-daemon.patch;patch=1 \
16 "
17
18inherit autotools pkgconfig update-rc.d gettext
19
20INITSCRIPT_NAME = "dbus-1"
21INITSCRIPT_PARAMS = "defaults"
22
23CONFFILES_${PN} = "${sysconfdir}/dbus-1/system.conf ${sysconfdir}/dbus-1/session.conf"
24
25FILES_${PN} = "${bindir}/dbus-daemon ${bindir}/dbus-launch ${bindir}/dbus-cleanup-sockets ${bindir}/dbus-send ${bindir}/dbus-monitor ${bindir}/dbus-uuidgen ${sysconfdir} ${datadir}/dbus-1/services ${libdir}/lib*.so.*"
26FILES_${PN}-dev += "${libdir}/dbus-1.0/include"
27
28pkg_postinst_dbus() {
29#!/bin/sh
30
31# can't do adduser stuff offline
32if [ "x$D" != "x" ]; then
33 exit 1
34fi
35
36MESSAGEUSER=messagebus
37MESSAGEHOME=/var/run/dbus
38
39mkdir -p $MESSAGEHOME || true
40chgrp "$MESSAGEUSER" "$MESSAGEHOME" 2>/dev/null || addgroup "$MESSAGEUSER"
41chown "$MESSAGEUSER"."$MESSAGEUSER" "$MESSAGEHOME" 2>/dev/null || adduser --system --home "$MESSAGEHOME" --no-create-home --disabled-password --ingroup "$MESSAGEUSER" "$MESSAGEUSER"
42}
43
44EXTRA_OECONF = " --disable-tests --disable-checks --disable-xml-docs \
45 --disable-doxygen-docs --with-xml=expat --without-x"
46
47do_stage () {
48 oe_libinstall -so -C dbus libdbus-1 ${STAGING_LIBDIR}
49
50 autotools_stage_includes
51
52 mkdir -p ${STAGING_LIBDIR}/dbus-1.0/include/dbus/
53 install -m 0644 dbus/dbus-arch-deps.h ${STAGING_LIBDIR}/dbus-1.0/include/dbus/
54}
55
56do_install_append () {
57 install -d ${D}${sysconfdir}/init.d
58 install -m 0755 ${WORKDIR}/dbus-1.init ${D}${sysconfdir}/init.d/dbus-1
59}
60
61python populate_packages_prepend () {
62 if (bb.data.getVar('DEBIAN_NAMES', d, 1)):
63 bb.data.setVar('PKG_dbus', 'dbus-1', d)
64}