diff options
Diffstat (limited to 'meta/packages/dbus/dbus_1.0.2.bb')
-rw-r--r-- | meta/packages/dbus/dbus_1.0.2.bb | 63 |
1 files changed, 3 insertions, 60 deletions
diff --git a/meta/packages/dbus/dbus_1.0.2.bb b/meta/packages/dbus/dbus_1.0.2.bb index 5bb41876a2..4ccc807239 100644 --- a/meta/packages/dbus/dbus_1.0.2.bb +++ b/meta/packages/dbus/dbus_1.0.2.bb | |||
@@ -1,61 +1,4 @@ | |||
1 | SECTION = "base" | 1 | require dbus.inc |
2 | HOMEPAGE = "http://www.freedesktop.org/Software/dbus" | 2 | DEFAULT_PREFERENCE = "1" |
3 | DESCRIPTION = "message bus system for applications to talk to one another" | ||
4 | LICENSE = "GPL" | ||
5 | DEPENDS = "expat glib-2.0 virtual/libintl libx11" | ||
6 | 3 | ||
7 | PR = "r5" | 4 | PR = "r6" |
8 | |||
9 | SRC_URI = "http://dbus.freedesktop.org/releases/dbus/dbus-${PV}.tar.gz \ | ||
10 | file://tmpdir.patch;patch=1 \ | ||
11 | file://dbus-1.init \ | ||
12 | file://cross.patch;patch=1 \ | ||
13 | file://fix-install-daemon.patch;patch=1" | ||
14 | |||
15 | inherit autotools pkgconfig update-rc.d gettext | ||
16 | |||
17 | INITSCRIPT_NAME = "dbus-1" | ||
18 | INITSCRIPT_PARAMS = "defaults" | ||
19 | |||
20 | CONFFILES_${PN} = "${sysconfdir}/dbus-1/system.conf ${sysconfdir}/dbus-1/session.conf" | ||
21 | |||
22 | FILES_${PN} = "${bindir}/dbus-daemon ${bindir}/dbus-launch ${bindir}/dbus-cleanup-sockets ${bindir}/dbus-send ${bindir}/dbus-monitor ${bindir}/dbus-uuidgen ${sysconfdir} ${datadir}/dbus-1/services ${libdir}/lib*.so.*" | ||
23 | FILES_${PN}-dev += "${libdir}/dbus-1.0/include" | ||
24 | |||
25 | pkg_postinst_dbus() { | ||
26 | #!/bin/sh | ||
27 | |||
28 | # can't do adduser stuff offline | ||
29 | if [ "x$D" != "x" ]; then | ||
30 | exit 1 | ||
31 | fi | ||
32 | |||
33 | MESSAGEUSER=messagebus | ||
34 | MESSAGEHOME=/var/run/dbus | ||
35 | |||
36 | mkdir -p $MESSAGEHOME || true | ||
37 | chgrp "$MESSAGEUSER" "$MESSAGEHOME" 2>/dev/null || addgroup "$MESSAGEUSER" | ||
38 | chown "$MESSAGEUSER"."$MESSAGEUSER" "$MESSAGEHOME" 2>/dev/null || adduser --system --home "$MESSAGEHOME" --no-create-home --disabled-password --ingroup "$MESSAGEUSER" "$MESSAGEUSER" | ||
39 | } | ||
40 | |||
41 | EXTRA_OECONF = " --disable-tests --disable-asserts --disable-xml-docs \ | ||
42 | --disable-doxygen-docs --with-xml=expat --with-x" | ||
43 | |||
44 | do_stage () { | ||
45 | oe_libinstall -so -C dbus libdbus-1 ${STAGING_LIBDIR} | ||
46 | |||
47 | autotools_stage_includes | ||
48 | |||
49 | mkdir -p ${STAGING_LIBDIR}/dbus-1.0/include/dbus/ | ||
50 | install -m 0644 dbus/dbus-arch-deps.h ${STAGING_LIBDIR}/dbus-1.0/include/dbus/ | ||
51 | } | ||
52 | |||
53 | do_install_append () { | ||
54 | install -d ${D}${sysconfdir}/init.d | ||
55 | install -m 0755 ${WORKDIR}/dbus-1.init ${D}${sysconfdir}/init.d/dbus-1 | ||
56 | } | ||
57 | |||
58 | python populate_packages_prepend () { | ||
59 | if (bb.data.getVar('DEBIAN_NAMES', d, 1)): | ||
60 | bb.data.setVar('PKG_dbus', 'dbus-1', d) | ||
61 | } | ||