summaryrefslogtreecommitdiffstats
path: root/meta/packages/dbus/dbus_1.0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/dbus/dbus_1.0.1.bb')
-rw-r--r--meta/packages/dbus/dbus_1.0.1.bb67
1 files changed, 67 insertions, 0 deletions
diff --git a/meta/packages/dbus/dbus_1.0.1.bb b/meta/packages/dbus/dbus_1.0.1.bb
new file mode 100644
index 0000000000..4b25589435
--- /dev/null
+++ b/meta/packages/dbus/dbus_1.0.1.bb
@@ -0,0 +1,67 @@
1DEFAULT_PREFERENCE = "-1"
2
3SECTION = "base"
4HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
5DESCRIPTION = "message bus system for applications to talk to one another"
6LICENSE = "GPL"
7DEPENDS = "expat glib-2.0 virtual/libintl"
8
9PR = "r1"
10
11DEFAULT_PREFERENCE = "-1"
12
13SRC_URI = "http://dbus.freedesktop.org/releases/dbus/dbus-${PV}.tar.gz \
14 file://tmpdir.patch;patch=1 \
15 file://dbus-1.init \
16 file://fix-segfault.patch;patch=1 \
17 file://cross.patch;patch=1 \
18 file://fix-install-daemon.patch;patch=1"
19
20inherit autotools pkgconfig update-rc.d gettext
21
22INITSCRIPT_NAME = "dbus-1"
23INITSCRIPT_PARAMS = "defaults"
24
25CONFFILES_${PN} = "${sysconfdir}/dbus-1/system.conf ${sysconfdir}/dbus-1/session.conf"
26
27FILES_${PN} = "${bindir}/dbus-daemon ${bindir}/dbus-launch ${bindir}/dbus-cleanup-sockets ${bindir}/dbus-send ${bindir}/dbus-monitor ${bindir}/dbus-uuidgen ${sysconfdir} ${datadir}/dbus-1/services ${libdir}/lib*.so.*"
28FILES_${PN}-dev += "${libdir}/dbus-1.0/include"
29
30pkg_postinst_dbus() {
31#!/bin/sh
32
33# can't do adduser stuff offline
34if [ "x$D" != "x" ]; then
35 exit 1
36fi
37
38MESSAGEUSER=messagebus
39MESSAGEHOME=/var/run/dbus
40
41mkdir -p $MESSAGEHOME || true
42chgrp "$MESSAGEUSER" "$MESSAGEHOME" 2>/dev/null || addgroup "$MESSAGEUSER"
43chown "$MESSAGEUSER"."$MESSAGEUSER" "$MESSAGEHOME" 2>/dev/null || adduser --system --home "$MESSAGEHOME" --no-create-home --disabled-password --ingroup "$MESSAGEUSER" "$MESSAGEUSER"
44}
45
46EXTRA_OECONF = "--disable-qt --disable-qt3 --disable-gtk --disable-tests \
47 --disable-checks --disable-xml-docs --disable-doxygen-docs \
48 --with-xml=expat --without-x"
49
50do_stage () {
51 oe_libinstall -so -C dbus libdbus-1 ${STAGING_LIBDIR}
52
53 autotools_stage_includes
54
55 mkdir -p ${STAGING_LIBDIR}/dbus-1.0/include/dbus/
56 install -m 0644 dbus/dbus-arch-deps.h ${STAGING_LIBDIR}/dbus-1.0/include/dbus/
57}
58
59do_install_append () {
60 install -d ${D}${sysconfdir}/init.d
61 install -m 0755 ${WORKDIR}/dbus-1.init ${D}${sysconfdir}/init.d/dbus-1
62}
63
64python populate_packages_prepend () {
65 if (bb.data.getVar('DEBIAN_NAMES', d, 1)):
66 bb.data.setVar('PKG_dbus', 'dbus-1', d)
67}