summaryrefslogtreecommitdiffstats
path: root/meta/packages/dbus/dbus-native_1.1.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/dbus/dbus-native_1.1.4.bb')
-rw-r--r--meta/packages/dbus/dbus-native_1.1.4.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/packages/dbus/dbus-native_1.1.4.bb b/meta/packages/dbus/dbus-native_1.1.4.bb
new file mode 100644
index 0000000000..55889a1a8b
--- /dev/null
+++ b/meta/packages/dbus/dbus-native_1.1.4.bb
@@ -0,0 +1,31 @@
1DESCRIPTION = "message bus system for applications to talk to one another"
2HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
3LICENSE = "GPL"
4SECTION = "base"
5
6PR = "r0"
7
8DEPENDS = "glib-2.0-native libxml2-native expat-native"
9
10DEFAULT_PREFERENCE = "-1"
11
12FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/dbus-${PV}"
13SRC_URI = "http://dbus.freedesktop.org/releases/dbus/dbus-${PV}.tar.gz \
14 file://cross.patch;patch=1 \
15 "
16
17inherit autotools pkgconfig gettext native
18
19S = "${WORKDIR}/dbus-${PV}"
20
21EXTRA_OECONF = " --disable-tests --disable-checks --disable-xml-docs \
22 --disable-doxygen-docs --with-xml=expat --without-x"
23
24do_stage () {
25 oe_runmake install
26 autotools_stage_all
27
28 # for dbus-glib-native introspection generation
29 install -d ${STAGING_DATADIR}/dbus
30 install -m 0644 bus/session.conf ${STAGING_DATADIR}/dbus/session.conf
31}