summaryrefslogtreecommitdiffstats
path: root/meta/packages/cairo/cairo-1.6.4/configure_fix.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/cairo/cairo-1.6.4/configure_fix.patch')
-rw-r--r--meta/packages/cairo/cairo-1.6.4/configure_fix.patch70
1 files changed, 0 insertions, 70 deletions
diff --git a/meta/packages/cairo/cairo-1.6.4/configure_fix.patch b/meta/packages/cairo/cairo-1.6.4/configure_fix.patch
deleted file mode 100644
index 44b59867f1..0000000000
--- a/meta/packages/cairo/cairo-1.6.4/configure_fix.patch
+++ /dev/null
@@ -1,70 +0,0 @@
1Libtool 2.2.2 can't cope unless the LT_ variables are marked as AC_SUBST
2as otherwise autofoo tries to expand them, fails and gets upset.
3
4You can't conditionally add AC_PROG_CXX to a configure.ac file since the
5mere mention of it triggers some internals which then get upset it if
6wasn't really called at configure time.
7
8Referring to a .cpp file in Makefiles without calling AC_PROG_CXX is
9now also a fatal error. Easiest fix is to drop the CXX stuff entirely.
10
11RP - 14/4/08
12
13---
14 boilerplate/Makefile.am | 1 -
15 configure.in | 6 +++---
16 2 files changed, 3 insertions(+), 4 deletions(-)
17
18--- cairo-1.6.4.orig/boilerplate/Makefile.am
19+++ cairo-1.6.4/boilerplate/Makefile.am
20@@ -11,11 +11,10 @@ libcairoboilerplate_la_SOURCES = \
21 xmalloc.c \
22 xmalloc.h
23 libcairoboilerplate_la_LIBADD = $(top_builddir)/src/libcairo.la $(CAIRO_LDADD)
24
25 if CAIRO_HAS_BEOS_SURFACE
26-libcairoboilerplate_la_SOURCES += cairo-boilerplate-beos.cpp
27 libcairoboilerplate_la_SOURCES += cairo-boilerplate-beos-private.h
28 # BeOS system headers trigger this warning
29 libcairoboilerplate_la_CXXFLAGS = -Wno-multichar
30 endif
31
32--- cairo-1.6.4.orig/configure.in
33+++ cairo-1.6.4/configure.in
34@@ -25,19 +25,22 @@ dnl ====================================
35
36 # libtool shared library version
37
38 # Increment if the interface has additions, changes, removals.
39 LT_CURRENT=19
40+AC_SUBST(LT_CURRENT)
41
42 # Increment any time the source changes; set to
43 # 0 if you increment CURRENT
44 LT_REVISION=5
45+AC_SUBST(LT_REVISION)
46
47 # Increment if any interfaces have been added; set to 0
48 # if any interfaces have been removed. removal has
49 # precedence over adding, so set to 0 if both happened.
50 LT_AGE=17
51+AC_SUBST(LT_AGE)
52
53 dnl ===========================================================================
54
55 VERSION_INFO="$LT_CURRENT:$LT_REVISION:$LT_AGE"
56 AC_SUBST(VERSION_INFO)
57@@ -442,13 +445,10 @@ CAIRO_BACKEND_ENABLE(beos, BeOS/Zeta, be
58 use_beos="no (requires a BeOS platform)"
59 ;;
60 esac
61 ])
62
63-if test "x$use_beos" = "xyes"; then
64- AC_PROG_CXX
65-fi
66
67 dnl ===========================================================================
68
69 CAIRO_BACKEND_ENABLE(png, PNG, png, PNG_FUNCTIONS, yes, [
70 use_png=no