diff options
Diffstat (limited to 'meta/packages/bluez')
-rw-r--r-- | meta/packages/bluez/bluez-utils.inc | 56 | ||||
-rw-r--r-- | meta/packages/bluez/bluez-utils_3.17.bb | 107 |
2 files changed, 129 insertions, 34 deletions
diff --git a/meta/packages/bluez/bluez-utils.inc b/meta/packages/bluez/bluez-utils.inc index ff3916ea94..3f90768708 100644 --- a/meta/packages/bluez/bluez-utils.inc +++ b/meta/packages/bluez/bluez-utils.inc | |||
@@ -1,60 +1,48 @@ | |||
1 | DESCRIPTION = "Linux Bluetooth Stack Userland Utilities." | 1 | DESCRIPTION = "Linux Bluetooth Stack Userland Utilities." |
2 | SECTION = "console" | 2 | SECTION = "console" |
3 | PRIORITY = "optional" | 3 | PRIORITY = "optional" |
4 | DEPENDS = "bluez-libs-${PV} pcmcia-cs" | 4 | DEPENDS = "gstreamer gst-plugins-base bluez-libs-${PV} libusb dbus" |
5 | RPROVIDES_${PN} = "bluez-pan bluez-sdp bluez-utils" | 5 | PROVIDES = "bluez-utils-dbus" |
6 | RPROVIDES_${PN} = "bluez-pan bluez-sdp bluez-utils-dbus" | ||
7 | RREPLACES_${PN} = "bluez-utils-dbus" | ||
8 | RCONFLICTS_${PN} = "bluez-utils-nodbus" | ||
6 | LICENSE = "GPL" | 9 | LICENSE = "GPL" |
7 | 10 | ||
8 | SRC_URI = "http://bluez.sourceforge.net/download/bluez-utils-${PV}.tar.gz \ | 11 | SRC_URI = "http://bluez.sourceforge.net/download/bluez-utils-${PV}.tar.gz \ |
9 | file://base.patch;patch=1 \ | 12 | file://hcid.conf " |
10 | file://blueboxes.patch;patch=1 \ | ||
11 | file://no-user-include.patch;patch=1 \ | ||
12 | file://hcid.conf \ | ||
13 | file://bluetooth.default \ | ||
14 | file://bluetooth.conf \ | ||
15 | file://02dtl1_cs.sh" | ||
16 | 13 | ||
17 | # Almost all serial CF cards w/ manfid 0x0000,0x0000 seem to use the bcs protocol | 14 | # Almost all serial CF cards w/ manfid 0x0000,0x0000 seem to use the bcs protocol |
18 | # Let's default to that instead of 'any' until further notice... | 15 | # Let's default to that instead of 'any' until further notice... |
19 | SRC_URI += " file://default-manfid-0x0-to-bcps.patch;patch=1" | 16 | #SRC_URI += " file://default-manfid-0x0-to-bcps.patch;patch=1" |
20 | 17 | ||
21 | S = "${WORKDIR}/bluez-utils-${PV}" | 18 | S = "${WORKDIR}/bluez-utils-${PV}" |
22 | 19 | ||
23 | # We don't depend on openobex, fuse, alsa or usb but we set paths into staging | ||
24 | # otherwise /usr/lib and /usr/include make it onto command lines with unpredictable results | ||
25 | # Ideally acinclude.m4 needs fixing | ||
26 | EXTRA_OECONF = "--with-bluez-libs=${STAGING_LIBDIR} --with-bluez-includes=${STAGING_INCDIR} \ | ||
27 | --enable-pcmcia --enable-initscripts --enable-bcm203x --enable-hid2hci \ | ||
28 | --disable-obex --disable-alsa \ | ||
29 | --with-openobex=${STAGING_DIR}/${HOST_SYS} --with-fuse=${STAGING_DIR}/${HOST_SYS} \ | ||
30 | --with-alsa=${STAGING_DIR}/${HOST_SYS} --with-usb=${STAGING_DIR}/${HOST_SYS} \ | ||
31 | --with-bluez=${STAGING_LIBDIR}/${HOST_SYS}" | ||
32 | |||
33 | inherit autotools update-rc.d | 20 | inherit autotools update-rc.d |
34 | 21 | ||
35 | INITSCRIPT_NAME = "bluetooth" | 22 | INITSCRIPT_NAME = "bluetooth" |
36 | INITSCRIPT_PARAMS = "defaults 23 19" | 23 | INITSCRIPT_PARAMS = "defaults 23 19" |
37 | 24 | ||
38 | do_compile_prepend() { | ||
39 | find ${S} -name Makefile | xargs sed -i 's:/usr/include:${STAGING_INCDIR}:' | ||
40 | } | ||
41 | |||
42 | do_install_append() { | 25 | do_install_append() { |
43 | install -d ${D}${base_sbindir} ${D}${base_bindir}/ ${D}${sysconfdir}/apm/event.d/ | 26 | install -d ${D}${base_sbindir} ${D}${base_bindir}/ ${D}${sysconfdir}/apm/event.d/ |
44 | mv ${D}${sbindir}/* ${D}${base_sbindir}/ | 27 | mv ${D}${sbindir}/* ${D}${base_sbindir}/ |
45 | mv ${D}${bindir}/* ${D}${base_bindir}/ | 28 | mv ${D}${bindir}/* ${D}${base_bindir}/ |
46 | rmdir ${D}${bindir} ${D}${sbindir} | 29 | rmdir ${D}${bindir} ${D}${sbindir} |
47 | chmod u+s ${D}${base_sbindir}/hciattach ${D}${base_sbindir}/hciconfig | 30 | chmod u+s ${D}${base_sbindir}/hciattach ${D}${base_sbindir}/hciconfig |
48 | chmod 755 ${D}${sysconfdir}/pcmcia/bluetooth | ||
49 | install -m 0644 ${WORKDIR}/hcid.conf ${D}${sysconfdir}/bluetooth/ | 31 | install -m 0644 ${WORKDIR}/hcid.conf ${D}${sysconfdir}/bluetooth/ |
50 | install -m 0644 ${WORKDIR}/bluetooth.default ${D}${sysconfdir}/default/bluetooth | 32 | install -m 0755 ${S}/daemon/.libs/passkey-agent ${D}${base_bindir}/ |
51 | cat ${WORKDIR}/bluetooth.conf >> ${D}${sysconfdir}/pcmcia/bluetooth.conf | ||
52 | install -m 0755 ${WORKDIR}/02dtl1_cs.sh ${D}${sysconfdir}/apm/event.d/ | ||
53 | } | 33 | } |
54 | 34 | ||
55 | CONFFILES_${PN} = "${sysconfdir}/bluetooth/hcid.conf ${sysconfdir}/bluetooth/rfcomm.conf \ | 35 | PACKAGES =+ "${PN}-alsa ${PN}-alsa-dev gst-plugin-bluez gst-plugin-bluez-dbg" |
56 | ${sysconfdir}/bluetooth/pin ${sysconfdir}/default/bluetooth" | 36 | |
37 | FILES_${PN}-alsa = "${libdir}/alsa-lib/libasound*" | ||
38 | FILES_${PN}-alsa-dev += " ${libdir}/alsa-lib/*.la " | ||
39 | |||
40 | FILES_gst-plugin-bluez = "${libdir}/gstreamer*/libgstblue*.so" | ||
41 | FILES_gst-plugin-bluez-dbg = "${libdir}/gstreamer*/.debug/libgstblue*.so" | ||
57 | 42 | ||
58 | PACKAGES =+ "${PN}-ciptool ${PN}-bluepin" | 43 | # |
59 | FILES_${PN}-ciptool = "/bin/ciptool" | 44 | # CUPS support |
60 | FILES_${PN}-bluepin = "/bin/bluepin" | 45 | # |
46 | #PACKAGES =+ " bluez-cups-backend" | ||
47 | #FILES_bluez-cups-backend = "${libdir}/cups/backend/bluetooth" | ||
48 | #RDEPENDS_bluez-cups-backend = "cups" | ||
diff --git a/meta/packages/bluez/bluez-utils_3.17.bb b/meta/packages/bluez/bluez-utils_3.17.bb new file mode 100644 index 0000000000..8fa75c34a7 --- /dev/null +++ b/meta/packages/bluez/bluez-utils_3.17.bb | |||
@@ -0,0 +1,107 @@ | |||
1 | require bluez-utils.inc | ||
2 | |||
3 | DEPENDS += "glib-2.0" | ||
4 | PR = "r1" | ||
5 | |||
6 | # ti patch doesn't apply, people using it should rediff it and send it upstream | ||
7 | #SRC_URI += "file://hciattach-ti-bts.patch;patch=1 " | ||
8 | |||
9 | EXTRA_OECONF = " \ | ||
10 | --enable-bccmd \ | ||
11 | --enable-hid2hci \ | ||
12 | --enable-alsa \ | ||
13 | --disable-cups \ | ||
14 | --enable-glib \ | ||
15 | --disable-sdpd \ | ||
16 | --enable-network \ | ||
17 | --enable-serial \ | ||
18 | --enable-input \ | ||
19 | --enable-audio \ | ||
20 | --enable-echo \ | ||
21 | --enable-configfile \ | ||
22 | --enable-initscripts \ | ||
23 | --enable-test \ | ||
24 | " | ||
25 | |||
26 | # The config options are explained below: | ||
27 | |||
28 | # --enable-obex enable OBEX support | ||
29 | # --enable-alsa enable ALSA support, not needed for nokia770, nokia800 and fic-gtao1 | ||
30 | # --enable-cups install CUPS backend support | ||
31 | # --enable-bccmd install BCCMD interface utility | ||
32 | # --enable-avctrl install Audio/Video control utility | ||
33 | # --enable-hid2hci install HID mode switching utility | ||
34 | # --enable-dfutool install DFU firmware upgrade utility | ||
35 | |||
36 | # --enable-glib For systems that use and install GLib anyway | ||
37 | # --disable-sdpd The sdpd is obsolete and should no longer be used. This of course requires that hcid will be started with -s to enable the SDP server | ||
38 | |||
39 | #Following services can be enabled so far: | ||
40 | # --enable-network | ||
41 | # --enable-serial | ||
42 | # --enable-input | ||
43 | # --enable-audio | ||
44 | # --enable-echo | ||
45 | |||
46 | #There is no need to modify any init script. They will be started | ||
47 | #automatically or on demand. Only /etc/bluetooth/*.service files should | ||
48 | #be patched to change name or the autostart value. | ||
49 | # --enable-configfile | ||
50 | # --enable-initscripts | ||
51 | |||
52 | #For even smaller -doc packages | ||
53 | # --disable-manpages | ||
54 | # --disable-pcmciarules | ||
55 | |||
56 | #I haven't seen any embedded device with HID proxy support. So simply | ||
57 | #disable it: | ||
58 | # --disable-hid2hci | ||
59 | |||
60 | |||
61 | PACKAGES =+ "${PN}-compat" | ||
62 | |||
63 | CONFFILES_${PN} = " \ | ||
64 | ${sysconfdir}/bluetooth/hcid.conf \ | ||
65 | ${sysconfdir}/default/bluetooth \ | ||
66 | " | ||
67 | |||
68 | CONFFILES_${PN}-compat = " \ | ||
69 | ${sysconfdir}/bluetooth/rfcomm.conf \ | ||
70 | " | ||
71 | |||
72 | FILES_${PN} = " \ | ||
73 | ${base_sbindir}/hcid \ | ||
74 | ${libdir}/bluetooth \ | ||
75 | ${sysconfdir}/init.d/bluetooth \ | ||
76 | ${sysconfdir}/bluetooth/*.service \ | ||
77 | ${sysconfdir}/bluetooth/hcid.conf \ | ||
78 | ${sysconfdir}/default \ | ||
79 | ${sysconfdir}/dbus-1 \ | ||
80 | ${base_sbindir}/hciattach \ | ||
81 | " | ||
82 | |||
83 | FILES_${PN}-dbg += " \ | ||
84 | ${libdir}/bluetooth/.debug \ | ||
85 | ${libdir}/cups/backend/.debug \ | ||
86 | ${libdir}/alsa-lib/.debug \ | ||
87 | " | ||
88 | |||
89 | FILES_${PN}-compat = " \ | ||
90 | ${base_bindir}/sdptool \ | ||
91 | ${base_bindir}/dund \ | ||
92 | ${base_bindir}/rctest \ | ||
93 | ${base_bindir}/ciptool \ | ||
94 | ${base_bindir}/l2test \ | ||
95 | ${base_bindir}/rfcomm \ | ||
96 | ${base_bindir}/hcitool \ | ||
97 | ${base_bindir}/pand \ | ||
98 | ${base_bindir}/hidd \ | ||
99 | ${base_bindir}/l2ping \ | ||
100 | ${base_sbindir}/hciconfig \ | ||
101 | ${base_sbindir}/bccmd \ | ||
102 | ${base_sbindir}/hciemu \ | ||
103 | ${base_sbindir}/hid2hci \ | ||
104 | ${base_bindir}/passkey-agent \ | ||
105 | ${sysconfdir}/bluetooth/rfcomm.conf \ | ||
106 | " | ||
107 | |||