summaryrefslogtreecommitdiffstats
path: root/meta/packages/bluez/bluez4_4.66.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/bluez/bluez4_4.66.bb')
-rw-r--r--meta/packages/bluez/bluez4_4.66.bb68
1 files changed, 68 insertions, 0 deletions
diff --git a/meta/packages/bluez/bluez4_4.66.bb b/meta/packages/bluez/bluez4_4.66.bb
new file mode 100644
index 0000000000..59193c2f99
--- /dev/null
+++ b/meta/packages/bluez/bluez4_4.66.bb
@@ -0,0 +1,68 @@
1DESCRIPTION = "Linux Bluetooth Stack Userland V4"
2SECTION = "libs"
3PRIORITY = "optional"
4DEPENDS = "gst-plugins-base alsa-lib libusb-compat dbus-glib"
5HOMEPAGE = "http://www.bluez.org"
6LICENSE = "GPL"
7
8# For angstrom we want this to replace at least bluez-libs
9PROVIDES_append_angstrom = " bluez-utils bluez-libs"
10
11ASNEEDED = ""
12
13PR = "r0"
14
15SRC_URI = "\
16 http://www.kernel.org/pub/linux/bluetooth/bluez-${PV}.tar.gz \
17 file://fix-dfutool-usb-declaration-mismatch.patch;patch=1 \
18 file://sbc-thumb.patch;patch=1 \
19 file://bluetooth.conf \
20"
21S = "${WORKDIR}/bluez-${PV}"
22
23inherit autotools
24AUTOTOOLS_STAGE_PKGCONFIG = "1"
25
26EXTRA_OECONF = "\
27 --enable-gstreamer \
28 --enable-alsa \
29 --enable-usb \
30 --enable-netlink \
31 --enable-tools \
32 --enable-bccmd \
33 --enable-hid2hci \
34 --enable-dfutool \
35 --enable-hidd \
36 --enable-pandd \
37 --enable-dund \
38 --disable-cups \
39 --enable-test \
40 --enable-manpages \
41 --enable-configfiles \
42 --enable-initscripts \
43 --disable-pcmciarules \
44"
45
46do_install_append() {
47 install -m 0644 ${S}/audio/audio.conf ${D}/${sysconfdir}/bluetooth/
48 install -m 0644 ${S}/network/network.conf ${D}/${sysconfdir}/bluetooth/
49 install -m 0644 ${S}/input/input.conf ${D}/${sysconfdir}/bluetooth/
50 # at_console doesn't really work with the current state of OE, so punch some more holes so people can actually use BT
51 install -m 0644 ${WORKDIR}/bluetooth.conf ${D}/${sysconfdir}/dbus-1/system.d/
52}
53
54PACKAGES =+ "gst-plugin-bluez libasound-module-bluez"
55
56FILES_gst-plugin-bluez = "${libdir}/gstreamer-0.10/lib*.so"
57FILES_libasound-module-bluez = "${libdir}/alsa-lib/lib*.so"
58FILES_${PN} += "${libdir}/bluetooth/plugins/*.so"
59FILES_${PN}-dev += "\
60 ${libdir}/bluetooth/plugins/*.la \
61 ${libdir}/alsa-lib/*.la \
62 ${libdir}/gstreamer-0.10/*.la \
63"
64
65FILES_${PN}-dbg += "\
66 ${libdir}/bluetooth/plugins/.debug \
67 ${libdir}/*/.debug \
68"