summaryrefslogtreecommitdiffstats
path: root/meta/packages/bluez/bluez-utils_3.36.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/bluez/bluez-utils_3.36.bb')
-rw-r--r--meta/packages/bluez/bluez-utils_3.36.bb64
1 files changed, 64 insertions, 0 deletions
diff --git a/meta/packages/bluez/bluez-utils_3.36.bb b/meta/packages/bluez/bluez-utils_3.36.bb
new file mode 100644
index 0000000000..cf6d6328ea
--- /dev/null
+++ b/meta/packages/bluez/bluez-utils_3.36.bb
@@ -0,0 +1,64 @@
1require bluez-utils3.inc
2
3PR = "r1"
4
5SRC_URI = "http://bluez.sourceforge.net/download/bluez-utils-${PV}.tar.gz \
6 file://hcid.conf \
7 "
8
9# see bluez-utils3.inc for the explanation of these option
10EXTRA_OECONF = " \
11 --enable-bccmd \
12 --enable-hid2hci \
13 --enable-hidd \
14 --enable-pand \
15 --enable-dund \
16 --disable-alsa \
17 --disable-cups \
18 --enable-glib \
19 --disable-sdpd \
20 --enable-network \
21 --enable-serial \
22 --enable-input \
23 --enable-audio \
24 --enable-echo \
25 --enable-configfile \
26 --enable-initscripts \
27 --enable-test \
28 "
29
30CONFFILES_${PN} = " \
31 ${sysconfdir}/bluetooth/hcid.conf \
32 ${sysconfdir}/default/bluetooth \
33 "
34
35CONFFILES_${PN}-compat = " \
36 ${sysconfdir}/bluetooth/rfcomm.conf \
37 "
38
39PACKAGES =+ "bluez-audio"
40
41FILES_${PN} = " \
42 ${base_sbindir}/hcid \
43 ${libdir}/bluetooth/plugins/*.so \
44 ${sysconfdir}/init.d/bluetooth \
45 ${sysconfdir}/bluetooth/hcid.conf \
46 ${sysconfdir}/default \
47 ${sysconfdir}/dbus-1 \
48 ${base_sbindir}/hciattach \
49 "
50
51FILES_bluez-audio = " \
52 ${libdir}/bluetooth/plugins/libaudio.so \
53 ${libdir}/gstreamer-0.10/*.so \
54 "
55
56FILES_${PN}-dbg += " \
57 ${libdir}/bluetooth/plugins/.debug \
58 ${libdir}/gstreamer-0.10/.debug \
59 "
60
61FILES_${PN}-dev += " \
62 ${libdir}/bluetooth/plugins/*.la \
63 ${libdir}/gstreamer-0.10/*.la \
64 "