diff options
Diffstat (limited to 'meta/packages/binutils/binutils-2.16.91.0.7')
7 files changed, 429 insertions, 0 deletions
diff --git a/meta/packages/binutils/binutils-2.16.91.0.7/binutils-2.16.91.0.6-objcopy-rename-errorcode.patch b/meta/packages/binutils/binutils-2.16.91.0.7/binutils-2.16.91.0.6-objcopy-rename-errorcode.patch new file mode 100644 index 0000000000..4461bedd4e --- /dev/null +++ b/meta/packages/binutils/binutils-2.16.91.0.7/binutils-2.16.91.0.6-objcopy-rename-errorcode.patch | |||
@@ -0,0 +1,31 @@ | |||
1 | # strip (and objcopy) fail to set the error code if there is no | ||
2 | # output file name and the rename of the stripped (or copied) file | ||
3 | # fails, yet the command fails to do anything. This fixes both | ||
4 | # objcopy and strip. | ||
5 | # | ||
6 | # modification by bero: Ported to 2.16.91.0.6 | ||
7 | # | ||
8 | #Signed-off-by: John Bowler <jbowler@acm.org> | ||
9 | #Signed-off-by: Bernhard Rosenkraenzer <bero@arklinux.org> | ||
10 | --- binutils-2.16.91.0.6/binutils/objcopy.c.ark 2006-03-11 15:59:07.000000000 +0100 | ||
11 | +++ binutils-2.16.91.0.6/binutils/objcopy.c 2006-03-11 15:59:45.000000000 +0100 | ||
12 | @@ -2593,7 +2593,8 @@ | ||
13 | if (preserve_dates) | ||
14 | set_times (tmpname, &statbuf); | ||
15 | if (output_file == NULL) | ||
16 | - smart_rename (tmpname, argv[i], preserve_dates); | ||
17 | + if(smart_rename (tmpname, argv[i], preserve_dates)) | ||
18 | + hold_status = 1; | ||
19 | status = hold_status; | ||
20 | } | ||
21 | else | ||
22 | @@ -3184,7 +3185,8 @@ | ||
23 | { | ||
24 | if (preserve_dates) | ||
25 | set_times (tmpname, &statbuf); | ||
26 | - smart_rename (tmpname, input_filename, preserve_dates); | ||
27 | + if (smart_rename (tmpname, input_filename, preserve_dates)) | ||
28 | + status = 1; | ||
29 | } | ||
30 | else | ||
31 | unlink (tmpname); | ||
diff --git a/meta/packages/binutils/binutils-2.16.91.0.7/binutils-uclibc-100-uclibc-conf.patch b/meta/packages/binutils/binutils-2.16.91.0.7/binutils-uclibc-100-uclibc-conf.patch new file mode 100644 index 0000000000..25222e5df2 --- /dev/null +++ b/meta/packages/binutils/binutils-2.16.91.0.7/binutils-uclibc-100-uclibc-conf.patch | |||
@@ -0,0 +1,139 @@ | |||
1 | --- binutils-2.16.91.0.7/bfd/configure | ||
2 | +++ binutils-2.16.91.0.7/bfd/configure | ||
3 | @@ -3576,7 +3576,7 @@ | ||
4 | ;; | ||
5 | |||
6 | # This must be Linux ELF. | ||
7 | -linux-gnu*) | ||
8 | +linux-gnu*|linux-uclibc*) | ||
9 | lt_cv_deplibs_check_method=pass_all | ||
10 | ;; | ||
11 | |||
12 | --- binutils-2.16.91.0.7/binutils/configure | ||
13 | +++ binutils-2.16.91.0.7/binutils/configure | ||
14 | @@ -3411,7 +3411,7 @@ | ||
15 | ;; | ||
16 | |||
17 | # This must be Linux ELF. | ||
18 | -linux-gnu*) | ||
19 | +linux-gnu*|linux-uclibc*) | ||
20 | lt_cv_deplibs_check_method=pass_all | ||
21 | ;; | ||
22 | |||
23 | --- binutils-2.16.91.0.7/configure | ||
24 | +++ binutils-2.16.91.0.7/configure | ||
25 | @@ -1270,7 +1270,7 @@ | ||
26 | am33_2.0-*-linux*) | ||
27 | noconfigdirs="$noconfigdirs ${libgcj} target-newlib target-libgloss" | ||
28 | ;; | ||
29 | - sh-*-linux*) | ||
30 | + sh*-*-linux*) | ||
31 | noconfigdirs="$noconfigdirs ${libgcj} target-newlib target-libgloss" | ||
32 | ;; | ||
33 | sh*-*-pe|mips*-*-pe|*arm-wince-pe) | ||
34 | @@ -1578,7 +1578,7 @@ | ||
35 | romp-*-*) | ||
36 | noconfigdirs="$noconfigdirs bfd binutils ld gas opcodes target-libgloss ${libgcj}" | ||
37 | ;; | ||
38 | - sh-*-* | sh64-*-*) | ||
39 | + sh*-*-* | sh64-*-*) | ||
40 | case "${host}" in | ||
41 | i[3456789]86-*-vsta) ;; # don't add gprof back in | ||
42 | i[3456789]86-*-go32*) ;; # don't add gprof back in | ||
43 | --- binutils-2.16.91.0.7/configure.in | ||
44 | +++ binutils-2.16.91.0.7/configure.in | ||
45 | @@ -468,7 +468,7 @@ | ||
46 | am33_2.0-*-linux*) | ||
47 | noconfigdirs="$noconfigdirs ${libgcj} target-newlib target-libgloss" | ||
48 | ;; | ||
49 | - sh-*-linux*) | ||
50 | + sh*-*-linux*) | ||
51 | noconfigdirs="$noconfigdirs ${libgcj} target-newlib target-libgloss" | ||
52 | ;; | ||
53 | sh*-*-pe|mips*-*-pe|*arm-wince-pe) | ||
54 | @@ -776,7 +776,7 @@ | ||
55 | romp-*-*) | ||
56 | noconfigdirs="$noconfigdirs bfd binutils ld gas opcodes target-libgloss ${libgcj}" | ||
57 | ;; | ||
58 | - sh-*-* | sh64-*-*) | ||
59 | + sh*-*-* | sh64-*-*) | ||
60 | case "${host}" in | ||
61 | i[[3456789]]86-*-vsta) ;; # don't add gprof back in | ||
62 | i[[3456789]]86-*-go32*) ;; # don't add gprof back in | ||
63 | --- binutils-2.16.91.0.7/gas/configure | ||
64 | +++ binutils-2.16.91.0.7/gas/configure | ||
65 | @@ -3411,7 +3411,7 @@ | ||
66 | ;; | ||
67 | |||
68 | # This must be Linux ELF. | ||
69 | -linux-gnu*) | ||
70 | +linux-gnu*|linux-uclibc*) | ||
71 | lt_cv_deplibs_check_method=pass_all | ||
72 | ;; | ||
73 | |||
74 | --- binutils-2.16.91.0.7/gprof/configure | ||
75 | +++ binutils-2.16.91.0.7/gprof/configure | ||
76 | @@ -3419,6 +3419,11 @@ | ||
77 | lt_cv_file_magic_test_file=`echo /lib/libc.so* /lib/libc-*.so` | ||
78 | ;; | ||
79 | |||
80 | +linux-uclibc*) | ||
81 | + lt_cv_deplibs_check_method=pass_all | ||
82 | + lt_cv_file_magic_test_file=`echo /lib/libuClibc-*.so` | ||
83 | + ;; | ||
84 | + | ||
85 | netbsd* | knetbsd*-gnu) | ||
86 | if echo __ELF__ | $CC -E - | grep __ELF__ > /dev/null; then | ||
87 | lt_cv_deplibs_check_method='match_pattern /lib[^/\.]+\.so\.[0-9]+\.[0-9]+$' | ||
88 | --- binutils-2.16.91.0.7/ld/configure | ||
89 | +++ binutils-2.16.91.0.7/ld/configure | ||
90 | @@ -3413,7 +3413,7 @@ | ||
91 | ;; | ||
92 | |||
93 | # This must be Linux ELF. | ||
94 | -linux-gnu*) | ||
95 | +linux-gnu*|linux-uclibc*) | ||
96 | lt_cv_deplibs_check_method=pass_all | ||
97 | ;; | ||
98 | |||
99 | --- binutils-2.16.91.0.7/libtool.m4 | ||
100 | +++ binutils-2.16.91.0.7/libtool.m4 | ||
101 | @@ -739,7 +739,7 @@ | ||
102 | ;; | ||
103 | |||
104 | # This must be Linux ELF. | ||
105 | -linux-gnu*) | ||
106 | +linux-gnu*|linux-uclibc*) | ||
107 | lt_cv_deplibs_check_method=pass_all | ||
108 | ;; | ||
109 | |||
110 | --- binutils-2.16.91.0.7/ltconfig | ||
111 | +++ binutils-2.16.91.0.7/ltconfig | ||
112 | @@ -602,6 +602,7 @@ | ||
113 | |||
114 | # Transform linux* to *-*-linux-gnu*, to support old configure scripts. | ||
115 | case $host_os in | ||
116 | +linux-uclibc*) ;; | ||
117 | linux-gnu*) ;; | ||
118 | linux*) host=`echo $host | sed 's/^\(.*-.*-linux\)\(.*\)$/\1-gnu\2/'` | ||
119 | esac | ||
120 | @@ -1247,7 +1248,7 @@ | ||
121 | ;; | ||
122 | |||
123 | # This must be Linux ELF. | ||
124 | -linux-gnu*) | ||
125 | +linux-gnu*|linux-uclibc*) | ||
126 | version_type=linux | ||
127 | need_lib_prefix=no | ||
128 | need_version=no | ||
129 | --- binutils-2.16.91.0.7/opcodes/configure | ||
130 | +++ binutils-2.16.91.0.7/opcodes/configure | ||
131 | @@ -3579,7 +3579,7 @@ | ||
132 | ;; | ||
133 | |||
134 | # This must be Linux ELF. | ||
135 | -linux-gnu*) | ||
136 | +linux-gnu*|linux-uclibc*) | ||
137 | lt_cv_deplibs_check_method=pass_all | ||
138 | ;; | ||
139 | |||
diff --git a/meta/packages/binutils/binutils-2.16.91.0.7/binutils-uclibc-300-001_ld_makefile_patch.patch b/meta/packages/binutils/binutils-2.16.91.0.7/binutils-uclibc-300-001_ld_makefile_patch.patch new file mode 100644 index 0000000000..04a7e61e25 --- /dev/null +++ b/meta/packages/binutils/binutils-2.16.91.0.7/binutils-uclibc-300-001_ld_makefile_patch.patch | |||
@@ -0,0 +1,50 @@ | |||
1 | #!/bin/sh -e | ||
2 | ## 001_ld_makefile_patch.dpatch | ||
3 | ## | ||
4 | ## All lines beginning with `## DP:' are a description of the patch. | ||
5 | ## DP: Description: correct where ld scripts are installed | ||
6 | ## DP: Author: Chris Chimelis <chris@debian.org> | ||
7 | ## DP: Upstream status: N/A | ||
8 | ## DP: Date: ?? | ||
9 | |||
10 | if [ $# -ne 1 ]; then | ||
11 | echo >&2 "`basename $0`: script expects -patch|-unpatch as argument" | ||
12 | exit 1 | ||
13 | fi | ||
14 | |||
15 | [ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts | ||
16 | patch_opts="${patch_opts:--f --no-backup-if-mismatch}" | ||
17 | |||
18 | case "$1" in | ||
19 | -patch) patch $patch_opts -p1 < $0;; | ||
20 | -unpatch) patch $patch_opts -p1 -R < $0;; | ||
21 | *) | ||
22 | echo >&2 "`basename $0`: script expects -patch|-unpatch as argument" | ||
23 | exit 1;; | ||
24 | esac | ||
25 | |||
26 | exit 0 | ||
27 | |||
28 | @DPATCH@ | ||
29 | --- binutils-2.16.91.0.1/ld/Makefile.am | ||
30 | +++ binutils-2.16.91.0.1/ld/Makefile.am | ||
31 | @@ -20,7 +20,7 @@ | ||
32 | # We put the scripts in the directory $(scriptdir)/ldscripts. | ||
33 | # We can't put the scripts in $(datadir) because the SEARCH_DIR | ||
34 | # directives need to be different for native and cross linkers. | ||
35 | -scriptdir = $(tooldir)/lib | ||
36 | +scriptdir = $(libdir) | ||
37 | |||
38 | EMUL = @EMUL@ | ||
39 | EMULATION_OFILES = @EMULATION_OFILES@ | ||
40 | --- binutils-2.16.91.0.1/ld/Makefile.in | ||
41 | +++ binutils-2.16.91.0.1/ld/Makefile.in | ||
42 | @@ -268,7 +268,7 @@ | ||
43 | # We put the scripts in the directory $(scriptdir)/ldscripts. | ||
44 | # We can't put the scripts in $(datadir) because the SEARCH_DIR | ||
45 | # directives need to be different for native and cross linkers. | ||
46 | -scriptdir = $(tooldir)/lib | ||
47 | +scriptdir = $(libdir) | ||
48 | BASEDIR = $(srcdir)/.. | ||
49 | BFDDIR = $(BASEDIR)/bfd | ||
50 | INCDIR = $(BASEDIR)/include | ||
diff --git a/meta/packages/binutils/binutils-2.16.91.0.7/binutils-uclibc-300-006_better_file_error.patch b/meta/packages/binutils/binutils-2.16.91.0.7/binutils-uclibc-300-006_better_file_error.patch new file mode 100644 index 0000000000..f337611edf --- /dev/null +++ b/meta/packages/binutils/binutils-2.16.91.0.7/binutils-uclibc-300-006_better_file_error.patch | |||
@@ -0,0 +1,43 @@ | |||
1 | #!/bin/sh -e | ||
2 | ## 006_better_file_error.dpatch by David Kimdon <dwhedon@gordian.com> | ||
3 | ## | ||
4 | ## All lines beginning with `## DP:' are a description of the patch. | ||
5 | ## DP: Specify which filename is causing an error if the filename is a | ||
6 | ## DP: directory. (#45832) | ||
7 | |||
8 | if [ $# -ne 1 ]; then | ||
9 | echo >&2 "`basename $0`: script expects -patch|-unpatch as argument" | ||
10 | exit 1 | ||
11 | fi | ||
12 | |||
13 | [ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts | ||
14 | patch_opts="${patch_opts:--f --no-backup-if-mismatch}" | ||
15 | |||
16 | case "$1" in | ||
17 | -patch) patch $patch_opts -p1 < $0;; | ||
18 | -unpatch) patch $patch_opts -p1 -R < $0;; | ||
19 | *) | ||
20 | echo >&2 "`basename $0`: script expects -patch|-unpatch as argument" | ||
21 | exit 1;; | ||
22 | esac | ||
23 | |||
24 | exit 0 | ||
25 | |||
26 | @DPATCH@ | ||
27 | diff -urNad /home/james/debian/packages/binutils/binutils-2.14.90.0.6/bfd/opncls.c binutils-2.14.90.0.6/bfd/opncls.c | ||
28 | --- /home/james/debian/packages/binutils/binutils-2.14.90.0.6/bfd/opncls.c 2003-07-23 16:08:09.000000000 +0100 | ||
29 | +++ binutils-2.14.90.0.6/bfd/opncls.c 2003-09-10 22:35:00.000000000 +0100 | ||
30 | @@ -150,6 +150,13 @@ | ||
31 | { | ||
32 | bfd *nbfd; | ||
33 | const bfd_target *target_vec; | ||
34 | + struct stat s; | ||
35 | + | ||
36 | + if (stat (filename, &s) == 0) | ||
37 | + if (S_ISDIR(s.st_mode)) { | ||
38 | + bfd_set_error (bfd_error_file_not_recognized); | ||
39 | + return NULL; | ||
40 | + } | ||
41 | |||
42 | nbfd = _bfd_new_bfd (); | ||
43 | if (nbfd == NULL) | ||
diff --git a/meta/packages/binutils/binutils-2.16.91.0.7/binutils-uclibc-300-012_check_ldrunpath_length.patch b/meta/packages/binutils/binutils-2.16.91.0.7/binutils-uclibc-300-012_check_ldrunpath_length.patch new file mode 100644 index 0000000000..498651a90c --- /dev/null +++ b/meta/packages/binutils/binutils-2.16.91.0.7/binutils-uclibc-300-012_check_ldrunpath_length.patch | |||
@@ -0,0 +1,47 @@ | |||
1 | #!/bin/sh -e | ||
2 | ## 012_check_ldrunpath_length.dpatch by Chris Chimelis <chris@debian.org> | ||
3 | ## | ||
4 | ## All lines beginning with `## DP:' are a description of the patch. | ||
5 | ## DP: Only generate an RPATH entry if LD_RUN_PATH is not empty, for | ||
6 | ## DP: cases where -rpath isn't specified. (#151024) | ||
7 | |||
8 | if [ $# -ne 1 ]; then | ||
9 | echo >&2 "`basename $0`: script expects -patch|-unpatch as argument" | ||
10 | exit 1 | ||
11 | fi | ||
12 | |||
13 | [ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts | ||
14 | patch_opts="${patch_opts:--f --no-backup-if-mismatch}" | ||
15 | |||
16 | case "$1" in | ||
17 | -patch) patch $patch_opts -p1 < $0;; | ||
18 | -unpatch) patch $patch_opts -p1 -R < $0;; | ||
19 | *) | ||
20 | echo >&2 "`basename $0`: script expects -patch|-unpatch as argument" | ||
21 | exit 1;; | ||
22 | esac | ||
23 | |||
24 | exit 0 | ||
25 | |||
26 | @DPATCH@ | ||
27 | diff -urNad /home/james/debian/packages/binutils/new/binutils-2.15/ld/emultempl/elf32.em binutils-2.15/ld/emultempl/elf32.em | ||
28 | --- /home/james/debian/packages/binutils/new/binutils-2.15/ld/emultempl/elf32.em 2004-05-21 23:12:58.000000000 +0100 | ||
29 | +++ binutils-2.15/ld/emultempl/elf32.em 2004-05-21 23:12:59.000000000 +0100 | ||
30 | @@ -692,6 +692,8 @@ | ||
31 | && command_line.rpath == NULL) | ||
32 | { | ||
33 | lib_path = (const char *) getenv ("LD_RUN_PATH"); | ||
34 | + if ((lib_path) && (strlen (lib_path) == 0)) | ||
35 | + lib_path = NULL; | ||
36 | if (gld${EMULATION_NAME}_search_needed (lib_path, &n, | ||
37 | force)) | ||
38 | break; | ||
39 | @@ -871,6 +873,8 @@ | ||
40 | rpath = command_line.rpath; | ||
41 | if (rpath == NULL) | ||
42 | rpath = (const char *) getenv ("LD_RUN_PATH"); | ||
43 | + if ((rpath) && (strlen (rpath) == 0)) | ||
44 | + rpath = NULL; | ||
45 | if (! (bfd_elf_size_dynamic_sections | ||
46 | (output_bfd, command_line.soname, rpath, | ||
47 | command_line.filter_shlib, | ||
diff --git a/meta/packages/binutils/binutils-2.16.91.0.7/binutils-uclibc-400-mips-ELF_MAXPAGESIZE-4K.patch b/meta/packages/binutils/binutils-2.16.91.0.7/binutils-uclibc-400-mips-ELF_MAXPAGESIZE-4K.patch new file mode 100644 index 0000000000..5959c718d2 --- /dev/null +++ b/meta/packages/binutils/binutils-2.16.91.0.7/binutils-uclibc-400-mips-ELF_MAXPAGESIZE-4K.patch | |||
@@ -0,0 +1,26 @@ | |||
1 | --- binutils/bfd/elf32-mips.c~ | ||
2 | +++ binutils/bfd/elf32-mips.c | ||
3 | @@ -1613,7 +1613,9 @@ | ||
4 | |||
5 | /* The SVR4 MIPS ABI says that this should be 0x10000, and Linux uses | ||
6 | page sizes of up to that limit, so we need to respect it. */ | ||
7 | -#define ELF_MAXPAGESIZE 0x10000 | ||
8 | +/*#define ELF_MAXPAGESIZE 0x10000*/ | ||
9 | +/* Use 4K to shrink the elf header. NOT for general use! */ | ||
10 | +#define ELF_MAXPAGESIZE 0x1000 | ||
11 | #define elf32_bed elf32_tradbed | ||
12 | |||
13 | /* Include the target file again for this target. */ | ||
14 | --- binutils/bfd/elfn32-mips.c~ | ||
15 | +++ binutils/bfd/elfn32-mips.c | ||
16 | @@ -2399,7 +2399,9 @@ | ||
17 | |||
18 | /* The SVR4 MIPS ABI says that this should be 0x10000, and Linux uses | ||
19 | page sizes of up to that limit, so we need to respect it. */ | ||
20 | -#define ELF_MAXPAGESIZE 0x10000 | ||
21 | +/*#define ELF_MAXPAGESIZE 0x10000*/ | ||
22 | +/* Use 4K to shrink the elf header. NOT for general use! */ | ||
23 | +#define ELF_MAXPAGESIZE 0x1000 | ||
24 | #define elf32_bed elf32_tradbed | ||
25 | |||
26 | /* Include the target file again for this target. */ | ||
diff --git a/meta/packages/binutils/binutils-2.16.91.0.7/binutils-uclibc-702-binutils-skip-comments.patch b/meta/packages/binutils/binutils-2.16.91.0.7/binutils-uclibc-702-binutils-skip-comments.patch new file mode 100644 index 0000000000..9ef7a7c9ec --- /dev/null +++ b/meta/packages/binutils/binutils-2.16.91.0.7/binutils-uclibc-702-binutils-skip-comments.patch | |||
@@ -0,0 +1,93 @@ | |||
1 | Retrieved from http://sources.redhat.com/ml/binutils/2004-04/msg00646.html | ||
2 | Fixes | ||
3 | localealias.s:544: Error: junk at end of line, first unrecognized character is `,' | ||
4 | when building glibc-2.3.2 with gcc-3.4.0 and binutils-2.15.90.0.3 | ||
5 | |||
6 | Paths adjusted to match crosstool's patcher. | ||
7 | |||
8 | Message-Id: m3n052qw2g.fsf@whitebox.m5r.de | ||
9 | From: Andreas Schwab <schwab at suse dot de> | ||
10 | To: Nathan Sidwell <nathan at codesourcery dot com> | ||
11 | Cc: Ian Lance Taylor <ian at wasabisystems dot com>, binutils at sources dot redhat dot com | ||
12 | Date: Fri, 23 Apr 2004 22:27:19 +0200 | ||
13 | Subject: Re: demand_empty_rest_of_line and ignore_rest_of_line | ||
14 | |||
15 | Nathan Sidwell <nathan@codesourcery.com> writes: | ||
16 | |||
17 | > Index: read.c | ||
18 | > =================================================================== | ||
19 | > RCS file: /cvs/src/src/gas/read.c,v | ||
20 | > retrieving revision 1.76 | ||
21 | > diff -c -3 -p -r1.76 read.c | ||
22 | > *** read.c 12 Mar 2004 17:48:12 -0000 1.76 | ||
23 | > --- read.c 18 Mar 2004 09:56:05 -0000 | ||
24 | > *************** read_a_source_file (char *name) | ||
25 | > *** 1053,1059 **** | ||
26 | > #endif | ||
27 | > input_line_pointer--; | ||
28 | > /* Report unknown char as ignored. */ | ||
29 | > ! ignore_rest_of_line (); | ||
30 | > } | ||
31 | > | ||
32 | > #ifdef md_after_pass_hook | ||
33 | > --- 1053,1059 ---- | ||
34 | > #endif | ||
35 | > input_line_pointer--; | ||
36 | > /* Report unknown char as ignored. */ | ||
37 | > ! demand_empty_rest_of_line (); | ||
38 | > } | ||
39 | > | ||
40 | > #ifdef md_after_pass_hook | ||
41 | |||
42 | This means that the unknown character is no longer ignored, despite the | ||
43 | comment. As a side effect a line starting with a line comment character | ||
44 | not followed by APP in NO_APP mode now triggers an error instead of just a | ||
45 | warning, breaking builds of glibc on m68k-linux. Earlier in | ||
46 | read_a_source_file where #APP is handled there is another comment that | ||
47 | claims that unknown comments are ignored, when in fact they aren't (only | ||
48 | the initial line comment character is skipped). | ||
49 | |||
50 | Note that the presence of #APP will mess up the line counters, but | ||
51 | that appears to be difficult to fix. | ||
52 | |||
53 | Andreas. | ||
54 | |||
55 | 2004-04-23 Andreas Schwab <schwab@suse.de> | ||
56 | |||
57 | * read.c (read_a_source_file): Ignore unknown text after line | ||
58 | comment character. Fix misleading comment. | ||
59 | |||
60 | --- binutils/gas/read.c.~1.78.~ 2004-04-23 08:58:23.000000000 +0200 | ||
61 | +++ binutils/gas/read.c 2004-04-23 21:49:01.000000000 +0200 | ||
62 | @@ -950,10 +950,14 @@ read_a_source_file (char *name) | ||
63 | unsigned int new_length; | ||
64 | char *tmp_buf = 0; | ||
65 | |||
66 | - bump_line_counters (); | ||
67 | s = input_line_pointer; | ||
68 | if (strncmp (s, "APP\n", 4)) | ||
69 | - continue; /* We ignore it */ | ||
70 | + { | ||
71 | + /* We ignore it */ | ||
72 | + ignore_rest_of_line (); | ||
73 | + continue; | ||
74 | + } | ||
75 | + bump_line_counters (); | ||
76 | s += 4; | ||
77 | |||
78 | sb_new (&sbuf); | ||
79 | @@ -1052,7 +1056,7 @@ read_a_source_file (char *name) | ||
80 | continue; | ||
81 | #endif | ||
82 | input_line_pointer--; | ||
83 | - /* Report unknown char as ignored. */ | ||
84 | + /* Report unknown char as error. */ | ||
85 | demand_empty_rest_of_line (); | ||
86 | } | ||
87 | |||
88 | |||
89 | -- | ||
90 | Andreas Schwab, SuSE Labs, schwab@suse.de | ||
91 | SuSE Linux AG, MaxfeldstraÃe 5, 90409 NÃrnberg, Germany | ||
92 | Key fingerprint = 58CA 54C7 6D53 942B 1756 01D3 44D5 214B 8276 4ED5 | ||
93 | "And now for something completely different." | ||